Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TRiLeZ

Common TRiBot Loader Problems

Recommended Posts

 

This thread addresses common TRiBot Loader problems.

 

Problem: Gets stuck on updating substance.jar

Solution:

 

Problem: The TRiBot Loader says it was successful, but TRiBot does not show up

Solution:

You may need to remove the old versions of Java from your computer, or just remember to select the correct Java from the drop down menu.

 

Problem:

HnRmR.jpg

Solution:

  • This error means that Java 6 was used to boot TRiBot. TRiBot is not compatible with Java 6. You may have the latest version of Java installed on your system, but the problem is that you are selecting Java 6 for use. You must select Java 8 or 7 in the drop down menu of the TRiBot Loader. I also recommend that you uninstall all of the old versions of Java from your computer, and install Java 8 from here: http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

 

 

mine loads and then tribot just completely shuts down.

Share this post


Link to post
Share on other sites

Describe the problem: Whenever I try to run TRiBot_Loader.jar, it tells me Java™ Platform SE Binary is not responding. 


Operating system (Mac OSX, Windows 7, etc): Windows 10


Was it working at an earlier time? (Yes/No): Yes


If yes:


Approximately when was it working last?: Two days


What changed?: Nothing I can think of 


What steps can be taken to replicate the issue?: It happens 100% of the time


Screenshots (if relevant): http://imgur.com/T8uqBjA


Bot/Client debug (if relevant):


What steps have been taken by you/others in an attempt to solve the problem?: Factory reset of laptop, change of operating system, many attempts at running different versions of java. Whenever I run java 7 it actually opens to the log in, but when I log in it tells me I need to upgrade, so this only seems to happen with java 8. 


Additional information (Provide as much as you can): Currently using JRE-8u72-64bit Java, when trying to open in command prompt I was getting error message "Could not open/create prefs.............) http://imgur.com/xz08nVb .   Once I created a Prefs in my JavaSoft through Regedit, I get this  http://imgur.com/gMOKJ21 . I have had this issue for a few days and worked on it for hours. I don't know if its something obvious. I have tried every version of java I could find, and java 7 seemed to work at least to let me log in, but then said I needed 8, whenever I used 8 I never even got to the log in screen. I am really looking to get this resolved.  


Share this post


Link to post
Share on other sites

@Calgarypros 
I googled the error message to find these threads below.

It looks like either deleting your .appdata folder and/or upgrading your Java version will solve this.
Make sure that you are selecting the most up to date Java you have installed on the drop-down box on the tribot loader.
 

 

 

Share this post


Link to post
Share on other sites
On 7/30/2016 at 5:15 PM, EazyBaker said:

i have the last error and nothing im doing is working. tried deleting all java and reinstalled java8 did the same thing for older javas nothings working. please help

What error is that? Please post a picture.

 

1 hour ago, Firerisor said:

when i log in the client crashes

 

Capture.PNG

Is there anything being printed in the bot debug? What heap size are you using?

Share this post


Link to post
Share on other sites
19 hours ago, Mr unknown said:

I keep getting erros, something about cant load human mouse.
Heap size: 389

 - When running scripts they just keep walking and don't do nothing

These errors are usually not related!

Try deleting your general.ini and hooks.dat from the .tribot folder, and then restarting TRiBot twice :)

Share this post


Link to post
Share on other sites

I am using a Mac, have deleted all previous Java/ tribot loaders and installed java 8. 

 

Still getting the same problem (Tribot loader has finished its process, but some errors/ :Unsupported major minor version 51.0)  when loading tribot. Any suggestions for help?

Screen Shot 2017-01-03 at 12.03.11 PM.png

Edited by schwaba12

Share this post


Link to post
Share on other sites
2 hours ago, schwaba12 said:

I am using a Mac, have deleted all previous Java/ tribot loaders and installed java 8. 

 

Still getting the same problem (Tribot loader has finished its process, but some errors/ :Unsupported major minor version 51.0)  when loading tribot. Any suggestions for help?

Screen Shot 2017-01-03 at 12.03.11 PM.png

I believe that issue is related to an outdated Java version, so try updating that.

Alternatively follow this tutorial step-by-step, your problem should be fixed:
[Mac] How To: Resolve Most Problems With TRiBot [Pics]

Share this post


Link to post
Share on other sites

Hello iFluffee!

Funnily enough im here with Client troubles. since the update (yay!) whenever i click the New Client button it opens the RS screen, loads to 100% then crashes. Ive scrubbed my system of tribot, redownloaded from the website and am still having these errors. I can put up a screen grab of the start of the error dump file if you want?

im running Java 8, heap size 389, not old school.

Share this post


Link to post
Share on other sites
10 minutes ago, TsaanDM said:

Hello iFluffee!

Funnily enough im here with Client troubles. since the update (yay!) whenever i click the New Client button it opens the RS screen, loads to 100% then crashes. Ive scrubbed my system of tribot, redownloaded from the website and am still having these errors. I can put up a screen grab of the start of the error dump file if you want?

im running Java 8, heap size 389, not old school.

rs3 isn't supported.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 48 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 34 replies
    • This release will:

      Fix an issue where breaks would stop firing


      Fix Combat#getWildernessLevel, use dynamic search for text and cache ID for later calls


      Fix an NPE in the Combat API


      Fix Mouse#leaveGame bug where the mouse wouldn't actually leave the game screen
        • Like
      • 21 replies
    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Thanks
        • Like
      • 59 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×