Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

TRiLeZ

Common TRiBot Loader Problems

120 posts in this topic

this some1 still solved it??? i keep getting the java error... i have only the latest versions on my mac, older eversions al removed and keep getting the message ...

Share this post


Link to post
Share on other sites

I don't understand. Yes it has a problem but then it says its going to start. Then just closes out. Please help.

 

 

 

[11:41:31] Starting TRiBot Loader.
[11:41:32] TRiBot Loader Release 2.01 is up-to-date.
[11:41:32] Attempting to launch TRiBot.
[11:41:32] Java Exe: /Library/Java/JavaVirtualMachines/jdk1.7.0_21.jdk/Contents/Home/jre/bin/java ([7, 0, 21])
[11:41:33] Error occurred during initialization of VM
[11:41:33] java.lang.NoSuchMethodError: sun.reflect.Reflection.getCallerClass()Ljava/lang/Class;
[11:41:33] at java.lang.Class.getDeclaredField(Class.java:2015)
[11:41:33] at java.util.Hashtable.
(Hashtable.java:235)
[11:41:33] at java.lang.System.initializeSystemClass(System.java:1114)
[11:41:33] TRiBot SID: '264a8-WMNcYhV05YOQ2GgWlI

flDAgzYUqlgTHBv2A6nvHELiK8HIINdZ'.
[11:39:51] Click this text box to copy the SID to your clipboard.
[11:39:51] TRiBot Loader has finished it's process. TRiBot will now start.

Share this post


Link to post
Share on other sites

I don't understand. Yes it has a problem but then it says its going to start. Then just closes out. Please help.

 

 

 

[11:41:31] Starting TRiBot Loader.

[11:41:32] TRiBot Loader Release 2.01 is up-to-date.

[11:41:32] Attempting to launch TRiBot.

[11:41:32] Java Exe: /Library/Java/JavaVirtualMachines/jdk1.7.0_21.jdk/Contents/Home/jre/bin/java ([7, 0, 21])

[11:41:33] Error occurred during initialization of VM

[11:41:33] java.lang.NoSuchMethodError: sun.reflect.Reflection.getCallerClass()Ljava/lang/Class;

[11:41:33] at java.lang.Class.getDeclaredField(Class.java:2015)

[11:41:33] at java.util.Hashtable.(Hashtable.java:235)

[11:41:33] at java.lang.System.initializeSystemClass(System.java:1114)

[11:41:33] TRiBot SID: '264a8-WMNcYhV05YOQ2GgWlI

flDAgzYUqlgTHBv2A6nvHELiK8HIINdZ'.

[11:39:51] Click this text box to copy the SID to your clipboard.

[11:39:51] TRiBot Loader has finished it's process. TRiBot will now start.

 

You must update your Java.

Share this post


Link to post
Share on other sites

Having similar issues as above, I have updated to Java 8 update 25, removed all older versions, even double and triple checked for older versions and checked for older versions on the java website, cleared dependencies and still I get the same issue with the client just not opening. I just re-downloaded tribot after 300 days of not playing RS.

 

screenshot: 23mxaft.jpg

Share this post


Link to post
Share on other sites

I updated my java to update 8u25 and TRiBot doesn't seem to support it. As stated above multiple times, it's having trouble with the VM allocations.

Share this post


Link to post
Share on other sites

[23:29:51] Starting TRiBot Loader.
[23:29:52] TRiBot Loader Release 2.01 is up-to-date.
[23:29:52] Attempting to launch TRiBot.
[23:29:52] Java Exe: /Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home/jre/bin/java ([7, 0, 45])
[23:29:53] TRiBot SID: '918d-RgI2fgI6C0hrRmsx7lQ yl38m4XCEUiBcvSSIcWVqoytJj1Aj'.
[23:29:53] Click this text box to copy the SID to your clipboard.
[23:29:53] TRiBot Loader has finished it's process. TRiBot will now start.

[23:29:53] CONSOLE STARTED
[23:29:53] TRiBot Release 9.211_0
[23:29:53] java.util.MissingResourceException: Can't find bundle for base name sun.text.resources.FormatData, locale en_JO
[23:29:53] Initial Settings Loaded
[23:29:53] at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)
[23:29:53] Using SID: 918d-RgI2fgI6C0hrRmsx7lQyl38m4XCEUiBcvSSIcWVqoytJj1Aj
[23:29:53] at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)
[23:29:53] at java.util.ResourceBundle.getBundle(ResourceBundle.java:841)
[23:29:53] at sun.util.resources.LocaleData$1.run(LocaleData.java:142)
[23:29:53] at sun.util.resources.LocaleData$1.run(LocaleData.java:140)
[23:29:53] at java.security.AccessController.doPrivileged(Native Method)
[23:29:53] at sun.util.resources.LocaleData.getBundle(LocaleData.java:140)
[23:29:53] at sun.util.resources.LocaleData.getNumberFormatData(LocaleData.java:136)
[23:29:53] at java.text.DecimalFormatSymbols.initialize(DecimalFormatSymbols.java:540)
[23:29:53] at java.text.DecimalFormatSymbols.(DecimalFormatSymbols.java:94)
[23:29:53] at java.text.DecimalFormatSymbols.getInstance(DecimalFormatSymbols.java:157)
[23:29:53] at java.util.Formatter.getZero(Formatter.java:2251)
[23:29:53] at java.util.Formatter.(Formatter.java:1877)
[23:29:53] at java.util.Formatter.(Formatter.java:1912)
[23:29:53] at org.tribot.util.Util.B(dc:363)
[23:29:53] at org.tribot.util.Util.getMACAddress(dc:525)
[23:29:53] at obf.qj.(yn:158)
[23:29:53] at obf.Tk.run(xm:900)
[23:29:53] at java.lang.Thread.run(Thread.java:744)
[23:29:53] Caused by: java.lang.UnsatisfiedLinkError: java.lang.Class.getCheckMemberAccessMethod(Ljava/lang/Class;)Ljava/lang/reflect/Method;
[23:29:53] at java.lang.Class.getCheckMemberAccessMethod(Native Method)
[23:29:53] at java.lang.Class.access$0(Class.java:2359)
[23:29:53] at java.lang.Class$SecurityManagerHelper.(Class.java:2320)
[23:29:53] at java.lang.Class.isCheckMemberAccessOverridden(Class.java:2340)
[23:29:53] at java.lang.Class.checkMemberAccess(Class.java:2377)
[23:29:53] at java.lang.Class.newInstance(Class.java:345)
[23:29:53] at java.util.ResourceBundle$Control.newBundle(ResourceBundle.java:2572)
[23:29:53] at java.util.ResourceBundle.loadBundle(ResourceBundle.java:1436)
[23:29:53] at java.util.ResourceBundle.findBundle(ResourceBundle.java:1400)
[23:29:53] at java.util.ResourceBundle.findBundle(ResourceBundle.java:1354)
[23:29:53] at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1296)
[23:29:53] ... 17 more
[23:29:53] java.util.MissingResourceException: Can't find bundle for base name sun.text.resources.FormatData, locale en_JO
[23:29:53] at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)
[23:29:53] at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)
[23:29:54] at java.util.ResourceBundle.getBundle(ResourceBundle.java:841)
[23:29:54] at sun.util.resources.LocaleData$1.run(LocaleData.java:142)
[23:29:54] at sun.util.resources.LocaleData$1.run(LocaleData.java:140)
[23:29:54] at java.security.AccessController.doPrivileged(Native Method)
[23:29:54] at sun.util.resources.LocaleData.getBundle(LocaleData.java:140)
[23:29:54] at sun.util.resources.LocaleData.getNumberFormatData(LocaleData.java:136)
[23:29:54] at java.text.DecimalFormatSymbols.initialize(DecimalFormatSymbols.java:540)
[23:29:54] at java.text.DecimalFormatSymbols.(DecimalFormatSymbols.java:94)
[23:29:54] at java.text.DecimalFormatSymbols.getInstance(DecimalFormatSymbols.java:157)
[23:29:54] at java.util.Formatter.getZero(Formatter.java:2251)
[23:29:54] at java.util.Formatter.(Formatter.java:1877)
[23:29:54] at java.util.Formatter.(Formatter.java:1912)
[23:29:54] at org.tribot.util.Util.B(dc:369)
[23:29:54] at org.tribot.util.Util.getMACAddress(dc:525)
[23:29:54] at obf.qj.(yn:158)
[23:29:54] at obf.Tk.run(xm:900)
[23:29:54] at java.lang.Thread.run(Thread.java:744)
[23:29:54] java.util.MissingResourceException: Can't find bundle for base name sun.text.resources.FormatData, locale en_JO
[23:29:54] at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)
[23:29:54] at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)
[23:29:54] at java.util.ResourceBundle.getBundle(ResourceBundle.java:841)
[23:29:54] at sun.util.resources.LocaleData$1.run(LocaleData.java:142)
[23:29:54] at sun.util.resources.LocaleData$1.run(LocaleData.java:140)
[23:29:54] at java.security.AccessController.doPrivileged(Native Method)
[23:29:54] at sun.util.resources.LocaleData.getBundle(LocaleData.java:140)
[23:29:54] at sun.util.resources.LocaleData.getNumberFormatData(LocaleData.java:136)
[23:29:54] at java.text.DecimalFormatSymbols.initialize(DecimalFormatSymbols.java:540)
[23:29:54] at java.text.DecimalFormatSymbols.(DecimalFormatSymbols.java:94)
[23:29:54] at java.text.DecimalFormatSymbols.getInstance(DecimalFormatSymbols.java:157)
[23:29:54] at java.util.Formatter.getZero(Formatter.java:2251)
[23:29:54] at java.util.Formatter.(Formatter.java:1877)
[23:29:54] at java.util.Formatter.(Formatter.java:1912)
[23:29:54] at org.tribot.util.Util.B(dc:587)
[23:29:54] at org.tribot.util.Util.getMACAddress(dc:525)
[23:29:55] at obf.qj.(yn:158)
[23:29:55] at obf.Tk.run(xm:900)
[23:29:55] at java.lang.Thread.run(Thread.java:744)
[23:29:55] java.util.MissingResourceException: Can't find bundle for base name sun.text.resources.FormatData, locale en_JO
[23:29:55] at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)
[23:29:55] at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)
[23:29:55] at java.util.ResourceBundle.getBundle(ResourceBundle.java:841)
[23:29:55] at sun.util.resources.LocaleData$1.run(LocaleData.java:142)
[23:29:55] at sun.util.resources.LocaleData$1.run(LocaleData.java:140)
[23:29:55] at java.security.AccessController.doPrivileged(Native Method)
[23:29:55] at sun.util.resources.LocaleData.getBundle(LocaleData.java:140)
[23:29:55] at sun.util.resources.LocaleData.getNumberFormatData(LocaleData.java:136)
[23:29:55] at java.text.DecimalFormatSymbols.initialize(DecimalFormatSymbols.java:540)
[23:29:55] at java.text.DecimalFormatSymbols.(DecimalFormatSymbols.java:94)
[23:29:55] at java.text.DecimalFormatSymbols.getInstance(DecimalFormatSymbols.java:157)
[23:29:55] at java.util.Formatter.getZero(Formatter.java:2251)
[23:29:55] at java.util.Formatter.(Formatter.java:1877)
[23:29:55] at java.util.Formatter.(Formatter.java:1912)
[23:29:55] at org.tribot.util.Util.B(dc:674)
[23:29:55] at org.tribot.util.Util.getMACAddress(dc:525)
[23:29:55] at obf.qj.(yn:158)
[23:29:55] at obf.Tk.run(xm:900)
[23:29:55] at java.lang.Thread.run(Thread.java:744)
[23:29:55] Exception in thread "TSV" java.lang.ExceptionInInitializerError
[23:29:55] at obf.Tk.run(xm:900)
[23:29:55] at java.lang.Thread.run(Thread.java:744)
[23:29:55] Caused by: java.util.MissingResourceException: Can't find bundle for base name sun.text.resources.FormatData, locale en_JO
[23:29:55] at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1499)
[23:29:55] at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1322)
[23:29:55] at java.util.ResourceBundle.getBundle(ResourceBundle.java:841)
[23:29:55] at sun.util.resources.LocaleData$1.run(LocaleData.java:142)
[23:29:55] at sun.util.resources.LocaleData$1.run(LocaleData.java:140)
[23:29:55] at java.security.AccessController.doPrivileged(Native Method)
[23:29:55] at sun.util.resources.LocaleData.getBundle(LocaleData.java:140)
[23:29:56] at sun.util.resources.LocaleData.getNumberFormatData(LocaleData.java:136)
[23:29:56] at java.text.DecimalFormatSymbols.initialize(DecimalFormatSymbols.java:540)
[23:29:56] at java.text.DecimalFormatSymbols.(DecimalFormatSymbols.java:94)
[23:29:56] at java.text.DecimalFormatSymbols.getInstance(DecimalFormatSymbols.java:157)
[23:29:56] at java.util.Formatter.getZero(Formatter.java:2251)
[23:29:56] at java.util.Formatter.(Formatter.java:1877)
[23:29:56] at java.util.Formatter.(Formatter.java:1912)
[23:29:56] at org.tribot.util.Util.B(dc:329)
[23:29:56] at org.tribot.util.Util.getMACAddress(dc:525)
[23:29:56] at obf.qj.(yn:158)
[23:29:56] ... 2 more
[23:29:56] Exception in thread "main" java.lang.UnsatisfiedLinkError: java.lang.Class.getCheckMemberAccessMethod(Ljava/lang/Class;)Ljava/lang/reflect/Method;
[23:29:56] at java.lang.Class.getCheckMemberAccessMethod(Native Method)
[23:29:56] at java.lang.Class.access$0(Class.java:2359)
[23:29:56] at java.lang.Class$SecurityManagerHelper.(Class.java:2320)
[23:29:56] at java.lang.Class.isCheckMemberAccessOverridden(Class.java:2340)
[23:29:56] at java.lang.Class.checkMemberAccess(Class.java:2377)
[23:29:56] at java.lang.Class.newInstance(Class.java:345)
[23:29:56] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:221)
[23:29:56] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
[23:29:56] at java.security.AccessController.doPrivileged(Native Method)
[23:29:56] at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:206)
[23:29:56] at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
[23:29:56] at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
[23:29:56] at sun.security.jca.ProviderList.getService(ProviderList.java:330)
[23:29:56] at sun.security.jca.GetInstance.getInstance(GetInstance.java:157)
[23:29:56] at java.security.Security.getImpl(Security.java:695)
[23:29:56] at java.security.MessageDigest.getInstance(MessageDigest.java:159)
[23:29:56] at org.tribot.util.MD5Checksum.createChecksum(gc:163)
[23:29:56] at org.tribot.util.MD5Checksum.getMD5Checksum(gc:114)
[23:29:56] at org.tribot.TRiBot.(xm:136)
[23:29:56] at org.tribot.TRiBot.M(xm:876)
[23:29:56] at org.tribot.TRiBot.main(xm:902)

 

This is what comes up after I open tribot, it was working fine till about 5 minutes ago. What can I do to fix this?
P.S. I use a macbook pro

Edited by sami99

Share this post


Link to post
Share on other sites

To follow up on my previous post, I installed an OLDER version of java and now my client is working, clearly the client doesn't support Java 8 Update 25 yet.

Share this post


Link to post
Share on other sites

New versions of the TRiBot Loader have been released. It now works with Java 8u25 and 7u71.

Share this post


Link to post
Share on other sites

hey, i am having trouble starting tribot the loader works and says tribot is about to start then the loader box disapears and nothing happens i have deleted all the dependancies and tried to download the loader again but nothing works.... help?

1 person likes this

Share this post


Link to post
Share on other sites

I've removed all java tried with versijon 8.25 of java that didn't work i deleted it downloaded 7.1 java that didn't work. Please help

this is what it says:

Java.lang.nullPointerexception

at obf.ph.run (qe:721)

at java.lang.Thread.Run (Thread.Java:745)

please help

Share this post


Link to post
Share on other sites

Same issue with me, i get this screen and then it closes. Installed Java8u25 and Java7u71 and both still doesnt work. Deleted .tribot folder to redownload data and still doesnt work.

 

LWuj4jK.png

 

I set up heap sizes 512 mb and 1024 mb, and pointed all environmental varaiables to correct java directories, still without luck

 

@TriLez Pls help us!!

Share this post


Link to post
Share on other sites

I get the Loader has finished and i press new client but it shows RUNESCAPE loading 100% then it closes and disappears forever. I dont know what the problem is. Help?

Share this post


Link to post
Share on other sites

I get the Loader has finished and i press new client but it shows RUNESCAPE loading 100% then it closes and disappears forever. I dont know what the problem is. Help?

 

Got this problem too.

Share this post


Link to post
Share on other sites

how can i delete all files associated with tribot, so that when i download the loader it's like a fresh start?

 

Edit: or is there a way to get tribotv3.013 directly, cause the loader wont open at all.

Edited by avvid

Share this post


Link to post
Share on other sites

 

This thread addresses common TRiBot Loader problems.

 

Problem: Gets stuck on updating substance.jar

Solution:

 

Problem: The TRiBot Loader says it was successful, but TRiBot does not show up

Solution:

You may need to remove the old versions of Java from your computer, or just remember to select the correct Java from the drop down menu.

 

Problem:

HnRmR.jpg

Solution:

  • This error means that Java 6 was used to boot TRiBot. TRiBot is not compatible with Java 6. You may have the latest version of Java installed on your system, but the problem is that you are selecting Java 6 for use. You must select Java 8 or 7 in the drop down menu of the TRiBot Loader. I also recommend that you uninstall all of the old versions of Java from your computer, and install Java 8 from here: http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

 

 

 when i click on the dropdown list it just says "java" and doesnt give me any other options. how to fix?

Share this post


Link to post
Share on other sites

My problem I'm having is that I click to run a script and then it just said's downloading script,"tri ghoul fighter pro" but doesn't load. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.