Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
karlrais

WarriorGuildDefender [$10][85K XP/HR][100HR proggie][UPDATED FOR DRAGON DEFENDERS]

Recommended Posts

my bot is just stopping i have had over 15 hour proggies with it and now its just standing still right next to the animator for no reason whatsoever tried re running the script multiple times doesnt seem to work! 

 

i will try and keep it running overnight tonight if it doesn not work again i will keep you informed, was working fine just before tribot update?:l

Edited by lixo1994
  • Like 1

Share this post


Link to post
Share on other sites

Is it supposed to carry on killing the cyclops' after it has looted the required defender?

 

It will exit the armor room and then log out if required defenders are gathered.

 

 

Also I didn't realise you have to manually use the defender on the woman outside for the next one, could you make it so the bot does that itself? =)

 

No. All you have to do is re-enter the cyclopes room and the script does.

 

 

Also another issue; it appears that when you get a random while getting tokens from the armour animation game it solves it and just stands there doing nothing regardless of whether your armour is on the floor or in your inventory

 

This is new to me. What randoms are causing this? 

 

my bot is just stopping i have had over 15 hour proggies with it and now its just standing still right next to the animator for no reason whatsoever tried re running the script multiple times doesnt seem to work! 

 

i will try and keep it running overnight tonight if it doesn not work again i will keep you informed, was working fine just before tribot update?:l

 

A lot of people are reporting their scripts freezing few minutes in.. Trilez is probably working on it right now.

  • Like 1

Share this post


Link to post
Share on other sites

I just got a steel defender and it seemed to me that the script was going to continue killing cyclops' until it ran out of tokens, no sign of it exiting/reentering.

 

Edit: literally just got a black, will see if the script tries to exit and re enter

 

Not sure whether it did or didnt.. might have before I realised I got the black

 

EDIT: After last nights update to the bot client your script ran flawlessly all night. To all those considering: go for it, runs flawlessly, went to sleep on a black defender and woke up with 4 rune defenders!

Edited by KiiTz

Share this post


Link to post
Share on other sites

Updated the script v1.41

  • No longer terminates the script upon failed STRANGEBOX random
  • Double walk to safespot method (one upon failed random and other on overall end script method)
  • Login bot state is no longer set to false anywhere. Let's see if that sovles some mysterious issues

Share this post


Link to post
Share on other sites

Yes it seems that when fighting the mith armour guy he may get stuck behind the thing and it logs me out. maybe add a feature to where you run somewhere if not in combat after the mith guy comes out 

 

It keeps attack clicking the armor every ~3 seconds if not in combat.

 

EDIT: I just saw it myself gg hold on

Edited by karlrais

Share this post


Link to post
Share on other sites

After running an all nighter I noticed that script gets stuck banking sometimes, it won't scroll to the bottom of the bank it'll just enter this loop where it moves the cursor down and up repeatedly.

 

I have a failsafe for that. If bank is open for more than 20 seconds it closes it and tries again, however, you are not the first reporting this. I'll look into this. 

  • Like 1

Share this post


Link to post
Share on other sites

got stuck here http://puu.sh/7eMrX.jpg

anyways: suggest you to make the bot eat food after killing the animated armour

 

edit: make the bot click the animated armour if not exp gain within 20 sec or so :)

 

edit edit: bot didnt eat when under 80% health http://puu.sh/7eMx9.jpg

Edited by stanlyHD

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 8 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 26 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...