Jump to content
karlrais

WarriorGuildDefender [$10][85K XP/HR][100HR proggie][UPDATED FOR DRAGON DEFENDERS]

Recommended Posts

2 WHOLE sets? Well if you disconnect the armor will disappear, so it could be that. Can you check the console tab see if reconnected at any point during the night?

yeah 2 whole sets, no big deal but yeah ;p it happend yesterday so don't know how to look back? but whenever it happends again i will check it right away!

Share this post


Link to post
Share on other sites

yeah 2 whole sets, no big deal but yeah ;p it happend yesterday so don't know how to look back? but whenever it happends again i will check it right away!

 

Found it. It is a bug. This happens when armor is on ground and you get combat random. 

I'll fix soon, like tomorrow or so.

Share this post


Link to post
Share on other sites

Updated the script v1.25!

  • Now using Tribot's clicking for looting instead of my own, because it has become more accurate.
  • No longer waits for dead cyclops to disappear, will immediately attack next one if cyclops hp = 0. This only works if not burying bones. If loot drops and it already attacked next one then it'll turn back and pick up the loot.

Share this post


Link to post
Share on other sites

the paint tells me i have gained a huge amount of xp (total xp in that skill) when I start it. Its quite annoying since I cannot track my xp/hour rate.

this happends always to me when i start the script when im not logged in. but whenever i start it im logged in it counts just from the 0

Share this post


Link to post
Share on other sites

just bought this and it somehow managed to get outside the guild and it was stuck clicking the wall for the food shop and couldnt get inside of the guild, need to add so it knows when it has to get back inside

 

 

edit 1 -also bought food and didnt loot armor, lost it

 

edit 2 - saw evil chicken happen while killing armor, it completed random but the armor was still animated, when and bought more food then went to bank because no armor found in inventory (because it was animated) needs to be able to register your armor is still animated and to go back to it.

Edited by ohjaysimp

Share this post


Link to post
Share on other sites

just bought this and it somehow managed to get outside the guild and it was stuck clicking the wall for the food shop and couldnt get inside of the guild, need to add so it knows when it has to get back inside

 

 

edit 1 -also bought food and didnt loot armor, lost it

 

edit 2 - saw evil chicken happen while killing armor, it completed random but the armor was still animated, when and bought more food then went to bank because no armor found in inventory (because it was animated) needs to be able to register your armor is still animated and to go back to it.

Outside of the guild WTF? Must have been random solver trying to "escape" a random, it was added in the latest patch :s

 

It does lock on to your current animated armor target. I'll look into this see if I can find the bug.

 

Can you send me the random recording?

Share this post


Link to post
Share on other sites

Outside of the guild WTF? Must have been random solver trying to "escape" a random, it was added in the latest patch :s

 

It does lock on to your current animated armor target. I'll look into this see if I can find the bug.

 

Can you send me the random recording?

decided id give it a go overnight, and i lost over 1m in items and all my tokens.... refund?

 

hgs1bd0h9kanw8rg6hz.png

Share this post


Link to post
Share on other sites

Can you make the mouse click on whichever cyclop attacks you? Cause sometimes it would pick up the loot but run off to attack another cyclop and there would be one already attacking him. Thanks! OH also it would be nice to make the bot not attack the cyclops that is already being attacked?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
        • Thanks
        • Like
      • 87 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 27 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
        • Like
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
        • Like
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Like
      • 22 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×