Jump to content
karlrais

WarriorGuildDefender [$10][85K XP/HR][100HR proggie][UPDATED FOR DRAGON DEFENDERS]

Recommended Posts

Pushed update v1.22!

 

Now deposits coins if not using custom food and has potions or not using potions at all.

Deposit and withdraw are now in their correct intended order.

Now moves camera when going to pot shop or food store. This reduces misclicks while moving.

Updated the thread with exlpanation of GUI options.

 

Let me know ASAP if anything does not work as intended.

 

EDIT: I'll look into the paint minimizing thing. Perhaps we can get this option in the client?

Edited by karlrais

Share this post


Link to post
Share on other sites
[14:43:57] Script Started: WarriorGuildDefender.

[14:43:57] Error creating GUI!

[14:43:57] java.lang.NullPointerException

[14:43:57] at scripts.defender.WarriorGuildDefender.E(WarriorGuildDefender.java:261)

[14:43:57] at scripts.defender.WarriorGuildDefender.run(WarriorGuildDefender.java:201)

[14:43:57] at java.lang.Thread.run(Thread.java:744)

[14:43:57] Script Ended: WarriorGuildDefender.

Edited by jordi2222

Share this post


Link to post
Share on other sites

 

[14:43:57] Script Started: WarriorGuildDefender.
[14:43:57] Error creating GUI!
[14:43:57] java.lang.NullPointerException
[14:43:57] at scripts.defender.WarriorGuildDefender.E(WarriorGuildDefender.java:261)
[14:43:57] at scripts.defender.WarriorGuildDefender.run(WarriorGuildDefender.java:201)
[14:43:57] at java.lang.Thread.run(Thread.java:744)
[14:43:57] Script Ended: WarriorGuildDefender.

 

EDIT: nvm it's fixed. Linux problem.

Edited by karlrais

Share this post


Link to post
Share on other sites

heey sometimes the bot switches to attack while i started it with the mode on aggresive. it got me 67 attack :( thought it was safe to go to run it while sleeping xD haha but ow well lets get 70 attack now

You probably opened the GUI while it was set on attack that's why (the same thing was happening to me). You have to make sure that even BEFORE you open the GUI to start the script that you're set on Strength training. Good luck!

Share this post


Link to post
Share on other sites

Is killing armours the only way it gets tokens? I'm pretty sure shot-put is the best method of getting tokens.

 

 

shot put would be a great update to the script

 

True! But then again, using the armour room makes this script a really great combat xp trainer on top of its defender-getting ability. 

Share this post


Link to post
Share on other sites

You probably opened the GUI while it was set on attack that's why (the same thing was happening to me). You have to make sure that even BEFORE you open the GUI to start the script that you're set on Strength training. Good luck!

 

Fuck i knew this would backfire...

 

What do you want me to do? I can:

  • Remove the "failsafe"
  • Keep the failsafe and print message what stance is selected IN CAPS. I can't print what stat will be trained tho.
  • Leave it as it as. Maybe add extra warning to somewhere

Share this post


Link to post
Share on other sites

Meh I would just leave it as it is - maybe toss a message in the GUI that says "Make sure your desired combat stance is selected before you open GUI. Please close and make sure."

 

Anyways, script is running flawlessly for me. Just got my first rune defender! Thanks a ton man, excellent script making skills =)

Share this post


Link to post
Share on other sites

You probably opened the GUI while it was set on attack that's why (the same thing was happening to me). You have to make sure that even BEFORE you open the GUI to start the script that you're set on Strength training. Good luck!

nopee im sure it was on agresive but lets see what happens this night :> bot got me already 70 attack now xD and for sure its flawless!

Share this post


Link to post
Share on other sites

I left it running for 3 hours and it didnt pick up a defender.

 

I still have to get bronze :P

 

What am i doing wrong:?

 

What do you mean it didn't pick up defender? It killed cyclopes but you found no defenders? 

 

3h is nothing really. I have had longer sessions with no defender drops.

Share this post


Link to post
Share on other sites

heey lost 2 mithril sets overnight, i do not know what causes it because i was at sleep. maybe you got any ideas? still going great for the rest :)

 

2 WHOLE sets? Well if you disconnect the armor will disappear, so it could be that. Can you check the console tab see if reconnected at any point during the night?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×