Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

Array
30 minutes ago, fjclyy said:

waiting for abc2 delay  to end ..Slow work   How to eliminate   ???

ABC2 delays are generated by Tribot's antiban. You can disable them in the script settings.

Go to Antiban --> ABC2 settings ("Disable ABC2 delays completely and use ABC1 delays instead"). You can also use the ABC2 modifier, -1 to -5 uses less delays.

Disable ABC2 delays or decrease the modifier at your own risk.

Edited by Aropupu

Share this post


Link to post
Share on other sites

Hi the bot works great but for some reason mine won't move the camera screen at all.

The option is enabled in settings and im running on looking glass mode with osbuddy and human mouse movement.

Also at the seers rooftops, the bot will 9 times out of 10 go past the bank (towards relekka road) when restarting the course which makes it look like a bot. Can you fix this?

thanks.

 

ps: i tried all the settings for camera movement and none of it worked.

Edited by man2

Share this post


Link to post
Share on other sites
4 hours ago, man2 said:

Hi the bot works great but for some reason mine won't move the camera screen at all.

The option is enabled in settings and im running on looking glass mode with osbuddy and human mouse movement.

Also at the seers rooftops, the bot will 9 times out of 10 go past the bank (towards relekka road) when restarting the course which makes it look like a bot. Can you fix this?

thanks.

 

ps: i tried all the settings for camera movement and none of it worked.

Camera movement is done by ABC2 at random times. I have no control over it. It uses random profiles so each account most likely does it at very different times if at all. The script itself only moves camera when it needs to.

Your seers rooftop problem is most likely caused by Antiban missclicks which I cannot fix. Tribot is responsible for all clicking. I think Tribot creates a profile for each account and some missclick more often and some don't at all. I can most likely add some sort of a failsafe for it but I need to know exactly where it clicks, how far it walks, where you end up etc. before I'm able to. 

There is also the possibility that your Tribot client is not working correctly (hooks are broken or something else). This could definitely cause all camera movement to not work. Please check the  Are you having problems with the script? part of the main post for the most common fixes to Tribot issues. I can confirm that camera movement works on Looking Glass at least while using a normal browser, just tested it. Most likely something is wrong on your end.

Share this post


Link to post
Share on other sites
14 minutes ago, Aropupu said:

Camera movement is done by ABC2 at random times. I have no control over it. It uses random profiles so each account most likely does it at very different times if at all. The script itself only moves camera when it needs to.

Your seers rooftop problem is most likely caused by Antiban missclicks which I cannot fix. Tribot is responsible for all clicking. I think Tribot creates a profile for each account and some missclick more often and some don't at all. I can most likely add some sort of a failsafe for it but I need to know exactly where it clicks, how far it walks, where you end up etc. before I'm able to. 

There is also the possibility that your Tribot client is not working correctly (hooks are broken or something else). This could definitely cause all camera movement to not work. Please check the  Are you having problems with the script? part of the main post for the most common fixes to Tribot issues. I can confirm that camera movement works on Looking Glass at least while using a normal browser, just tested it. Most likely something is wrong on your end.

Hey mate what the ban rate with this? + using LG

Share this post


Link to post
Share on other sites
28 minutes ago, Aropupu said:

Camera movement is done by ABC2 at random times. I have no control over it. It uses random profiles so each account most likely does it at very different times if at all. The script itself only moves camera when it needs to.

Your seers rooftop problem is most likely caused by Antiban missclicks which I cannot fix. Tribot is responsible for all clicking. I think Tribot creates a profile for each account and some missclick more often and some don't at all. I can most likely add some sort of a failsafe for it but I need to know exactly where it clicks, how far it walks, where you end up etc. before I'm able to. 

There is also the possibility that your Tribot client is not working correctly (hooks are broken or something else). This could definitely cause all camera movement to not work. Please check the  Are you having problems with the script? part of the main post for the most common fixes to Tribot issues. I can confirm that camera movement works on Looking Glass at least while using a normal browser, just tested it. Most likely something is wrong on your end.

It moves east of the bank a few steps on the road before clicking on the bank wall to climb

Share this post


Link to post
Share on other sites
5 hours ago, dantan said:

How come it doesn't rotate the camera the direction of the click ? It just stays where it is...

Without knowing when you are expecting it to move the camera, there's very little I can do or know what's wrong. Will send you a PM about it.

Edited by Aropupu

Share this post


Link to post
Share on other sites
7 hours ago, Str En Gt said:

Seems to be a problem with the camera turning, I've read the comments and others are experiencing the same issue, and as I've read it's not the script issue, hope it gets resolved soon :|

As I have said multiple times, camera movement is fully working. I cannot know what your problem is without any information and you also don't give me any information. Will send you a PM.

Edited by Aropupu

Share this post


Link to post
Share on other sites

Been having some problems with seers course, I was able to run fally 6+ hours with no errors, I've been trying to run seers on 3 occasions and It breaks inside of an hour, it could be due to connection, but I'll attempt to babysit and observe when it happens.

Share this post


Link to post
Share on other sites
26 minutes ago, Oteca said:

Been having some problems with seers course, I was able to run fally 6+ hours with no errors, I've been trying to run seers on 3 occasions and It breaks inside of an hour, it could be due to connection, but I'll attempt to babysit and observe when it happens.

Please check the client debug for any errors, messages etc.

Share this post


Link to post
Share on other sites
1 hour ago, Aropupu said:

Please check the client debug for any errors, messages etc.

  • [13:32:50] java.lang.IllegalArgumentException: Invalid range (Min: 1750000, Mean: 1738163, Max: 2000000).

this was the only thing I could find that didn't look normal; could not find those values anywhere when i started up the next round. 

 

  • [13:29:30] The script will now worldhop!
  • [13:32:50] java.lang.IllegalArgumentException: Invalid range (Min: 1750000, Mean: 1738163, Max: 2000000).
  • [13:32:50] at org.tribot.api.General.randomSD(fs:646)
  • [13:32:50] at scripts.aAgilityNEW.sb.f(AFKHandler.java:45)
  • [13:32:50] at scripts.aAgilityNEW.sb.B(AFKHandler.java:30)
  • [13:32:50] at scripts.aAgilityNEW.Main.m(Main.java:209)
  • [13:32:50] at scripts.aAgilityNEW.Main.f(Main.java:187)
  • [13:32:50] at scripts.aAgilityNEW.Main.G(Main.java:157)
  • [13:32:50] at scripts.aAgilityNEW.Main.run(Main.java:126)
  • [13:32:50] at java.lang.Thread.run(Unknown Source)
  • [13:32:53] Script Ended: aAgility [PREMIUM].
Edited by Oteca

Share this post


Link to post
Share on other sites
34 minutes ago, Oteca said:
  • [13:32:50] java.lang.IllegalArgumentException: Invalid range (Min: 1750000, Mean: 1738163, Max: 2000000).

this was the only thing I could find that didn't look normal; could not find those values anywhere when i started up the next round. 

This is caused by your AFK mode settings. Will send you a PM with questions.

Share this post


Link to post
Share on other sites
11 hours ago, michaelpwn said:

Bot stopped working today, it just keeps taking food from the bank and banking it again

The script is working without any issues (tested with several different eating options). Without any information from you about what settings you are using, what location etc. I cannot even begin to know what causes your issue. My guess would be that your Tribot client isn't working correctly. Please check the Are you having problems with the script? part of the main post which gives you the most common fixes to almost every Tribot issue.

Edited by Aropupu

Share this post


Link to post
Share on other sites
4 hours ago, andy9432 said:

Got a 2 day ban using this script, What a fkin joke.

You always take a risk when you bot. Many people have used this script without any issues.

The script is built in such a way that you can affect how it works a lot, which can possibly affect ban rate but there's no way to know what settings do and what don't if at all. There are too many factors that can cause bans that it's impossible to have 100% accurate information about what causes them so ban reports are usually quite useless.

You can report your ban properly here:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...