Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

On 12/26/2017 at 6:38 AM, Dj_Sammy said:

i dont think i've come across something bad since i started using this script
multiple accounts botted 1-80 agil with this script
and i just got my second account to 99 using this script only.
absolutely flawless
appreciate the work @Aropupu

Have you been botting low level accounts? I want to get 99 agil on my Obby mauler with 99 Fish.

Share this post


Link to post
Share on other sites
21 hours ago, Zopppo said:

Hey my aAgility V2 keeps crashing in Varock just after purchase... ive tried restarting the clients etc too :( Any ideas what it could be? It always does a few laps then crashes in the same spot!

This is usually caused by you using Looking Glass with the official osrs client. If this is the case, use OSBuddy instead. Looking Glass is in beta and has issues. Unfortunately it doesn't work well with the official runescape client.

If that isn't the issue and you are already using OSBuddy, please check the "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

If everything fails, you should copypaste the error information that stops the script. You can easily copypaste the entire client debug by doing the following:

DzdslQF.png

18 hours ago, nicholaszz said:

sorry for asking a noob question love your script trying premium planning to buy lifetime. Would love to level to 99 agi then get theiving. However how do you display an exp tracker, time elapse etc?

If the default paint is not working for you, go to Behavior --> Paint settings in script settings and change the paint.

Edited by Aropupu

Share this post


Link to post
Share on other sites

This time the script ran for a good 55 minutes before going crazy. Its been doing it with all my scripts so i added an example of another one in with the client debug. Generally once its stuffed up, it wont work again for ages :( Any idea of what this is or means?


[12:18:00] Starting client.
[12:18:13] Downloading script 'AlphaSmither Pro'.
[12:18:16] Script Started: AlphaSmither Pro.
[12:20:28] java.lang.NullPointerException
[12:20:28]     at scripts.alphascripts.c.r.j(MyWalking.java:48)
[12:20:28]     at scripts.alphascripts.c.r.j(MyWalking.java:41)
[12:20:28]     at scripts.alphascripts.c.r.j(MyWalking.java:139)
[12:20:28]     at scripts.alphascripts.utilities.walking.u.run(Walker.java:96)
[12:20:28]     at scripts.alphascripts.b.l.j(Employer.java:44)
[12:20:28]     at scripts.alphascripts.b.l.j(Employer.java:42)
[12:20:28]     at scripts.alphascripts.b.l.j(Employer.java:32)
[12:20:28]     at scripts.alphasmither.AlphaSmither.run(AlphaSmither.java:188)
[12:20:28]     at java.lang.Thread.run(Thread.java:748)
[12:20:32] Script Ended: AlphaSmither Pro.
[12:21:38] Downloading script 'aAgility v2'.
[12:21:41] Script Started: aAgility v2.
[12:21:51] Disabled all randoms.
[12:36:15] Script Ended: aAgility v2.
[12:40:39] Script Started: aAgility v2.
[12:40:40] Disabled all randoms.
[12:40:48] Script was paused using the pause button!
[13:30:26] java.lang.NullPointerException
[13:30:26]     at org.tribot.api2007.types.RSObject.getModel(oi:496)
[13:30:26]     at org.tribot.api2007.types.RSObject.isClickable(oi:522)
[13:30:26]     at scripts.aAgilityNEW.ab.j(ClickingMethods.java:77)
[13:30:26]     at scripts.aAgilityNEW.lb.M(Course.java:75)
[13:30:26]     at scripts.aAgilityNEW.Main.D(Main.java:179)
[13:30:26]     at scripts.aAgilityNEW.Main.run(Main.java:131)
[13:30:26]     at java.lang.Thread.run(Thread.java:748)
[13:30:31] Script Ended: aAgility v2.
[13:35:54] Script Started: aAgility v2.
[13:35:56] Disabled all randoms.
[13:35:59] java.lang.NullPointerException
[13:35:59]     at org.tribot.api2007.types.RSObject.getModel(oi:496)
[13:35:59]     at org.tribot.api2007.types.RSObject.isClickable(oi:522)
[13:35:59]     at scripts.aAgilityNEW.ab.j(ClickingMethods.java:77)
[13:35:59]     at scripts.aAgilityNEW.lb.M(Course.java:75)
[13:35:59]     at scripts.aAgilityNEW.Main.D(Main.java:179)
[13:35:59]     at scripts.aAgilityNEW.Main.run(Main.java:131)
[13:35:59]     at java.lang.Thread.run(Thread.java:748)
[13:35:59] Script Ended: aAgility v2.

Share this post


Link to post
Share on other sites
11 hours ago, Zopppo said:

This time the script ran for a good 55 minutes before going crazy. Its been doing it with all my scripts so i added an example of another one in with the client debug. Generally once its stuffed up, it wont work again for ages :( Any idea of what this is or means?
[13:35:59] java.lang.NullPointerException
[13:35:59]     at org.tribot.api2007.types.RSObject.getModel(oi:496)
[13:35:59]     at org.tribot.api2007.types.RSObject.isClickable(oi:522)
[13:35:59]     at scripts.aAgilityNEW.ab.j(ClickingMethods.java:77)
[13:35:59]     at scripts.aAgilityNEW.lb.M(Course.java:75)
[13:35:59]     at scripts.aAgilityNEW.Main.D(Main.java:179)
[13:35:59]     at scripts.aAgilityNEW.Main.run(Main.java:131)
[13:35:59]     at java.lang.Thread.run(Thread.java:748)
[13:35:59] Script Ended: aAgility v2.

Did you read my previous reply?

This is usually caused by you using the official OSRS client Looking Glass. Change to using OSBuddy if you haven't already and if you are even using Looking Glass. 

Either way this is a Tribot error having to do with Tribot methods. (org.tribot.api2007.types.RSObject.getModel(oi:496))

Share this post


Link to post
Share on other sites
1 hour ago, Aropupu said:

Did you read my previous reply?

This is usually caused by you using the official OSRS client Looking Glass. Change to using OSBuddy if you haven't already and if you are even using Looking Glass. 

Either way this is a Tribot error having to do with Tribot methods. (org.tribot.api2007.types.RSObject.getModel(oi:496))

I did but im honestly having a bit of trouble running it with OSB as the looking glass isnt picking up the client! Any tips on how to get that to work? Thanks for the replies by the way mate! Super happy with the script just stuck with this issue atm :( 

Share this post


Link to post
Share on other sites
38 minutes ago, Zopppo said:

I did but im honestly having a bit of trouble running it with OSB as the looking glass isnt picking up the client! Any tips on how to get that to work? Thanks for the replies by the way mate! Super happy with the script just stuck with this issue atm :( 

Check the "3. How to start using Looking Glass?" part of the above thread.

More solutions for looking glass problems: https://tribot.org/forums/topic/71758-looking-glass-issues/?tab=comments#comment-837486

 

I cannot help you more than these posts can. If you still continue to have problems, please post in the bot help section.

Share this post


Link to post
Share on other sites

I'm currently trying to use the script in seer's village, but when I activate the option to use tele tabs to teleport to camelot it will constantly left click slightly to the left of the tele tab rather than just right clicking it to teleport. I ran the script for 2 hours earlier and it worked flawlessly, I just purchased the 14 day use of it and now it is doing this. I cant even complete a single lap if I have "use tele tabs" option activated. 

Share this post


Link to post
Share on other sites
6 hours ago, pmbbrownie said:

I'm currently trying to use the script in seer's village, but when I activate the option to use tele tabs to teleport to camelot it will constantly left click slightly to the left of the tele tab rather than just right clicking it to teleport. I ran the script for 2 hours earlier and it worked flawlessly, I just purchased the 14 day use of it and now it is doing this. I cant even complete a single lap if I have "use tele tabs" option activated. 

Try runes? and check if you have the settings correct

Share this post


Link to post
Share on other sites
8 hours ago, pmbbrownie said:

I'm currently trying to use the script in seer's village, but when I activate the option to use tele tabs to teleport to camelot it will constantly left click slightly to the left of the tele tab rather than just right clicking it to teleport. I ran the script for 2 hours earlier and it worked flawlessly, I just purchased the 14 day use of it and now it is doing this. I cant even complete a single lap if I have "use tele tabs" option activated. 

Seers teleport seems to be working without any issues. Sound like you could be experiencing a client related issue based on what you are describing. Impossible to say without seeing it. Are you able to get a gif/video of it happening?

You should also try the steps in "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

1 hour ago, simongek said:

hi there

The script works good for me but ill get more exp in seers then in ardougne? how is that possible

I have no idea. Maybe if you gave me more information. xp/hr? client debug? settings? Also, look at how the script works. Is there anything going wrong?

Ardougne course is working without any issues right now.

You should also try the steps in "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

Share this post


Link to post
Share on other sites
7 hours ago, Aropupu said:

Seers teleport seems to be working without any issues. Sound like you could be experiencing a client related issue based on what you are describing. Impossible to say without seeing it. Are you able to get a gif/video of it happening?

You should also try the steps in "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

I have no idea. Maybe if you gave me more information. xp/hr? client debug? settings? Also, look at how the script works. Is there anything going wrong?

Ardougne course is working without any issues right now.

You should also try the steps in "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

Thanks

Share this post


Link to post
Share on other sites

Script doesn't work at canifis rooftop:

  • [16:43:33] java.lang.NullPointerException
  • [16:43:33] at org.tribot.api2007.types.RSObject.getModel(oi:496)
  • [16:43:33] at org.tribot.api2007.types.RSObject.isClickable(oi:522)
  • [16:43:33] at scripts.aAgilityNEW.cb.D(ClickingMethods.java:77)
  • [16:43:33] at scripts.aAgilityNEW.xb.h(Course.java:75)
  • [16:43:33] at scripts.aAgilityNEW.Main.h(Main.java:179)
  • [16:43:33] at scripts.aAgilityNEW.Main.run(Main.java:131)
  • [16:43:33] at java.lang.Thread.run(Thread.java:745)
  • [16:43:33] Script Ended: aAgility v2.

Share this post


Link to post
Share on other sites
On 26-12-2017 at 6:38 AM, Dj_Sammy said:

i dont think i've come across something bad since i started using this script
multiple accounts botted 1-80 agil with this script
and i just got my second account to 99 using this script only.
absolutely flawless
appreciate the work @Aropupu

could  you tell me your settings also?

Cheers mates

Share this post


Link to post
Share on other sites
7 hours ago, H3h3j0 said:

Script doesn't work at canifis rooftop:

  • [16:43:33] java.lang.NullPointerException
  • [16:43:33] at org.tribot.api2007.types.RSObject.getModel(oi:496)
  • [16:43:33] at org.tribot.api2007.types.RSObject.isClickable(oi:522)
  • [16:43:33] at scripts.aAgilityNEW.cb.D(ClickingMethods.java:77)
  • [16:43:33] at scripts.aAgilityNEW.xb.h(Course.java:75)
  • [16:43:33] at scripts.aAgilityNEW.Main.h(Main.java:179)
  • [16:43:33] at scripts.aAgilityNEW.Main.run(Main.java:131)
  • [16:43:33] at java.lang.Thread.run(Thread.java:745)
  • [16:43:33] Script Ended: aAgility v2.

confirmed

Share this post


Link to post
Share on other sites

Hey Aropuputhanks for this awesome script my dude! I plan on purchasing it very shortly after the trial runs out. 

If you do continue to update the script with new features, here are a couple things that you should consider:

Most accounts aren't going to have the Kandaran hard diaries done; therefore it may be helpful to implement more frequent and fluent alching while making the long run back from the end of the Seer's course to the beginning. Currently, the script alchs once during the run whereas a real player would be alching the majority of alchs per lap during this period. 

I personally can maintain 35k+agility exp/hr and 30k+magic exp/hr at the Seer's course without teleports. With settings that seemed to logically increase the speed of the bot, I had difficulty reaching these numbers. With the bot, I was able to get 29k agilty exp/hr and 20k magic exp/hr at the Seer's agility course. Perhaps I am at fault and am using settings that are less efficient than the bots capacity. 

Anyway, thanks again for taking the time to read/respond to community posts. 

Cheers,
P
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • [CONTEST ANNOUNCEMENT] 2019 Botter's Choice Awards
      2019 Botter’s Choice Awards

      To celebrate the launch of our TRiBot Official RuneScape Bot Blog,

      we’re doing a giveaway! 

      The TRiBot Official RuneScape Bot Blog: 

      Teaching you how to do more advanced botting, faster.
      Contest Details

      Prize: 3 winners will be selected to win 25 TRiBot credits.

      How to enter:

      Respond to this forum post by November 12th tagging the thread for: 

      Your favorite script

      Provide a brief explanation (1-2 sentences) why you think that script should be put in the top 5. 

      Who can enter?

      Botter’s who are not currently scripters. Sorry scripters, the people are going to vote. Your contest is here.

      The top 5 in each category will be showcased on our TRiBot Official RuneScape Bot Blog in a “People’s Choice” section and promoted across the TRiBot website. 

      -- Credits will be awarded based on thoughtfulness and humor -- 

      Bonus points

      Use a meme in your explanation. Because we all love memes.

      *no purchase necessary. Winners will be announced on Friday, November 15, 2019 at 4:00 p.m. on our News and Announcements forum. 

      -- Vote Below -- 
        • Like
      • 28 replies
    • [READ TO THE END FOR A TEASER]

      I've noticed some new TRiBotters have had some troubles finding out sources of how to do certain things, such as using advanced scripts and often get lost in the forums.

      We are still getting posts asking where to start, what to do, recommended scripts, etc. 

      As many of you know, I am new to the team, and had troubles myself learning how to bot, let alone script. 

      So, what our team decided to do was make it easier to learn how to bot, how to script, and just become an overall better botter and scripter faster. 

      As some of you might have seen, I've posted 3 new blogs, you can check it out by clicking on the following picture or here.


      These first 3 blogs are the first of many blogs that will be TRiBot official. They are encouraged to be challenged, improved upon and act as A Best Practices Guide for Botters.

      What information would you like to see in the blogs?

      👇 [TEASER] 👇

      .

      .

      .

      We are going to be hosting a  CONTEST  this  OCTOBER.

      Its scary to think how soon you'll find out.👻

      Stay tuned.


      - RileyZ
      • 8 replies
    • Today marks a big day for TRiBot! To make it easier for users to use TRiBot, we've created installers available for every platform! These installers are all bundled with the latest version of OpenJDK 1.8 (Java 😎, which is LG compatible.

      Using TRiBot is now easy. Simply download the installer for your platform, install TRiBot, and run it. The TRiBot Loader will correctly identify the bundled JDK so there's no need to change the Java selection.

      Windows

      EXE installer: TRiBot-windows-x64-4.0.3.exe


      MSI installer: TRiBot-windows-x64-4.0.3.msi


      Portable version: TRiBot-windows-x64-4.0.3.zip


      Mac OS

      Installer: TRiBot-macos-4.0.3.dmg


      Portable version: TRiBot-macos-4.0.3.tgz


      Unix/Linux

      Installer: TRiBot-unix-4.0.3.sh


      RPM installer (CentOS/Fedora): TRiBot-linux-4.0.3.rpm


      DEB installer (Debian): TRiBot-linux-4.0.3.deb


      Portable version: TRiBot-unix-4.0.3.tar.gz


      Platform Independent

      JAR file: tribot-loader-4.0.3.jar


      Note that this jar file does not include the bundled JDK.



      Windows and Mac OS users may notice a warning message stating that the installer/application is un-recognized or un-trusted. Please ignore this message and proceed with running the installer/application. We need to acquire a code signing certificate so that we can sign the installers letting the operating system know that these files can be trusted. It will take a week or more to acquire one, so please hold tight.

      Other notable changes to the TRiBot Loader:

      Support getting the version from OpenJDK distributions


      Add check for bundled JDK


      Copy OpenJDK tools.jar to the bundled JDK if not present


      Set the current java as the first available list entry


      Ignore Java versions which are symbolic links


      Make the bundled JDK the preferred Java version


      Update icon images


      Reduce the number of HTTP calls
        • Thanks
        • Like
      • 24 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 18 replies
    • Hello TRiBot,

      Today we have a significant release that has been in the works for the last month addressing several key issues, features and bugs in the backlog.

      With these changes, we are also including a new TRiBot Loader which will allow you to select any version that is released. This adds the flexibility of allowing you to revert to a previous version should an issue arise, run development only builds, view an accurate change log between versions etc. we are very proud to offer this feature and think it will add a lot more functionality down the road as we continue to release new versions.

      These changes include 80+ commits by our development team, a list of them is summarized below and also available for your viewing pleasure in the new TRiBot Loader.

      In addition, we have taken additional steps to improve as a development team by adding continuous integration and deployment into our workflow to assist in delivering timely releases such as bug fixes as well as new features on a weekly basis depending on our development cycle.
        • Thanks
        • Like
      • 39 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...