Jump to content
Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

1 hour ago, fearful65 said:

@Aropupu Hey, I am using the seers village teleport method with kandarin hard diary completed, and there is a glitch. It does not switch to magic spellbook menu all the time to click the teleport. Like there is probably antiban which makes the bot switch to skills menu sometimes and the mouse just tries to go to the position of where camelot teleport is but it is on the skills menu so it does not teleport and the mouse moves back and forth.

for example, if these were my stats, it sometimes is on skill menu and just moves moouse back and forth between cooking and thieving, does not click magic menu so it can teleport, it must think its on magic menu but is not.

Should be fixed in the latest version. Restart your script without using the rerun button.

Also, some people think that Jagex can ban you if you show your stats completely, because they could find your account that way. I don't think they bother with something like this, but if you do, you should get rid of that picture of your stats.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Aropupu said:

Should be fixed in the latest version. Restart your script without using the rerun button.

Also, some people think that Jagex can ban you if you show your stats completely, because they could find your account that way. I don't think they bother with something like this, but if you do, you should get rid of that picture of your stats.

I just googled rs 2007 stats lol or something, they are not my stats.

Share this post


Link to post
Share on other sites
1 hour ago, Norminton said:

So disabling ABC2 delays worked for alching, however when banking, the script will not re-withdraw your nature runes/item you want to alch (in my case, yew longbow)

Should be fixed in the latest version. Restart the script without using the rerun button.

If it's not fixed, I need to know exactly what settings you have enabled. (what the script is banking for)

Share this post


Link to post
Share on other sites
8 hours ago, shredly said:

bot spam right clicks at varrock might be new update not sure

You are not giving enough information for me to know what could be causing this issue for you (where does it right-click?). The script is currently be working without any issues. If you are using looking glass, it's most likely a looking glass bug. Please check the Are you having problems running the script? part in the main post

Edited by Aropupu

Share this post


Link to post
Share on other sites
9 minutes ago, iPiNkx said:

Doesn't do draynor

Draynor works without any issues at all.

Please check the  Are you having problems with the script? part of the main post. There are steps there that fix most if not all Tribot issues. Also, please check the client debug for any information that could tell what's causing this for you

Share this post


Link to post
Share on other sites
1 minute ago, stonedsmurf1 said:

Fally course didnt work.

Error: Negative file size for archive 6. and bunch of numbers-

Tribot error. Script is working without any issues.

Please check the  Are you having problems with the script? part of the main post. There are steps there that fix most if not all Tribot issues.

Share this post


Link to post
Share on other sites
4 minutes ago, Aropupu said:

Tribot error. Script is working without any issues.

Please check the  Are you having problems with the script? part of the main post. There are steps there that fix most if not all Tribot issues.

thanks for letting me know so quickly, works after I simply restarted tribot client.

  • Like 1

Share this post


Link to post
Share on other sites

On progressive leveling, it does walk to fally, but it will stop when it gets there.

 

[13:33:40] Starting client.
[13:34:44] Downloading script 'aAgility [Premium]'.
[13:34:45] Script Started: aAgility [Premium].
[13:34:47] Autoleveling is enabled. Following courses are disabled: 
[13:34:47] Your level is: 44
[13:34:47] Canifis is disabled in your autoleveling settings! Choosing next best course!
[13:34:47] Best course for your level is Varrock Rooftop
[13:34:47] Disabled all randoms.
[13:34:47] Generating script antiban profile...
[13:34:49] Antiban profile successfully generated!
[17:38:12] XP failsafe is now disabled before breaking.
[17:38:12] Break Handler: Taking a break for: 
[18:16:08] Break Handler: Break ended.
[18:16:08] XP failsafe is now enabled after breaking.
[18:16:09] Login bot started.
[18:16:09] Login Bot: Login...
[18:16:10] Login bot succeeded.
[19:18:29] Progress report:
[19:18:29] Location: Varrock Rooftop
[19:18:29] Gained levels: 5
[19:18:29] XP achieved: 45320
[19:18:29] XP/hour: 7912
[19:18:29] Total runtime: 05:43:39
[19:18:29] Reached level 50! Changing to Falador course!
[19:21:50] The script didn't gain any xp in 3 minutes. Logging out!
[19:21:50] If you think this was an error, you can disable this in the settings! (Behavior -> Random settings)
[19:21:50] Position: (3032, 3342, 0)
[19:21:50] Progress report:
[19:21:50] Location: Falador Rooftop
[19:21:50] Gained levels: 6
[19:21:50] XP achieved: 45320
[19:21:50] XP/hour: 7835
[19:21:50] Total runtime: 05:47:01
[19:22:09] Script Ended: aAgility [Premium].
Quote
[13:33:23] TRiBot Release 9.303_4 loaded. (1.8.0_45:C:\Program Files (x86)\Java\jdk1.8.0_45\jre)
[13:33:23] Loading human mouse movement data.
[13:33:23] Could not load human mouse data. Reason: Human mouse data encryption key not found.
[17:38:12] java.io.IOException
[17:38:12] 	at c.t(c.java:51)
[17:38:12] 	at a.t(a.java:32)
[17:38:12] 	at ag.i(ag.java:2644)
[17:38:12] 	at ft.t(ft.java:58)
[17:38:12] 	at fw.q(fw.java:3987)
[17:38:12] 	at client.r(client.java:916)
[17:38:12] 	at eh.rz(eh.java:255)
[17:38:12] 	at eh.run(eh.java:234)
[17:38:12] 	at java.lang.Thread.run(Thread.java:745)
[18:16:08] Re-calc true

 

 

Share this post


Link to post
Share on other sites
10 hours ago, sanas elf said:

On progressive leveling, it does walk to fally, but it will stop when it gets there.

Are you botting on several accounts in the same Tribot window? This can cause issues because Tribot can get information from the other tabs in the same window. I will make some changes that should fix the issue but so far you are the only one who has this issue.

6 hours ago, Hazyyy said:

Would be cool if it would log out when it finishes 'stop after' settings or maybe an option for it. Also, I feel like it should always complete the lap. 

I can add this setting but you use it on your own risk. There is a chance that Tribot bugs out and the login bot prevents the script from stopping after logging out, which will result in an infinite login loop that will log you back in even though the script is already stopped. I think this usually happens with looking glass, but not that often. EDIT: Should be added now.

You can also use an infinite break to stop the script.

Use stop after laps if you want it to stop only after completing laps. It's normal for a human to also stop between laps sometimes if you just have to go at that time.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Aropupu said:

Are you botting on several accounts in the same Tribot window? This can cause issues because Tribot can get information from the other tabs in the same window. I will make some changes that should fix the issue but so far you are the only one who has this issue.

I am not, I am running two accounts in two different windows. It has the same problem when going to seers!

 

Share this post


Link to post
Share on other sites
2 hours ago, sanas elf said:

I am not, I am running two accounts in two different windows. It has the same problem when going to seers!

 

Try these steps:

- Make sure your roofs are toggled off in Runescape settings.
- Simply restarting your Tribot client can sometimes help too. Close all windows of Tribot and then restart it.
- If you are using LG with OSBuddy, try it with a normal browser instead.
- Make sure you have "Restart client on update" DISABLED in Tribot's settings. If it's enabled, it will cause problems after Runescape updates.

I have tested both travelling after autoleveling to seers course and falador course and they both work without any issues. I also made some changes in the latest version of the script that could fix the issue. Restart the script without using the rerun button to update it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 21 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
        • Like
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
        • Like
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Like
      • 22 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      [NEW] Bug fix for intelligent banking


      [NEW] Improvement to the stability of LG over time


      [NEW] Vastly improved the reliability and speed of Screen#getColorAt on both LG and the regular client


      [NEW] Fix LG login problems


      [NEW] Fixed re-sizable mode container bug


      [NEW] Fixed re-sizable mode mouse bug


      [NEW] Use of public constants in the Banking API


      [NEW] Use of other various constants such as Projection#NULL_PT and Screen#EMPTY_COLOR



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
        • Thanks
        • Like
      • 12 replies
  • Recently Browsing   1 member

×