Jump to content
Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

8 hours ago, shredly said:

bot spam right clicks at varrock might be new update not sure

You are not giving enough information for me to know what could be causing this issue for you (where does it right-click?). The script is currently be working without any issues. If you are using looking glass, it's most likely a looking glass bug. Please check the Are you having problems running the script? part in the main post

Edited by Aropupu

Share this post


Link to post
Share on other sites
9 minutes ago, iPiNkx said:

Doesn't do draynor

Draynor works without any issues at all.

Please check the  Are you having problems with the script? part of the main post. There are steps there that fix most if not all Tribot issues. Also, please check the client debug for any information that could tell what's causing this for you

Share this post


Link to post
Share on other sites
1 minute ago, stonedsmurf1 said:

Fally course didnt work.

Error: Negative file size for archive 6. and bunch of numbers-

Tribot error. Script is working without any issues.

Please check the  Are you having problems with the script? part of the main post. There are steps there that fix most if not all Tribot issues.

Share this post


Link to post
Share on other sites
4 minutes ago, Aropupu said:

Tribot error. Script is working without any issues.

Please check the  Are you having problems with the script? part of the main post. There are steps there that fix most if not all Tribot issues.

thanks for letting me know so quickly, works after I simply restarted tribot client.

  • Like 1

Share this post


Link to post
Share on other sites

On progressive leveling, it does walk to fally, but it will stop when it gets there.

 

[13:33:40] Starting client.
[13:34:44] Downloading script 'aAgility [Premium]'.
[13:34:45] Script Started: aAgility [Premium].
[13:34:47] Autoleveling is enabled. Following courses are disabled: 
[13:34:47] Your level is: 44
[13:34:47] Canifis is disabled in your autoleveling settings! Choosing next best course!
[13:34:47] Best course for your level is Varrock Rooftop
[13:34:47] Disabled all randoms.
[13:34:47] Generating script antiban profile...
[13:34:49] Antiban profile successfully generated!
[17:38:12] XP failsafe is now disabled before breaking.
[17:38:12] Break Handler: Taking a break for: 
[18:16:08] Break Handler: Break ended.
[18:16:08] XP failsafe is now enabled after breaking.
[18:16:09] Login bot started.
[18:16:09] Login Bot: Login...
[18:16:10] Login bot succeeded.
[19:18:29] Progress report:
[19:18:29] Location: Varrock Rooftop
[19:18:29] Gained levels: 5
[19:18:29] XP achieved: 45320
[19:18:29] XP/hour: 7912
[19:18:29] Total runtime: 05:43:39
[19:18:29] Reached level 50! Changing to Falador course!
[19:21:50] The script didn't gain any xp in 3 minutes. Logging out!
[19:21:50] If you think this was an error, you can disable this in the settings! (Behavior -> Random settings)
[19:21:50] Position: (3032, 3342, 0)
[19:21:50] Progress report:
[19:21:50] Location: Falador Rooftop
[19:21:50] Gained levels: 6
[19:21:50] XP achieved: 45320
[19:21:50] XP/hour: 7835
[19:21:50] Total runtime: 05:47:01
[19:22:09] Script Ended: aAgility [Premium].
Quote
[13:33:23] TRiBot Release 9.303_4 loaded. (1.8.0_45:C:\Program Files (x86)\Java\jdk1.8.0_45\jre)
[13:33:23] Loading human mouse movement data.
[13:33:23] Could not load human mouse data. Reason: Human mouse data encryption key not found.
[17:38:12] java.io.IOException
[17:38:12] 	at c.t(c.java:51)
[17:38:12] 	at a.t(a.java:32)
[17:38:12] 	at ag.i(ag.java:2644)
[17:38:12] 	at ft.t(ft.java:58)
[17:38:12] 	at fw.q(fw.java:3987)
[17:38:12] 	at client.r(client.java:916)
[17:38:12] 	at eh.rz(eh.java:255)
[17:38:12] 	at eh.run(eh.java:234)
[17:38:12] 	at java.lang.Thread.run(Thread.java:745)
[18:16:08] Re-calc true

 

 

Share this post


Link to post
Share on other sites
10 hours ago, sanas elf said:

On progressive leveling, it does walk to fally, but it will stop when it gets there.

Are you botting on several accounts in the same Tribot window? This can cause issues because Tribot can get information from the other tabs in the same window. I will make some changes that should fix the issue but so far you are the only one who has this issue.

6 hours ago, Hazyyy said:

Would be cool if it would log out when it finishes 'stop after' settings or maybe an option for it. Also, I feel like it should always complete the lap. 

I can add this setting but you use it on your own risk. There is a chance that Tribot bugs out and the login bot prevents the script from stopping after logging out, which will result in an infinite login loop that will log you back in even though the script is already stopped. I think this usually happens with looking glass, but not that often. EDIT: Should be added now.

You can also use an infinite break to stop the script.

Use stop after laps if you want it to stop only after completing laps. It's normal for a human to also stop between laps sometimes if you just have to go at that time.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Aropupu said:

Are you botting on several accounts in the same Tribot window? This can cause issues because Tribot can get information from the other tabs in the same window. I will make some changes that should fix the issue but so far you are the only one who has this issue.

I am not, I am running two accounts in two different windows. It has the same problem when going to seers!

 

Share this post


Link to post
Share on other sites
2 hours ago, sanas elf said:

I am not, I am running two accounts in two different windows. It has the same problem when going to seers!

 

Try these steps:

- Make sure your roofs are toggled off in Runescape settings.
- Simply restarting your Tribot client can sometimes help too. Close all windows of Tribot and then restart it.
- If you are using LG with OSBuddy, try it with a normal browser instead.
- Make sure you have "Restart client on update" DISABLED in Tribot's settings. If it's enabled, it will cause problems after Runescape updates.

I have tested both travelling after autoleveling to seers course and falador course and they both work without any issues. I also made some changes in the latest version of the script that could fix the issue. Restart the script without using the rerun button to update it.

Share this post


Link to post
Share on other sites
15 hours ago, morbideraser said:

I clicked "enable eating" but noticed it hadn't eaten and it was almost at half HP. When does it eat?

ABC2 (Tribot's antiban) decides when your character eats. I have no control over it.

If you are using Automatic detection of food, you need to make sure that the food is actually detected when you start the script. It will print out "No food detected in inventory. The script will not eat anything!" in the client debug if the food was not detected. Sometimes Tribot hooks can be broken on your client, which means the script will not be able to detect the food correctly. Sometimes simply completely restarting your tribot client can fix this (close all windows and then restart), but sometimes you need to close your tribot client and then manually delete your hooks.dat file from your .tribot folder. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 30 replies
    • This release will:

      Fix an issue where breaks would stop firing


      Fix Combat#getWildernessLevel, use dynamic search for text and cache ID for later calls


      Fix an NPE in the Combat API


      Fix Mouse#leaveGame bug where the mouse wouldn't actually leave the game screen
        • thonking
      • 21 replies
    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 59 replies
    • This update will:

      Allow for clicking through the chat box when possible (Thanks @Todd)


      Fix Combat#selectIndex (Thanks @Encoded)


      Ensure worlds stay sorted and added a check to avoid misclicks in the in-game world hopper (Thanks @erickho123)


      Fix out-dated Options API interface indices (Thanks @Todd)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 12 replies
    • This release will:

      Fix login bot after today's game update (Thanks @JoeDezzy1)


      Fix latest in-game world hopping issues (Thanks @erickho123)


      Compact Settings UI and set location relative to TRiBot (Thanks @JoeDezzy1)


      Fix an older implementation of GrandExchange#getWindowState (Thanks @JoeDezzy1)


      Improve the preformance of NPCChat by only searching in certain interface parents (Thanks @JoeDezzy1)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      LG support for RuneLite


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 16 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×