Jump to content
Aropupu

[ABCL 10] [ABC2] aAgility v2 [ALL ROOFTOPS]

Recommended Posts

1 hour ago, fsujoseph said:

Is it normal for the bot to take a few seconds and pause on some parts of the rooftop courses?

Usually yes. They are most likely antiban delays generated by Tribot's ABC2. If they bother you, you should try disabling ABC2 delays in the settings of the script.

Edited by Aropupu

Share this post


Link to post
Share on other sites

idk if this is the scipt or client but i get this after running the scipt for 5 mins or so 

  • [12:22:45] Script Started: aAgility [Premium].
  • [12:22:53] Disabled all randoms.
  • [12:22:53] Generating script antiban profile...
  • [12:22:55] Antiban profile successfully generated!
  • [12:33:47] java.lang.NullPointerException
  • [12:33:47] at org.tribot.api2007.types.RSObject.getModel(om:583)
  • [12:33:47] at org.tribot.api2007.types.RSObject.isClickable(om:223)
  • [12:33:47] at scripts.aAgilityNEW.yb.m(ClickingMethods.java:512)
  • [12:33:47] at scripts.aAgilityNEW.yb.H(ClickingMethods.java:361)
  • [12:33:47] at scripts.aAgilityNEW.yb.h(ClickingMethods.java:173)
  • [12:33:47] at scripts.aAgilityNEW.yb.H(ClickingMethods.java:79)
  • [12:33:47] at scripts.aAgilityNEW.mb.h(Course.java:64)
  • [12:33:47] at scripts.aAgilityNEW.Main.h(Main.java:176)
  • [12:33:47] at scripts.aAgilityNEW.Main.run(Main.java:133)
  • [12:33:47] at java.lang.Thread.run(Thread.java:745)
  • [12:33:50] Script Ended: aAgility [Premium].

 

 

Share this post


Link to post
Share on other sites
7 hours ago, user64 said:

idk if this is the scipt or client but i get this after running the scipt for 5 mins or so 

  • [12:22:45] Script Started: aAgility [Premium].
  • [12:22:53] Disabled all randoms.
  • [12:22:53] Generating script antiban profile...
  • [12:22:55] Antiban profile successfully generated!
  • [12:33:47] java.lang.NullPointerException
  • [12:33:47] at org.tribot.api2007.types.RSObject.getModel(om:583)
  • [12:33:47] at org.tribot.api2007.types.RSObject.isClickable(om:223)
  • [12:33:47] at scripts.aAgilityNEW.yb.m(ClickingMethods.java:512)
  • [12:33:47] at scripts.aAgilityNEW.yb.H(ClickingMethods.java:361)
  • [12:33:47] at scripts.aAgilityNEW.yb.h(ClickingMethods.java:173)
  • [12:33:47] at scripts.aAgilityNEW.yb.H(ClickingMethods.java:79)
  • [12:33:47] at scripts.aAgilityNEW.mb.h(Course.java:64)
  • [12:33:47] at scripts.aAgilityNEW.Main.h(Main.java:176)
  • [12:33:47] at scripts.aAgilityNEW.Main.run(Main.java:133)
  • [12:33:47] at java.lang.Thread.run(Thread.java:745)
  • [12:33:50] Script Ended: aAgility [Premium].

The NullPointerException happens in the getModel method, which is a Tribot API method. I unfortunately cannot fix Tribot methods. If it is a temporary Tribot issue like a hook problem, you should try the steps in "Are you having problems with the script?" part of the main post. Those steps usually fix any tribot issues that are on your end and not caused by errors in the client itself that Trilez has to fix.

Edited by Aropupu

Share this post


Link to post
Share on other sites
On 5/24/2016 at 2:03 PM, Aropupu said:

The NullPointerException happens in the getModel method, which is a Tribot API method. I unfortunately cannot fix Tribot methods. If it is a temporary Tribot issue like a hook problem, you should try the steps in "Are you having problems with the script?" part of the main post. Those steps usually fix any tribot issues that are on your end and not caused by errors in the client itself that Trilez has to fix.

Misread gunna try some other stuff

Tried deleting hook.dat didn't help then deleted tribot folder still no success.

Encoded fishing working though. shrug

Edited by Hazyyy
More info

Share this post


Link to post
Share on other sites
7 hours ago, Hazyyy said:

Misread gunna try some other stuff

Tried deleting hook.dat didn't help then deleted tribot folder still no success.

Encoded fishing working though. shrug

34 minutes ago, Yourigames said:

I've been having the same problem as the guy above me. Yesterday it was working fine, today, not. All other scripts are working fine...

The issue happens within a Tribot method. There is already a bug report about the issue. It could also be that only certain people are having the issue. The fact that some scripts work doesn't mean anything at all. If a script uses a method that uses getModel, it will cause the same issue. In this case isClickable uses getModel. These are all Tribot's methods and I cannot fix them.

Here is a client bug report about the issue: 

 

 

Share this post


Link to post
Share on other sites
3 hours ago, shredly said:

Is there something with my settings wrong, because every time I start script it instantly ends with no other warnings. Checked the rooftop setting so that's not in.

Check your client debug. Most likely a Tribot issue that needs to be fixed by Trilez.

It can also be a problem with hooks.  If the script doesn't do anything at all, your hooks could be broken, which can happen after a Runescape update. It's usually fixed by simply restarting your Tribot client several times. If restarting doesn't help, usually removing your hooks.dat from your .tribot folder does the trick. However, there are some bigger problems right now with the Tribot client itself so I'd advice waiting.

Share this post


Link to post
Share on other sites

have you considered adding an option to use Camelot teleport while doing Seer's Village Course? with Kandarin hard diary you can teleport to the center of Seer's via Camelot teleport, and if you teleport at the end of the course it speeds up the Course to make it the best to do up until level 90.

 

ps. awesome script regardless, love it!

Edited by varago

Share this post


Link to post
Share on other sites
11 hours ago, varago said:

have you considered adding an option to use Camelot teleport while doing Seer's Village Course? with Kandarin hard diary you can teleport to the center of Seer's via Camelot teleport, and if you teleport at the end of the course it speeds up the Course to make it the best to do up until level 90.

ps. awesome script regardless, love it!

This feature is already added. You can find it in Behavior --> Seers teleport

11 hours ago, SocialMercurai said:

Ive had to many beers, do I need to request v2? Or is it already added? If so no reply is necessary 

Already added.

Share this post


Link to post
Share on other sites
1 hour ago, Toofstah said:

Never really had any problems with this script until now - I'm getting the same error as a lot of people here @Aropupu not sure what to do really been like this for a few days now, any ETA on a fix? This is my main source of RSGP :< 

If you are using Looking Glass, it's currently broken and you need to wait for Trilez to fix it. Your options are to wait or to stop using Looking Glass.

If you are not using Looking Glass, you should give me more information. In this case usually hooks are broken and simply restarting your Tribot several times fixes it. If restarting doesn't fix it, usually deleting your hooks.dat file from your .tribot folder fixes it

Share this post


Link to post
Share on other sites
On 24-5-2016 at 2:42 PM, user64 said:

idk if this is the scipt or client but i get this after running the scipt for 5 mins or so 

  • [12:22:45] Script Started: aAgility [Premium].
  • [12:22:53] Disabled all randoms.
  • [12:22:53] Generating script antiban profile...
  • [12:22:55] Antiban profile successfully generated!
  • [12:33:47] java.lang.NullPointerException
  • [12:33:47] at org.tribot.api2007.types.RSObject.getModel(om:583)
  • [12:33:47] at org.tribot.api2007.types.RSObject.isClickable(om:223)
  • [12:33:47] at scripts.aAgilityNEW.yb.m(ClickingMethods.java:512)
  • [12:33:47] at scripts.aAgilityNEW.yb.H(ClickingMethods.java:361)
  • [12:33:47] at scripts.aAgilityNEW.yb.h(ClickingMethods.java:173)
  • [12:33:47] at scripts.aAgilityNEW.yb.H(ClickingMethods.java:79)
  • [12:33:47] at scripts.aAgilityNEW.mb.h(Course.java:64)
  • [12:33:47] at scripts.aAgilityNEW.Main.h(Main.java:176)
  • [12:33:47] at scripts.aAgilityNEW.Main.run(Main.java:133)
  • [12:33:47] at java.lang.Thread.run(Thread.java:745)
  • [12:33:50] Script Ended: aAgility [Premium].

 

 

I have the same problem :/ Almost no scripts are working atm.

Share this post


Link to post
Share on other sites

I notice that when the script goes to high alch, it'll click the spell and then wait/hover for about 1-7 seconds before alching and then returning to agility. I was excited about the alching feature but have since turned it off because of it's botlike behavior. Any word on looking into this?

Share this post


Link to post
Share on other sites
10 hours ago, Norminton said:

I notice that when the script goes to high alch, it'll click the spell and then wait/hover for about 1-7 seconds before alching and then returning to agility. I was excited about the alching feature but have since turned it off because of it's botlike behavior. Any word on looking into this?

You are not giving enough information for me to look into it. I need to know exactly when this happens. Does it happen right after finishing an obstacle? You also don't tell me anything about what kind of settings you have enabled/disabled. 

This is most likely caused by ABC2 delays so try disabling those in the antiban settings. 

Edited by Aropupu

Share this post


Link to post
Share on other sites

@Aropupu Hey, I am using the seers village teleport method with kandarin hard diary completed, and there is a glitch. It does not switch to magic spellbook menu all the time to click the teleport. Like there is probably antiban which makes the bot switch to skills menu sometimes and the mouse just tries to go to the position of where camelot teleport is but it is on the skills menu so it does not teleport and the mouse moves back and forth.

for example, if these were my stats, it sometimes is on skill menu and just moves moouse back and forth between cooking and thieving, does not click magic menu so it can teleport, it must think its on magic menu but is not.

XshinobizXstatss.png

Share this post


Link to post
Share on other sites
1 hour ago, fearful65 said:

@Aropupu Hey, I am using the seers village teleport method with kandarin hard diary completed, and there is a glitch. It does not switch to magic spellbook menu all the time to click the teleport. Like there is probably antiban which makes the bot switch to skills menu sometimes and the mouse just tries to go to the position of where camelot teleport is but it is on the skills menu so it does not teleport and the mouse moves back and forth.

for example, if these were my stats, it sometimes is on skill menu and just moves moouse back and forth between cooking and thieving, does not click magic menu so it can teleport, it must think its on magic menu but is not.

Should be fixed in the latest version. Restart your script without using the rerun button.

Also, some people think that Jagex can ban you if you show your stats completely, because they could find your account that way. I don't think they bother with something like this, but if you do, you should get rid of that picture of your stats.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Aropupu said:

Should be fixed in the latest version. Restart your script without using the rerun button.

Also, some people think that Jagex can ban you if you show your stats completely, because they could find your account that way. I don't think they bother with something like this, but if you do, you should get rid of that picture of your stats.

I just googled rs 2007 stats lol or something, they are not my stats.

Share this post


Link to post
Share on other sites
1 hour ago, Norminton said:

So disabling ABC2 delays worked for alching, however when banking, the script will not re-withdraw your nature runes/item you want to alch (in my case, yew longbow)

Should be fixed in the latest version. Restart the script without using the rerun button.

If it's not fixed, I need to know exactly what settings you have enabled. (what the script is banking for)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 30 replies
    • This release will:

      Fix an issue where breaks would stop firing


      Fix Combat#getWildernessLevel, use dynamic search for text and cache ID for later calls


      Fix an NPE in the Combat API


      Fix Mouse#leaveGame bug where the mouse wouldn't actually leave the game screen
        • Like
      • 21 replies
    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Thanks
        • Like
      • 59 replies
    • This update will:

      Allow for clicking through the chat box when possible (Thanks @Todd)


      Fix Combat#selectIndex (Thanks @Encoded)


      Ensure worlds stay sorted and added a check to avoid misclicks in the in-game world hopper (Thanks @erickho123)


      Fix out-dated Options API interface indices (Thanks @Todd)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 12 replies
    • This release will:

      Fix login bot after today's game update (Thanks @JoeDezzy1)


      Fix latest in-game world hopping issues (Thanks @erickho123)


      Compact Settings UI and set location relative to TRiBot (Thanks @JoeDezzy1)


      Fix an older implementation of GrandExchange#getWindowState (Thanks @JoeDezzy1)


      Improve the preformance of NPCChat by only searching in certain interface parents (Thanks @JoeDezzy1)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      LG support for RuneLite


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Thanks
        • Like
      • 16 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×