Jump to content
TRiLeZ

High CPU Usage Thread

Recommended Posts

Did you follow the guide linked above? Yes.

What is the CPU usage before you start a script? 3-6%

What is the CPU usage after you start a script? 50-80%

What script are you using? Relekka rock crabs PRO & Master AIO thiever.

What version of TRiBot are you using? TRiBot 3.008

What version of Java is TRiBot using? jdk 1.8.0_25

What operating system are you using? Windows 8

Do you experience high CPU usage with other scripts? Relekka rock crabs PRO and Master AIO thiever. 

What is the "Max Heap Size" set to as defined in the TRiBot Login? 256MB

What is your Client Paint Delay? 75

Are you running lite mode? Yes

Do you minimize TRiBot while botting? Yes

 

Additional information; I did not have this problem yesterday. I could run at least 5 accounts flawless. But then I logged in today and it started screwing me over. Scanned my PC, few 'possible threats' removed, did some tune-up stuff and everything, but nothing worked. Therefore, my only explanation is the problem is on TRiBot's side, or I just blew my CPU up. 

 

I'd love anyone that could help me, forever.

 

Edit; Nevermind this. I'm not lagging with wQuester nor Master Thiever AIO. It's just Relekka rock crabs. Still trying to find a fix for this, so if anyone could help me with that, I'll still love you forever.

It's probably a script issue, a month late but if you ever come back or if someone else is viewing this thread regarding the same script.

Share this post


Link to post
Share on other sites

Did you follow the guide linked above?YES
What is the CPU usage before you start a script? Jumping between 3-9
What is the CPU usage after you start a script?jumping between 15-24
What script are you using?ExRunecrafter
What version of TRiBot are you using?9.217._1
What version of Java is TRiBot using?8.0_25
What operating system are you using?Win7
Do you experience high CPU usage with other scripts?aAgility is jumping between 4-15.relleka crabs pro always ~25
What is the "Max Heap Size" set to as defined in the TRiBot Login?256
What is your Client Paint Delay? tried 30/60 did not change anything
Are you running lite mode? YES
Do you minimize TRiBot while botting? YES

 

I used to run 8 accounts flawlessly, but after the latest update i can barely run 3 accounts.Efficiency has dropped significantly too. from 1.6k runes per hour to 1.2, running 4 accounts.Also i have noticed that the client using proxy using ~5% more cpu than the client without proxys.

 

PLESE note that i all this started to happen after the client update.

Share this post


Link to post
Share on other sites

Note the following stats are just from running the client with the old school client running WITHOUT playing the game. How the heck do I decrease the usage?! It's ridiculous.

 

Did you follow the guide linked above? Yes
What is the CPU usage before you start a script? 100%+
What is the CPU usage after you start a script? Can't run a script at the moment
What script are you using? None
What version of TRiBot are you using? 9.220_8
What version of Java is TRiBot using? 1.8.0_25
What operating system are you using? OS X 10.10
Do you experience high CPU usage with other scripts? I don't know, I'm a new user
What is the "Max Heap Size" set to as defined in the TRiBot Login? 386
What is your Client Paint Delay? 100
Are you running lite mode? Yes
Do you minimize TRiBot while botting? If I minimize to system tray the CPU percentage changes by about 5%.

 

When there is no oldschool client open the cpu usage is at about 3%. This also occurs on my VNS with CentOS 6.5, 64 bit. 

 

 

EDIT:

 

for some reason now the client doesn't use 100% of my CPU. So I guess that solves that issue. I'm not really sure why.

Edited by this_is_my_username

Share this post


Link to post
Share on other sites
Did you follow the guide linked above? YES
What is the CPU usage before you start a script? 0.1 (when tribot open blank) 18.3% - 20.7% (With a new client window)
What is the CPU usage after you start a script? 90-95% (when running all scripts)
What script are you using? tau motherlode miner
What version of TRiBot are you using? TRiBot Release 9.223_3 
What version of Java is TRiBot using? jre1.8.0_51
What operating system are you using? Windows 8.1
Do you experience high CPU usage with other scripts? YES
What is the "Max Heap Size" set to as defined in the TRiBot Login? 256 with 1 client 
What is your Client Paint Delay? 100
Are you running lite mode? YES
Do you minimize TRiBot while botting? YES... a tiny difference.
 
#A few notes
When i 'start' script the 'Client debug' starts bugging up. Looks liek it's compiling tasks is being overwhelmed. And CPU shoots up. The script is non-responsive. It will just stay in an idle state. 

Share this post


Link to post
Share on other sites

Hi,

Sorry to bump up an old thread but did not find better thread for this.

 

I see 90%+ CPU usage with only the client open and standing on the login page. I have this issue on all of my VPS's. I try to run only 1 oldschool client, the VPS is 3Ghz xeon with 1 Gb RAM and Ubuntu 14.04 64bit LTS OS.

 

Did you follow the guide linked above? Yes
What is the CPU usage before you start a script? 90%+
What is the CPU usage after you start a script? 99-100%
What script are you using? None, it is already 90%+ with just the client opened
What version of TRiBot are you using? 9.230_0
What version of Java is TRiBot using? 1.8.0_51:/usr/lib/jvm/java-8-oracle/jre
What operating system are you using? Ubuntu 14.04 LTS 64bit
Do you experience high CPU usage with other scripts? Non applicable
What is the "Max Heap Size" set to as defined in the TRiBot Login? 384
What is your Client Paint Delay? 65, but tried multiple values between 0-100
Are you running lite mode? Yes
Do you minimize TRiBot while botting? Yes, but non applicable

 

I tried so far without luck:

   - delete hooks.dat multiple times

   - delete .tribot folder

   - Lite mode

   - paint delay

 

EDIT: also tried to full reinstall to 32bit system, did not solve the problem either

Edited by xfish

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 30 replies
    • This update will:

      Allow for clicking through the chat box when possible (Thanks @Todd)


      Fix Combat#selectIndex (Thanks @Encoded)


      Ensure worlds stay sorted and added a check to avoid misclicks in the in-game world hopper (Thanks @erickho123)


      Fix out-dated Options API interface indices (Thanks @Todd)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 12 replies
    • This release will:

      Fix login bot after today's game update (Thanks @JoeDezzy1)


      Fix latest in-game world hopping issues (Thanks @erickho123)


      Compact Settings UI and set location relative to TRiBot (Thanks @JoeDezzy1)


      Fix an older implementation of GrandExchange#getWindowState (Thanks @JoeDezzy1)


      Improve the preformance of NPCChat by only searching in certain interface parents (Thanks @JoeDezzy1)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      LG support for RuneLite


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 16 replies
    • This release will:

      Fix bytecode manipulation in order to prevent the modification of parameters within the Filter and Condition classes themselves (thanks @wastedbro)


      Fix NPE caused by non-null value in GE API (thanks @erickho123)


      Add and fix equals methods for api2007.types (thanks @JoeDezzy1)


      Modify Mouse#leaveGame to make the mouse leave the game from top, left, right, or bottom (thanks @erickho123)


      Add Entrana area to Ships API (thanks @erickho123)


      Fix raid prayers index/settings in Prayer API (thanks @erickho123)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 29 replies
    • This update will:

      Implement better canvas locking/synchronization mechanism


      Fix small Login API bug


      Remove the requirement for xbooting Java classes


      Use ExecutorService to perform canvas work in parallel


      Add "Account Management" game tab to GameTab API (thanks @Encoded)


      Fix NPCChat#getMessage (thanks @Encoded )


      Fix NPCChat#selectOption (thanks @Encoded )


      Fix Banking API after today's update (thanks @Encoded )


      Fix in-game world hopper after today's update (thanks @Encoded )



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 38 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×