Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Sign in to follow this  
TRiLeZ

TRiBot Dev 8.08 Testing

Recommended Posts

Hello,

 

I need testers for the "Development Release" of TRiBot. TRiBot Release 8.08 was released earlier today, but was reverted because many users claimed they had "freezing problems".

 

Please run the development version of TRiBot by clicking the "Development Release" box in the TRiBot Loader.

 

Please post your results here. Remember, I need details.

 

Also, use this format if the client freezes:

 


Time elapsed before the freeze:

Script Running:

Lite Mode: (yes/no)

Java Version:

Operating System:

What Froze: (client, TRiBot window, or both)

Client Debug:

TRiBot Loader Console Debug:

 

To get the 'TRiBot Loader Console Debug', put the TRiBot Loader in Console Mode.

 

Thanks,

TRiLeZ

Share this post


Link to post
Share on other sites

Tried three times. Hope you can make use of this.

 

 

Time elapsed before the freeze: Around 4 minutes.

Script Running: African Hunter.

Lite Mode: (yes/no) Yes.

Java Version: Latest. (JRE and JDK)

Operating System: Windows 8

 

 

Time elapsed before the freeze: 2 minutes.

Script Running: African Hunter

Lite Mode: (yes/no) Yes

Java Version: Latest

Operating System: Windows 7

 

 

Time elapsed before the freeze: Again 2 minutes.

Script Running: African Hunter.

Lite Mode: (yes/no) Yes

Java Version: Latest

Operating System: Windows 7

 

 

Hope this can help the community in some way I wasted 12 traps attempting this! Lol.

Share this post


Link to post
Share on other sites

Tried three times. Hope you can make use of this.

 

 

Time elapsed before the freeze: Around 4 minutes.

Script Running: African Hunter.

Lite Mode: (yes/no) Yes.

Java Version: Latest. (JRE and JDK)

Operating System: Windows 8

 

 

Time elapsed before the freeze: 2 minutes.

Script Running: African Hunter

Lite Mode: (yes/no) Yes

Java Version: Latest

Operating System: Windows 7

 

 

Time elapsed before the freeze: Again 2 minutes.

Script Running: African Hunter.

Lite Mode: (yes/no) Yes

Java Version: Latest

Operating System: Windows 7

 

 

Hope this can help the community in some way I wasted 12 traps attempting this! Lol.

Thanks.

 

Could you also tell me if it was the TRiBot window, the RS client, or both that froze?

Share this post


Link to post
Share on other sites

Thanks.

 

Could you also tell me if it was the TRiBot window, the RS client, or both that froze?

It was the whole thing. It would not allow me to click anywhere. In fact just to close the window I had to use task manager as it was not closing manually. Also if it's relevant my account logs off as soon as it freezes. It may not show it but I can immediately log back on after the freeze on the RS webclient.

 

Edit: Apparently it lasts a bit longer on windows 8 could be a coincident but I'm not sure. (lasted 6 minutes this time)

Edited by bloodydroid

Share this post


Link to post
Share on other sites

Time elapsed before the freeze: When 3+ windows are open and I closed one.  Client freezes up.  However, If I don't close a window it's lasted 60+ minutes so far.  Haven't had a freeze from just time, running 3 tabs.

Script Running: aMiner [FREE].

Lite Mode: (yes/no) Yes

Java Version: Latest

Operating System: Windows 7

 

This also seemed to happen on the previous version, but with 5 or more tabs when I tried to close one.

Edited by Naughty0907

Share this post


Link to post
Share on other sites

I didn't tick "Development version",

 

trib.png

 

Time elapsed before the freeze: Started script, froze seconds into it

Script Running: --

Lite Mode: (yes/no) yes

Java Version: u45

Operating System: win7 64bit

What Froze: (client, TRiBot window, or both)

Client Debug: Above pic

TRiBot Loader Console Debug: Above pic

Share this post


Link to post
Share on other sites

I didn't tick "Development version",

 

trib.png

 

Time elapsed before the freeze: Started script, froze seconds into it

Script Running: --

Lite Mode: (yes/no) yes

Java Version: u45

Operating System: win7 64bit

What Froze: (client, TRiBot window, or both)

Client Debug: Above pic

TRiBot Loader Console Debug: Above pic

 

TRiBot Loader Console Debug is actually the debug messages displayed in the TRiBot Loader. That's what I need.

 

Just was forced to update my client again and the bot froze within 5 minutes of use.. had no problems before I was forced to update

froze on me again..

Those posts provide no help whatsoever. Please use the specified format as listed in the original post.

Share this post


Link to post
Share on other sites

Time elapsed before the freeze: 5 Minutes (Rougly)

Script Running: BrMasterThieverPro v3.055

Lite Mode: yes

Java Version: Version 7 Update 45

Operating System: Windows XP SP3

What Froze: TRiBot Client

Client Debug: Client Froze not able to click to see the Debug.

TRiBot Loader Console Debug:

 

[00:55:33] SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
[00:55:33] SLF4J: Defaulting to no-operation (NOP) logger implementation
[00:55:33] SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

 

This error didn't freeze the client but this one did...

 

 

Waiting for the client to freeze then will post.

Edited by Aryan

Share this post


Link to post
Share on other sites

all frozen again, why did you even update? 0_o

This post is 0% helpful.

 

Time elapsed before the freeze: 5 Minutes (Rougly)

Script Running: BrMasterThieverPro v3.055

Lite Mode: yes

Java Version: Version 7 Update 45

Operating System: Windows XP SP3

What Froze: TRiBot Client

Client Debug: Can't see it froze.

TRiBot Loader Console Debug:

Could you try and get the TRiBot Loader Console Debug?

Share this post


Link to post
Share on other sites

Java JRE Home: C:\Program Files (x86)\Java\jre7.
[11:45:05] Using "C:\Program Files (x86)\Java\jre7\bin\java.exe" to boot TRiBot.
[11:45:05] Error: Could not find or load main class org.tribot.TRiBot
[11:45:05] Please use CMSClassUnloadingEnabled in place of CMSPermGenSweepingEnabled in the future
[11:45:05] TRiBot Loader has finished it's process, but some errors have occurred.

Share this post


Link to post
Share on other sites

Error it gives on crash.

01:03:47] The AWT Event Dispatch Thread is locked-up. Attempting to restart it.[01:03:47] - java.lang.Thread.suspend0(Native Method)[01:03:47] - java.lang.Thread.suspend(Unknown Source)[01:03:47] - obf.Ge.m(fh:454)[01:03:47] - obf.Ge.getGraphics(fh:1021)[01:03:47] - sun.awt.RepaintArea.paint(Unknown Source)[01:03:47] - sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)[01:03:47] - java.awt.Component.dispatchEventImpl(Unknown Source)[01:03:47] - java.awt.Component.dispatchEvent(Unknown Source)[01:03:47] - java.awt.EventQueue.dispatchEventImpl(Unknown Source)[01:03:47] - java.awt.EventQueue.access$200(Unknown Source)[01:03:47] - java.awt.EventQueue$3.run(Unknown Source)[01:03:47] - java.awt.EventQueue$3.run(Unknown Source)[01:03:47] - java.security.AccessController.doPrivileged(Native Method)[01:03:47] - java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)[01:03:48] - java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)[01:03:48] - java.awt.EventQueue$4.run(Unknown Source)[01:03:48] - java.awt.EventQueue$4.run(Unknown Source)[01:03:48] - java.security.AccessController.doPrivileged(Native Method)[01:03:48] - java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)[01:03:48] - java.awt.EventQueue.dispatchEvent(Unknown Source)[01:03:48] - obf.Ac.dispatchEvent(fn:153)[01:03:48] - java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)[01:03:48] - java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)[01:03:48] - java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)[01:03:48] - java.awt.EventDispatchThread.pumpEvents(Unknown Source)[01:03:48] - java.awt.EventDispatchThread.pumpEvents(Unknown Source)[01:03:48] - java.awt.EventDispatchThread.run(Unknown Source)[01:03:57] The AWT Event Dispatch Thread is locked-up. Attempting to restart it.[01:03:57] - java.awt.Component.invalidate(Unknown Source)[01:03:57] - java.awt.Container.invalidate(Unknown Source)[01:03:57] - javax.swing.JComponent.revalidate(Unknown Source)[01:03:57] - javax.swing.plaf.basic.BasicListUI.redrawList(Unknown Source)[01:03:57] - javax.swing.plaf.basic.BasicListUI.access$900(Unknown Source)[01:03:57] - javax.swing.plaf.basic.BasicListUI$Handler.intervalAdded(Unknown Source)[01:03:57] - javax.swing.AbstractListModel.fireIntervalAdded(Unknown Source)[01:03:57] - javax.swing.DefaultListModel.addElement(Unknown Source)[01:03:58] - obf.Of.run(ze:5)[01:03:58] - java.awt.event.InvocationEvent.dispatch(Unknown Source)[01:03:58] - java.awt.EventQueue.dispatchEventImpl(Unknown Source)[01:03:58] - java.awt.EventQueue.access$200(Unknown Source)[01:03:58] - java.awt.EventQueue$3.run(Unknown Source)[01:03:58] - java.awt.EventQueue$3.run(Unknown Source)[01:03:58] - java.security.AccessController.doPrivileged(Native Method)[01:03:58] - java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)[01:03:58] - java.awt.EventQueue.dispatchEvent(Unknown Source)[01:03:58] - obf.Ac.dispatchEvent(fn:153)[01:03:58] - java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)[01:03:59] - java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)[01:03:59] - java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)[01:03:59] - java.awt.EventDispatchThread.pumpEvents(Unknown Source)[01:03:59] - java.awt.EventDispatchThread.pumpEvents(Unknown Source)[01:03:59] - java.awt.EventDispatchThread.run(Unknown Source)
Edited by Aryan
  • Like 1

Share this post


Link to post
Share on other sites

Still freezing. In fact, it's worse with development mode. To be more precise, for me specifically the GUI of any script freezes the bot. I can load up and play just fine, but when I start a script with a GUI interface, it freezes before I can start the script. Even more specifically, for example AIO Stronghold, which is a big GUI with a lot of info you have to fill in, is the script I'm freezing up on.

Share this post


Link to post
Share on other sites

Time elapsed before the freeze: 15 minutes


Script Running: Encoded Fisher


Lite Mode: I don't think so.


Java Version: Version 7 Update 25 (build 1.7.0_25-b17)


Operating System: Windows 7


What Froze: (client, TRiBot window, or both) Just the client, the scripts are working fine, although very laggy and input is impossible for example I can't pause, stop or start a script or tab between my open dinwso either )


Client Debug: I don't believe it's possible as it's just frozen, the lag thing to happen from what I can see is that it solved a random event, the sandwich lady to be specific.


TRiBot Loader Console Debug:


 


 


It was working perfectly fine for me yesterday ( the live version ) and now that one is worse than the development issue as the live version freezes the script as well.


Share this post


Link to post
Share on other sites

Time elapsed before the freeze: 2-3 Minutes~

Script Running: Local Private Script + wBarrows (Tested both same results)

Lite Mode: (yes/no) Yes

Java Version:

1.7 1.7.0_21 C:\Program Files\Java\jre7\bin\javaw.exe   true

Operating System: Windows 7

What Froze: (client, TRiBot window, or both) EVERYTHING!

Client Debug: None.

TRiBot Loader Console Debug: None.

 

Imgur picture of freeze: [Half is grey because I dragged it out of window and back, makes it more clear that it is, in fact, frozen]

 

JVI6rzo.png

Edited by Foooolmaster

Share this post


Link to post
Share on other sites

Time elapsed before the freeze: 1-5min

Script Running: a local fighter script, nothig out of the ordinary. uses teleports, walking and banking too.

Lite Mode: (yes/no) yes

Java Version: latest

Operating System:

What Froze: (client, TRiBot window, or both) client frozen, window is partially responsive (X is clickable bit has no effect)

Client Debug: nothig there this time, just the loaded version message

TRiBot Loader Console Debug: usual stuff (loaded, ready..). Loader does not freeze btw.

 

what I noticed with the current "official" version: 

1. open 1 bot, run a script > works fine, had 1h10min of runtime

2. open 2nd bot and dont run a scirpt > the 1st one is fine

3. open 2nd bot and run a script > 2nd bot freezes in 1-5min and the 1st one that worked fine so far (1h10m) also freezes ~1-2 min after the 2nd bot has frozen.

4. case 3 repeats when I run official version as the 1st bot and dev version as the 2nd.

 

E: the pervious stuff is about 8.08_5

 

8.08_6 just froze (i doubled the heap size to 1024mb but still frozen)

 

12:26:22] CONSOLE STARTED

[12:26:22] TRiBot 8.8_6
[12:26:22] Initial Settings Loaded
[12:26:22] Using SID: jbCIKh92VD9l9HFQFaWt0j9BVaPYNbTENJtP7tBYgt33yYBHw8X
[12:26:23] Initializing TRiBot
[12:26:23] TRiBot AppData Dir: C:\Users\MinuPC\AppData\Roaming\.tribot
[12:26:23] Sesssion Validated
[12:26:24] TRiBot Release (8.8_6) loaded. (1.7.0_45:C:\Program Files (x86)\Java\jre7)
[12:26:24] Global Font Set
[12:26:24] Settings Applied
[12:26:24] TRiBot GUI is ready.
[12:26:24] Settings Applied
[12:26:24] Preferences Installed
[12:32:29] Error: aq.n() ah.f() w.p() cq.au() bk.as() dn.co() dn.co() ab.cf() client.g() bk.pm() | di:502 di:347 aq:128 ah:301 w:83 cq:11 cu:1145 cu:791 bk:4486 dn:8080 dn:8329 ab:7984 client:840 bk:238 bk:195 java.lang.Thread.run | java.lang.NullPointerException
[12:32:29] error_game_crash
[12:33:11] Done

Edited by l6bus tank

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 27 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 70 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 23 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...