Jump to content
Sign in to follow this  
TRiLeZ

TRiBot Release 8.07_0

Recommended Posts

keep getting strange plant random.. and it says this

 

  • [18:54:03] We are attempting to solve the Strange Plant random.
  • [18:54:07] We successfully solved the Strange Plant random. 

but i was watching it this time (since last time it sed this but i was dead) and it started attacking me and i died 

Share this post


Link to post
Share on other sites

mine random just logged out. I'd REALLY like to see a sound from now on when a random event occurs. This seems like something that should of been implemented from the start.  As an example: I get a Random Event and the client plays a noise out load, I hear it from my computer and i check to make sure the random is completed. This need to be done. It seems OSRS is really changing the random events over and over, we need this to keep our accounts safe and free from bans.  Everyone should really scream for this to be applied to the next tribot update. 

Share this post


Link to post
Share on other sites

mine random just logged out. I'd REALLY like to see a sound from now on when a random event occurs. This seems like something that should of been implemented from the start.  As an example: I get a Random Event and the client plays a noise out load, I hear it from my computer and i check to make sure the random is completed. This need to be done. It seems OSRS is really changing the random events over and over, we need this to keep our accounts safe and free from bans.  Everyone should really scream for this to be applied to the next tribot update.

I disagree, trilez and the team are working on a method so randoms will never need to be updated again. Just be patient, they are great coders and I'm sure we'll see something about randoms from them soon

Share this post


Link to post
Share on other sites

I don't know if this is client related or script related, but since the new version everytime after a teleportation random (Molly etc.). The bot logs out. 

At first I thought it was because of my own script, but I've had it with aAgility aswell. Not sure but it seems that the random event solver uses onResume() a bit too quick. 

Thus giving the client the idea that you are not in a certain area and returning the state null or loging out (I always use logout instead of null when working with states). 

 

Any ideas?

Share this post


Link to post
Share on other sites

^^ This needs to be looked at it.  I've had it happen to me also directly after completing a random, not all the time, but frequently.

 

Also on the valuables interface that pops up after randoms saying you left things on the floor I believe you can toggle that in lumbridge at the doomsayer if I'm not mistaken.

Share this post


Link to post
Share on other sites

now fix this bug what I keep having after 5 minutes of running a script.

 

max amount of instances has been surpassed.

 

I run 1 script, on 1 account, it's a premium script.

 

... made 2 posts about it on forums already, no helpful replies yet :/

 

Lots of people are getting this it was doing for me but not any more when no one answers me i usually just PM the admin or a mod or a prem script writer they can always offer some advice

Share this post


Link to post
Share on other sites

[12:46:53] Starting TRiBot Loader.
[12:46:54] TRiBot Loader Release 1.78 is up-to-date.
[12:47:07] Attempting to launch TRiBot.
[12:47:07] The java bin directory couldn't be found. Using the "java" command to boot TRiBot.
[12:47:07] TRiBot SID: 'oVN6Hrcz40JgrP2JUDLTZMMK d4eN7RU8QY0XRUmEyCHD6dEPZ'.
[12:47:07] Click this text box to copy the SID to your clipboard.
[12:47:07] TRiBot Loader has finished it's process. TRiBot will now start.


[12:47:07] CONSOLE STARTED
[12:47:07] TRiBot 8.7_3
[12:47:07] Please use CMSClassUnloadingEnabled in place of CMSPermGenSweepingEnabled in the future

[12:47:07] Initial Settings Loaded
[12:47:07] Using SID: oVN6Hrcz40JgrP2JUDLTZMMKd4eN7RU8QY0XRUmEyCHD6dEPZ
[12:47:08] Initializing TRiBot
[12:47:08] TRiBot AppData Dir: /root/.tribot
[12:47:08] Sesssion Validated
[12:47:09] TRiBot Release (8.7_3) loaded. (1.7.0_25:/usr/lib/jvm/java-7-openjdk-amd64/jre)
[12:47:09] Global Font Set
[12:47:09] Settings Applied
[12:47:09] TRiBot GUI is ready.
[12:47:09] Settings Applied
[12:47:09] Preferences Installed

 

What is that and how to fix it? Anyone? :)

Share this post


Link to post
Share on other sites

[12:46:53] Starting TRiBot Loader.

[12:46:54] TRiBot Loader Release 1.78 is up-to-date.

[12:47:07] Attempting to launch TRiBot.

[12:47:07] The java bin directory couldn't be found. Using the "java" command to boot TRiBot.

[12:47:07] TRiBot SID: 'oVN6Hrcz40JgrP2JUDLTZMMK d4eN7RU8QY0XRUmEyCHD6dEPZ'.

[12:47:07] Click this text box to copy the SID to your clipboard.

[12:47:07] TRiBot Loader has finished it's process. TRiBot will now start.

[12:47:07] CONSOLE STARTED

[12:47:07] TRiBot 8.7_3

[12:47:07] Please use CMSClassUnloadingEnabled in place of CMSPermGenSweepingEnabled in the future

[12:47:07] Initial Settings Loaded

[12:47:07] Using SID: oVN6Hrcz40JgrP2JUDLTZMMKd4eN7RU8QY0XRUmEyCHD6dEPZ

[12:47:08] Initializing TRiBot

[12:47:08] TRiBot AppData Dir: /root/.tribot

[12:47:08] Sesssion Validated

[12:47:09] TRiBot Release (8.7_3) loaded. (1.7.0_25:/usr/lib/jvm/java-7-openjdk-amd64/jre)

[12:47:09] Global Font Set

[12:47:09] Settings Applied

[12:47:09] TRiBot GUI is ready.

[12:47:09] Settings Applied

[12:47:09] Preferences Installed

 

What is that and how to fix it? Anyone? :)

 

Nothing looks wrong to me.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Our picks

    • Please welcome our new developers, @JoeDezzy1, @erickho123, @Encoded, and @wastedbro.

      These members will be responsible for working on, maintaining, and improving TRiBot.

      This means that bug fixes and improvements will now come at a much faster pace! We're committed to providing users with the best botting experience possible!
        • Thanks
        • Like
      • 30 replies
    • This release includes:

      More 3rd party libraries for script writers to use


      Apache Commons Codec


      Apache Commons Collections


      Apache Commons Configuration


      Apache Commons IO


      Apache Commons Lang


      Apache Commons Math


      GSON


      Guava


      JFoenix




      Hint arrow API


      Game#getHintArrowX


      Game#getHintArrowY




      Fix player hooks including Player#getSkullIcon and Prayer#getPrayerIcon
        • Thanks
        • Like
      • 39 replies
    • This update includes:

      Fix broken hooks


      Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."


      Fix bug relating to which bot tab is sent human input


      General#randomLong bug fix involving negative numbers


      Fix GE API



      Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.
        • Thanks
        • Like
      • 37 replies
    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
        • Thanks
        • Like
      • 100 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 27 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×