Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0

TRiBot Beta 7.60_0

64 posts in this topic

Random solvers are breaking for some of my users

  • [16:15:20] Encoded Fisher: We are attempting to solve the Mysterious Old Man random. 
  • [16:15:22] java.lang.NullPointerException
  • [16:15:22] at org.tribot.api2007.types.RSInterface.getParentID(kj:162)
  • [16:15:22] at org.tribot.api2007.NPCChat.getClickContinueInterface(oe:138)
  • [16:15:22] at org.tribot.api2007.NPCChat.getMessage(oe:167)
  • [16:15:22] at org.tribot.api2007.NPCChat.clickContinue(oe:802)
  • [16:15:22] at obf.cc.C(yd:145)
  • [16:15:22] at obf.mB.C(zm:685)
  • [16:15:22] at obf.mB.run(zm:1097)
  • [16:15:22] at java.lang.Thread.run(Unknown Source)
  • [16:15:22] Encoded Fisher: We failed to solve the Mysterious Old Man random. (2)
  • [16:15:22] Script Ended: Encoded Fisher.

Share this post

Link to post
Share on other sites


I'm getting this just a few seconds before crashing on rs3

[09:25:56] Error: client.init:1047 sun.reflect.NativeMethodAccessorImpl.invoke0 sun.reflect.NativeMethodAccessorImpl.invoke sun.reflect.DelegatingMethodAccessorImpl.invoke java.lang.reflect.Method.invoke Rs2Applet.a:173 Rs2Applet.init:355 obf.Hf.run java.lang.Thread.run | java.lang.RuntimeException | 


If the client crashes, you either:

  1. Are not using the 32-bit version of Java.
  2. Are not using the latest Java (7u40)
  3. Have outdated/no graphics driver
  4. Are not using windows.

Share this post

Link to post
Share on other sites

The "lots of randoms" seems to involve problems with wise old man. I have noticed that whenever a random has failed or my user is logged out while a random is being solved (that means: script still running, random attempt on-going, user logged out because the random solver was not doing anything), logging in and restarting script ALWAYS gets the random solved (no wise old man = no problems).

One more thing: The fails are not 100%, most of the time, stuff gets solved just fine.

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.