Jump to content

Recommended Posts

logged in, i tried logged out and its still just wants to run me to the corner of nothingness if i select bank, and if i select either drop he doesn't do anything at all, and when sliding the area tab ive only gotten the red indicator twice out of like 15 times runnign the bot, it started to work once when i was on fast drop and when i stopped it and started it again on bank he jsut ran off again! haha 

 

nvm got it i think! thanks for the help (:

 

I think I've made it so this shouldn't happen again. When you click rerun script it remembers your last settings, but now I've got it to wait for you to hit start on the GUI again.

 

Did you update the anti-ban? On a scale of 1 to random integer, whats the ABCL rating? =P

 

I'm not sure what the ABCL is, the only thing that has changed from the user perspective is you no longer need to type out the rock ids.

Share this post


Link to post
Share on other sites

does it support exploding rocks yet....?

It does avoid them for the most part, but I'm still working on improving it.

Smoking rocks are tricky because there is no definite way to tell that you are interacting with one.

With this new objectclicking interface though I may have found a definite solution.

Edited by Encoded

Share this post


Link to post
Share on other sites

1. Got a major problem when banking from Rimmington mining area to Falador east bank, keeps re-clicking the minimap so the script wont have time to click the bank open and then just runs behind the bank. This does not happen always, maybe one of 5 runs.

 

2. Pretty rarely it can fail to the smoking rock and break the pickaxe, in that case it didn't run back to the bank and get a new pickaxe, continued to click the rock even though it says you cannot mine without a pickaxe.

 

Help for these problems would be much appreciated because it is pretty suspicious activity:)

 

iYyPzYN.jpg

Share this post


Link to post
Share on other sites

1. Got a major problem when banking from Rimmington mining area to Falador east bank, keeps re-clicking the minimap so the script wont have time to click the bank open and then just runs behind the bank. This does not happen always, maybe one of 5 runs.

 

2. Pretty rarely it can fail to the smoking rock and break the pickaxe, in that case it didn't run back to the bank and get a new pickaxe, continued to click the rock even though it says you cannot mine without a pickaxe.

 

Help for these problems would be much appreciated because it is pretty suspicious activity:)

 

iYyPzYN.jpg

 

I'll have to make areas for all the banks because right now I just check if you are within distance of the bank booth.

 

I thought I pushed an update to stop the script if it does end up breaking your pickaxe from a smoking rock but maybe it didn't get updated. I'll try uploading it again.

Share this post


Link to post
Share on other sites

Surprised I'm not banned yet seeing as I'm mining tin with a bronze pickaxe, but here's almost 24 hours. (it's still running)

 

dc77b6436b.png

 

 

Ended up stopping at  24:44:33. I changed the XP Gained to hopefully now display 200k instead of 0.2m.

Edited by Encoded

Share this post


Link to post
Share on other sites

I'll have to make areas for all the banks because right now I just check if you are within distance of the bank booth.

 

I thought I pushed an update to stop the script if it does end up breaking your pickaxe from a smoking rock but maybe it didn't get updated. I'll try uploading it again.

Yeah the bank method should be improved especially at Falador east,

thanks for your fast reply.

Share this post


Link to post
Share on other sites

Not exactly sure if this is your scripts problem or the clients, or if this is even a post that contributes towards something but I cant seem to run it longer than 10 minutes. It just started about 3 hours ago. I get this :

 

  • [22:22:13] We are attempting to solve the Strange Plant random.
  • [22:22:14] We successfully solved the Strange Plant random.
  • [22:33:02] java.lang.NullPointerException
  • [22:33:02] at scripts.miner.tasks.g.H(Mine.java:241)
  • [22:33:02] at scripts.miner.tasks.g.f(Mine.java:222)
  • [22:33:02] at scripts.miner.tasks.g.e(Mine.java:193)
  • [22:33:02] at scripts.miner.tasks.g.h(Mine.java:64)
  • [22:33:02] at scripts.miner.tasks.g.m(Mine.java:48)
  • [22:33:02] at scripts.miner.EncodedMiner.run(EncodedMiner.java:95)
  • [22:33:02] at java.lang.Thread.run(Unknown Source)

 

 

 

There's also a previous one:
 

  • [20:49:37] We successfully solved the Frog random.
  • [20:49:48] java.lang.NullPointerException
  • [20:49:48] at scripts.miner.tasks.g.H(Mine.java:241)
  • [20:49:48] at scripts.miner.tasks.g.f(Mine.java:222)
  • [20:49:48] at scripts.miner.tasks.g.e(Mine.java:193)
  • [20:49:48] at scripts.miner.tasks.w.active(Mining.java:51)
  • [20:49:48] at org.tribot.api.Timing.waitCondition(qf:9)
  • [20:49:48] at scripts.miner.tasks.t.m(Mining.java:34)
  • [20:49:48] at scripts.miner.EncodedMiner.run(EncodedMiner.java:95)
  • [20:49:48] at java.lang.Thread.run(Unknown Source)

 

The pattern im seeing is after the random it wiggs out. Probably client. Thought I would share!

Share this post


Link to post
Share on other sites

Not exactly sure if this is your scripts problem or the clients, or if this is even a post that contributes towards something but I cant seem to run it longer than 10 minutes. It just started about 3 hours ago. I get this :

 

  • [22:22:13] We are attempting to solve the Strange Plant random.
  • [22:22:14] We successfully solved the Strange Plant random.
  • [22:33:02] java.lang.NullPointerException
  • [22:33:02] at scripts.miner.tasks.g.H(Mine.java:241)
  • [22:33:02] at scripts.miner.tasks.g.f(Mine.java:222)
  • [22:33:02] at scripts.miner.tasks.g.e(Mine.java:193)
  • [22:33:02] at scripts.miner.tasks.g.h(Mine.java:64)
  • [22:33:02] at scripts.miner.tasks.g.m(Mine.java:48)
  • [22:33:02] at scripts.miner.EncodedMiner.run(EncodedMiner.java:95)
  • [22:33:02] at java.lang.Thread.run(Unknown Source)

 

 

 

There's also a previous one:

 

  • [20:49:37] We successfully solved the Frog random.
  • [20:49:48] java.lang.NullPointerException
  • [20:49:48] at scripts.miner.tasks.g.H(Mine.java:241)
  • [20:49:48] at scripts.miner.tasks.g.f(Mine.java:222)
  • [20:49:48] at scripts.miner.tasks.g.e(Mine.java:193)
  • [20:49:48] at scripts.miner.tasks.w.active(Mining.java:51)
  • [20:49:48] at org.tribot.api.Timing.waitCondition(qf:9)
  • [20:49:48] at scripts.miner.tasks.t.m(Mining.java:34)
  • [20:49:48] at scripts.miner.EncodedMiner.run(EncodedMiner.java:95)
  • [20:49:48] at java.lang.Thread.run(Unknown Source)

 

The pattern im seeing is after the random it wiggs out. Probably client. Thought I would share!

That's an error on my end, it's fixed now.

Share this post


Link to post
Share on other sites

@Encoded Hey bro I just started using this script it's amazing never the less getting mithril and addy w/o premium script is cherry BUT I was wondering how possible it is to add mining coal while it can't mine the main ore specified because it's obviously waiting for respawn but if its to much thanks for considering my idea at all :)

Share this post


Link to post
Share on other sites

@Encoded Hey bro I just started using this script it's amazing never the less getting mithril and addy w/o premium script is cherry BUT I was wondering how possible it is to add mining coal while it can't mine the main ore specified because it's obviously waiting for respawn but if its to much thanks for considering my idea at all :)

Yeah I thought about this when I was remaking the script, only reason I didn't make it is because I'd have to redesign the GUI but that's not too big of a deal

Share this post


Link to post
Share on other sites

Paint doesn't show up and I do get this error:

  • [03:47:37] java.lang.SecurityException: Access denied to: D:\Users\User\AppData\Roaming\.tribot\encoded_scripts\miner\gui.properties
  • [03:47:37] at obf.pB.a(id:623)
  • [03:47:37] at obf.pB.checkWrite(id:248)
  • [03:47:37] at java.io.File.createNewFile(Unknown Source)
  • [03:47:37] at scripts.miner.GUI.j(GUI.java:148)
  • [03:47:37] at scripts.miner.GUI.(GUI.java:56)
  • [03:47:37] at scripts.miner.j.run(EncodedMiner.java:72)
  • [03:47:37] at java.awt.event.InvocationEvent.dispatch(Unknown Source)
  • [03:47:37] at obf.Lg.dispatchEvent(li:74)
  • [03:47:37] at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
  • [03:47:37] at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
  • [03:47:37] at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
  • [03:47:37] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
  • [03:47:37] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
  • [03:47:37] at java.awt.EventDispatchThread.run(Unknown Source)
  • [03:47:46] java.lang.NullPointerException
  • [03:47:46] at scripts.miner.EncodedMiner.j(EncodedMiner.java:181)
  • [03:47:46] at scripts.miner.EncodedMiner.onEnd(EncodedMiner.java:177)
  • [03:47:46] at obf.AE.run(jm:945)
  • [03:47:46] at java.lang.Thread.run(Unknown Source) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×