Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
TRiLeZ

TRiBot Beta 7.43_0

39 posts in this topic

WebWalking cant handle the lumby to al-kharid gate correctly, it does it then start walking then goes back and does it again wasting all your gps :P. This has been there a long time, I just think in this thread someone actually sees this.

Share this post


Link to post
Share on other sites

My cosmic runecrafting bots are not working properly. When I turn them on I just stand there. I tried moving the essence on the top of the bank page and nothing changed. One of the cosmic runecraft bots just rotates the camera and then the script stops. 

  • [23:33:38] Starting client.
  • [23:34:36] Script Started: CosmicRunner.
  • [23:34:38] CosmicRunner: Login Bot started!
  • [23:34:40] CosmicRunner: Login Bot succeeded.
  • [23:35:30] java.lang.ArrayIndexOutOfBoundsException: 0
  • [23:35:30] at scripts.CosmicRunner.loop(CosmicRunner.java:170)
  • [23:35:30] at scripts.CosmicRunner.run(CosmicRunner.java:96)
  • [23:35:30] at java.lang.Thread.run(Unknown Source)
  • [23:35:30] Script Ended: CosmicRunner. 

This is the log I see.

Edited by DemonHunterX

Share this post


Link to post
Share on other sites

Banking.depositAll() was changed with this update to use the button. :)

 

Banking.depositEquipment() was also added, just not in the java docs yet.

I'll just change the scroll position calculation.

 

Absolutely phenomenal :)

 

 

Didn't read the API well enough, thanks!

 

It's an easy mistake to make, don't worry about it mate ^^

 

 

just to add to broken random list - frog, maze, jekyll

 

If you find out about a broken random (such as maze), and want it fixed quickly, then I have a solution for you. Next time you get one, just leave your account in there. And then contact TRiLeZ or USA (admins) saying that this random is broken, and this is my account stuck in there. This really helps the admins out and ensures a quick and speedy fix. (Oh, sometimes they give you a 5 day free VIP voucher to say thanks)

 

They do appreciate you reporting that it's broken, but providing them an account to use that's stuck there is a lot more useful.

 

Thanks for letting us know though.

1 person likes this

Share this post


Link to post
Share on other sites

Where is the download link?! im lost lol.

 

HELP

 

The download link for TRiBot is located on the homepage. Link: www.tribot.org

(click the Download TRiBot link at the top)

 

Most TRiBot updates are automatic. When you open up Tribot.jar and it loads up, it will update itself if a change is made.

 

If you didn't understand that or have any other issues or problems, feel free to send me a PM Message.

Edited by MegaMan_Alpha

Share this post


Link to post
Share on other sites

Bot is still not working ?

 

The bot still works fine, and has done for some time. It is very good.

 

If you can't get it to work, post up a topic in the "Bot Help" section or send me or another Support Staff a PM Message, and we will help you.

Share this post


Link to post
Share on other sites

Hey the miner script seems to be down, it takes me to the spots but does not mine the ores. Can you update the bot thank you! It is possible that the I.D. of the rocks changed?

Share this post


Link to post
Share on other sites

Hey the miner script seems to be down, it takes me to the spots but does not mine the ores. Can you update the bot thank you! It is possible that the I.D. of the rocks changed?

 

Like you said, it's most likely that the ID's has changed. Use a proper script that actually uses the rock names, not the ID's to search.

 

It's something you need to report to the script author and not an error with TRiBot. Most scripts will find the rocks by looking at the object names, and model information. However some people use ID's which is very poor, so I recommend not using scripts that use ID searching, because IDs change a lot causing your script to regularly break.

Share this post


Link to post
Share on other sites

My cosmic runecrafting bots are not working properly. When I turn them on I just stand there. I tried moving the essence on the top of the bank page and nothing changed. One of the cosmic runecraft bots just rotates the camera and then the script stops. 

  • [23:33:38] Starting client.
  • [23:34:36] Script Started: CosmicRunner.
  • [23:34:38] CosmicRunner: Login Bot started!
  • [23:34:40] CosmicRunner: Login Bot succeeded.
  • [23:35:30] java.lang.ArrayIndexOutOfBoundsException: 0
  • [23:35:30] at scripts.CosmicRunner.loop(CosmicRunner.java:170)
  • [23:35:30] at scripts.CosmicRunner.run(CosmicRunner.java:96)
  • [23:35:30] at java.lang.Thread.run(Unknown Source)
  • [23:35:30] Script Ended: CosmicRunner. 

This is the log I see.

 

Take that up with the owner of the script. Nothing to do with TRiBot's API.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.