Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Aropupu

[ABCL 10] [ABC2] aFisher [Custom] [Normal fishing] [Barbarian fishing] [Barehanded fishing]

350 posts in this topic

i just can get this to work it wont go bank :(

 

i set the bank tile in the bank and fish tile on the docks and tried like every way of the bank methods...

 

it will like end up in the fishing store or like outside the bank

Share this post


Link to post
Share on other sites

Thank you for the feedback. Unfortunately there are multiple things that could cause it to lose your fishing equipment so I can't really know what's causing it to do that. The method I use to avoid the whirlpools should be quite good but I doubt it's perfect.

 

You should try putting the banking tile away from walls but near the banker/bank booth. I can't really test Fishing Guild myself because I don't have access there currently.

WebWalking walks through pre-defined webs that are built into Tribot.

WalkPath generates a straight path to the tile and walks through that path.

BlindWalking is most likely the same as WalkPath but it's there just in case as backup.

 

Read above. Oh and this script doesn't have a paid version and will always remain free.

I have tried all the walking methods and different bank tiles. It's just the fishing guild is screws up in. So I just fish at Catherby.

 

i just can get this to work it wont go bank :(

 

i set the bank tile in the bank and fish tile on the docks and tried like every way of the bank methods...

 

it will like end up in the fishing store or like outside the bank

As I stated above. Fishing in guild will for some reason always bug up and you will get stuck outside bank. So do the next best thing and go Catherby :)

Share this post


Link to post
Share on other sites

I have been using this bot for awhile it's amazing! Now... it just died on me. Everytime I login and try to load the bot it says I have no fishing equipment in my inventory, when it clearly shows I do. Any thoughts?

Share this post


Link to post
Share on other sites

I have been using this bot for awhile it's amazing! Now... it just died on me. Everytime I login and try to load the bot it says I have no fishing equipment in my inventory, when it clearly shows I do. Any thoughts?

 

Tribot is broken. It doesn't detect any items in your inventory after today's update. You have to wait until it's fixed.

Share this post


Link to post
Share on other sites

Tribot is broken. It doesn't detect any items in your inventory after today's update. You have to wait until it's fixed.

Damn... fml... that'll be AWHILE :(

Share this post


Link to post
Share on other sites

My findings:

 

If the bot accidently clicks on a spell or item, it will break because when it tries to click on a fishing spot, it shows "Cast wind strike on fishing spot" or "Use swordfish with fishingspot" and the script just doesn't do anything.

 

Also when fishing tuna+swordfish, and the shark fishing spot is in the same location as the swordfish spot, it'll try and fish sharks instead of swordfish.

 

Both "bugs" fix themselves after a couple minutes, but it would be nice to see them not happen.

Share this post


Link to post
Share on other sites

After the swirl pool sucks the harpoon up it does not get another out of bank? how come please help

I haven't added that feature yet, because I have never had problems with whirlpools while using this script. I can add it tho.

 

EDIT: The script will now get new fishing equipment from your bank if you lose them. Updated it just now.

 

My findings:

 

If the bot accidently clicks on a spell or item, it will break because when it tries to click on a fishing spot, it shows "Cast wind strike on fishing spot" or "Use swordfish with fishingspot" and the script just doesn't do anything.

 

Also when fishing tuna+swordfish, and the shark fishing spot is in the same location as the swordfish spot, it'll try and fish sharks instead of swordfish.

 

Both "bugs" fix themselves after a couple minutes, but it would be nice to see them not happen.

Unfortunately the first bug is caused by Tribot missclicking on stuff and I unfortunately can't do anything about it. I can add a failsafe that will make the script fix itself whenever it detects that Tribot has accidentally clicked on the wrong stuff. It's extremely weird that it would somehow open the spellbook, but there's nothing in my code that could cause it to do that.

 

I have not found a solution to the second bug yet. It's basically caused by Tribot clicking on the first available option it sees when clicking on the fishing spot regardless of which fishing spot that option belongs to. 

 

EDIT: I have now updated a failsafe so it shouldn't get stuck on "Cast wind strike on fishing spot" or "Use swordfish with fishingspot" anymore.

Edited by Aropupu

Share this post


Link to post
Share on other sites

I also find that sometimes the bot stops behind the bank after a fishing set?

 

Do you have roofs disabled? You can disable them by writing ::toggleroof in Runescape chat.

If you are having this problem with fishing guild, I unfortunately can't recreate the problem to know what's wrong because I don't have access there.

Share this post


Link to post
Share on other sites

this is the best fishing bot out period. 55 hours and still running. thanks man, i know its a lot to ask but would you ever consider making a powerfisher?

Share this post


Link to post
Share on other sites
  • [13:03:02] Script Started: aFisher.
  • [13:03:54] java.lang.NullPointerException
  • [13:03:54] at scripts.aFisher.G(aFisher.java:566)
  • [13:03:54] at scripts.aFisher.run(aFisher.java:535)
  • [13:03:54] at java.lang.Thread.run(Unknown Source)
  • [13:03:54] Script Ended: aFisher. 

i got to bank, set bank tile, go to fishing spot, set fishing tile and it ends.

 

im fishing by barbarian village

Share this post


Link to post
Share on other sites

 

  • [13:03:02] Script Started: aFisher.
  • [13:03:54] java.lang.NullPointerException
  • [13:03:54] at scripts.aFisher.G(aFisher.java:566)
  • [13:03:54] at scripts.aFisher.run(aFisher.java:535)
  • [13:03:54] at java.lang.Thread.run(Unknown Source)
  • [13:03:54] Script Ended: aFisher. 

i got to bank, set bank tile, go to fishing spot, set fishing tile and it ends.

 

im fishing by barbarian village

 

 

It didn't detect any fishing equipment in your inventory when you started it. Dunno what could've caused it. Make sure your inventory and the equipment is visible when you start the script. Sometimes Tribot doesn't detect your items otherwise.

Share this post


Link to post
Share on other sites

i tried this agen without break handler activated, and it works, then when i tried with break handler, it shows the same error as i posted above

Share this post


Link to post
Share on other sites

 

 

You should try putting the banking tile away from walls but near the banker/bank booth. I can't really test Fishing Guild myself because I don't have access there currently.

WebWalking walks through pre-defined webs that are built into Tribot.

WalkPath generates a straight path to the tile and walks through that path.

BlindWalking is most likely the same as WalkPath but it's there just in case as backup.

 

Yeah I've tried putting the banking tile on EVERY tile in the banking area, it just doesn't want to bank there. Also i don't know if this is your script or not but i get logged out randomly when using your script (no other script but yours). Cant get proggys more than an hour because of this.

 

Also respect to you as not many people can do others a service like yourself (Make a free script) then put up with the text rape of complaints made by the people who are reaping the benefits of your hard work, so believe me when i say thank you for this script! but srs plz fix <3

Share this post


Link to post
Share on other sites

Yeah I've tried putting the banking tile on EVERY tile in the banking area, it just doesn't want to bank there. Also i don't know if this is your script or not but i get logged out randomly when using your script (no other script but yours). Cant get proggys more than an hour because of this.

 

Also respect to you as not many people can do others a service like yourself (Make a free script) then put up with the text rape of complaints made by the people who are reaping the benefits of your hard work, so believe me when i say thank you for this script! but srs plz fix <3

 

Do you have roofs disabled? You can disable them by writing ::toggleroof in the runescape chat.

I cannot fix it because I don't have access to Fishing Guild atm. Also, some people have posted quite long proggies from the fishing guild in here.

Share this post


Link to post
Share on other sites

Do you have roofs disabled? You can disable them by writing ::toggleroof in the runescape chat.

I cannot fix it because I don't have access to Fishing Guild atm. Also, some people have posted quite long proggies from the fishing guild in here.

I have roofs disabled. It 8/10 will bank correctly, it just doesn't seem to be consistent with the banking... At catherby however, the bank is fine. I dont understand what this logging out issue is caused by but thats a different issue altogether.

Share this post


Link to post
Share on other sites

The logging out issue was an issue with Tribot I believe.. And I'm having the same problem as you, but most of the other fishing bots around also have problems with the fishing guild. 

Just set it up at Catherby, it's extremely efficient so the extra distance to the bank is pretty darn negligible :)

Share this post


Link to post
Share on other sites

Great script!

zya4w0.png

Got me 1-35 fishing in 3hrs, flawless!

Improved anti-ban would help but other than that it's great.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.