Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
TRiLeZ

TRiBot Beta 7.30_0

37 posts in this topic

This update includes:

  • Tabbing support.
  • Working Appendage random solver.
  • Fix for linux VPS users.
1 person likes this

Share this post


Link to post
Share on other sites

TRiLeZ, love the update. Tab support is fucking boss

trying it now

Edited by erickho123
1 person likes this

Share this post


Link to post
Share on other sites

What exactly is "tabbing support"?

TY for update. Nice to see things turning.

1 person likes this

Share this post


Link to post
Share on other sites

What exactly is "tabbing support"?

TY for update. Nice to see things turning.

I believe it means multiple tabs in one client

Share this post


Link to post
Share on other sites

Just pumping out the updates, I like it.

 

When I go to select a script with two tabs open, my client freezes. I am not in lite mode.

Edited by Encoded

Share this post


Link to post
Share on other sites

 

This update includes:

  • Tabbing support.
  • Working Appendage random solver.
  • Fix for linux VPS users.

 

 

Thank you!

Share this post


Link to post
Share on other sites

Just pumping out the updates, I like it.

 

When I go to select a script with two tabs open, my client freezes. I am not in lite mode.

 Works fine for me in themed mode (not lite mode). It's probably a bug with a script.

Share this post


Link to post
Share on other sites

 Works fine for me in themed mode (not lite mode). It's probably a bug with a script.

I need to change the max heap size

Share this post


Link to post
Share on other sites

multi tabs are very buggy, scripts wont start when more then 2 are running, max heap is 1024mb

 

tried everything and it crashes, not going to use it if it cant support 3+ tabs ):

 

lite mode.

 

 

nope again got 4 bots running in 1 window then start script doesnt respond then the whole thing crashes. 

 

java.lang.OutOfMemoryError: PermGen space.

using 407mb/1gb 

 

Doesnt Work.

 

 

prison pete random is now broken. got an acc stuck in there if you hurry and reply quickly it might still be there to debug.

*no class def found; obf/lb

 

scripts are breaking saying obj/state/run errors >.> fml bots arent stable with this new update.

Edited by hatshacker

Share this post


Link to post
Share on other sites

multi tabs are very buggy, scripts wont start when more then 2 are running, max heap is 1024mb

 

tried everything and it crashes, not going to use it if it cant support 3+ tabs ):

 

lite mode.

 

 

nope again got 4 bots running in 1 window then start script doesnt respond then the whole thing crashes. 

 

java.lang.OutOfMemoryError: PermGen space.

using 407mb/1gb 

 

Doesnt Work.

So when you try to start the 3rd script, it'll say "java.lang.OutOfMemoryError: PermGen space"?

prison pete random is now broken. got an acc stuck in there if you hurry and reply quickly it might still be there to debug.

*no class def found; obf/lb

 

scripts are breaking saying obj/state/run errors >.> fml bots arent stable with this new update.

Nothing is broken. When the TRiBot.jar in the dependencies update, all currently running TRiBot instances will not work if they need to load more classes from the jar. This is because the JVM/java classloaders won't define classes until they are needed. When they are needed and aren't defined, they will be loaded from their appropriate jar and then defined.

So if TRiBot tries to load a not yet defined class and the jar was updated while it was running, it will try to load an invalid class. Hence the no class def found exception.

Share this post


Link to post
Share on other sites

So when you try to start the 3rd script, it'll say "java.lang.OutOfMemoryError: PermGen space"?

 

had 4 running fine started 5'th tab, loaded to login screen, click start script. they all crashed saying that error message, gone back to single clients for now

 

its now saying Error Loading Script: Main!

i have other bots running the same script but now i cant start it anymore \=

working now. \=

Edited by hatshacker

Share this post


Link to post
Share on other sites

Please take a look why bot use higher cpu than previous versions. version 7.00 was ok and previous one before 7.00 i think.

 

2n9wby0.png

Edited by TAKITO

Share this post


Link to post
Share on other sites

had 4 running fine started 5'th tab, loaded to login screen, click start script. they all crashed saying that error message, gone back to single clients for now

 

its now saying Error Loading Script: Main!

i have other bots running the same script but now i cant start it anymore \=

working now. \=

 I have an update to the loader which addresses this issue coming soon.

 

Please take a look why bot use higher cpu than previous versions. version 7.00 was ok and previous one before 7.00 i think.

 

2n9wby0.png

Could you answer some questions for me?

If you go to File->Settings, what is your:

  • Client Paint Delay
  • TRiBot Sleep Modifier

Also, what version of Java are you using? Is it 32 bit or 64 bit? What are you setting the max heap size to?

Share this post


Link to post
Share on other sites

Looks like if you close a tab when it begins to load the jar, even though you've closed it. It's still playing the login music.

Share this post


Link to post
Share on other sites

*Tab issue "out of memory" occurs when you close tab and reopen several times without closing bot.

 

@TRiLeZ

Settings(defaults):

* 25

* 1

* 100

-

+ Lite Mode

-

+Paint Screen Models

 

Java version on picture is 32Bit ~ default by browser.

Maximum heap size: 1024

 

Script for test was used: https://tribot.org/forums/index.php?/topic/17003-updated-august-9th-tri-edgeville-man-fighter-v1145k-gphrbankinglootingrandoms/

 

I'll test now with java 64Bit.

 

Edit:

 

I've downloaded Java 64Bit from official website of java.

Deleted 32 Bit version and istalled 64 one.

Opened Bot.

Started 3 tabs loading one by one "till torches fires up".

After loading all 3 tabs, logged on first one and looks like client got bugged with "start script" button. I could not open Script panel to play script. Client settings same as previous and max Heap size too. I'll try to restart my PC and get scripts runing.

 

Edit2:

 

I wasn't able to start 3 tabs on one client because of huge lagg issue by client :( (I've managed to open 3 tabs but like in 2 minutes client stoped responding).

So I've decided to open 3 clients and look how's it going with version 64Bit of Java, and it was pretty same ~ just memory got increased total ~700mb.

Here's picture of this run.

CPU is very unstable on client 7.30 graphs are 30s but that's enough to see. As I  have previous mentioned this cpu issue started after version 7.00 i believe.

 

pic:

16ht4q9.png

Edited by TAKITO

Share this post


Link to post
Share on other sites

Auto Responser doesn't work for me.

On the release day of the Auto Responser it worked, but since the latest Updates it doesn't.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.