Jump to content
Sign in to follow this  
TRiLeZ

TRiBot Beta 7.20_0

Recommended Posts

This update includes:

  • A custom made mouse movement path generator. The new algorithm looks far more human-like when compared to the previous version.
  • DynamicMouse and DynamicClicking are now much faster.
  • Updated RSArea API
    • New: getRandomTile()
  • Updated Maze random solver.

Share this post


Link to post
Share on other sites

 

This update includes:

  • A custom made mouse movement path generator. The new algorithm looks far more human-like when compared to the previous version.
  • DynamicMouse and DynamicClicking are now much faster.
  • Updated RSArea API
    • New: getRandomTile()
  • Updated Maze random solver.

 

 

 

thanks for the update, but has the random for frog prince been fixed also?

Share this post


Link to post
Share on other sites

Redownloaded and ran it. Can't you just undo the authentication changes you made in the update? Notice it says null at the end now.

 

Thanks. It seems as though TRiBot isn't able to connect to tribot.org. I didn't do any authentication changes so I don't know what is causing this bug.

Share this post


Link to post
Share on other sites

Thanks. It seems as though TRiBot isn't able to connect to tribot.org. I didn't do any authentication changes so I don't know what is causing this bug.

It seems to be occurring for Linux systems; it's not occurring on my Windows home PC. If the client can log in get a session ID yet the second verification isn't working, maybe it's because of the server on which the second verification is hosted. Otherwise, it's probably something to do with the second verification method itself. Wouldn't it be easier to just remove this second authentication?

I'm very keen to do whatever I can do to help you solve this issue as the issue means I cannot bot overnight. If you need me to do anything/test anything to get this solved, I'm more than happy to do so.

Edited by the bot

Share this post


Link to post
Share on other sites

It seems to be occurring for Linux systems; it's not occurring on my Windows home PC. If the client can log in get a session ID yet the second verification isn't working, maybe it's because of the server on which the second verification is hosted. Otherwise, it's probably something to do with the second verification method itself. Wouldn't it be easier to just remove this second authentication?

I'm very keen to do whatever I can do to help you solve this issue as the issue means I cannot bot overnight. If you need me to do anything/test anything to get this solved, I'm more than happy to do so.

 

Tested on:

Ubuntu 12.04 LTS 64bit - working

Debian 7.1 64bit - working

Fedora 19 64bit - working

 

Try changing ur DNS server to Google ones in /etc/resolv.conf

8.8.8.8

8.8.4.4

Share this post


Link to post
Share on other sites

Was the maze random the only one that wasn't working? If so thank you so much!!

 

 

NO the Frog Prince Random and the Mordut classroom one is still in need of fixing. one of my bots was logged out because it failed the classroom random and the other bot was logged because it failed at frog prince. 

Share this post


Link to post
Share on other sites
  • [15:49:42] java.lang.NullPointerException 
  • [15:49:42] at obf.Rd.(cp:127) 
  • [15:49:42] at obf.kc.G(pn:8) 
  • [15:49:42] at org.tribot.api.input.DynamicMouse.move(sg:116) 
  • [15:49:42] at org.tribot.api.DynamicClicking.clickRSModel(xh:1295) 
  • [15:49:42] at org.tribot.api.DynamicClicking.clickRSNPC(xh:1662) 
  • [15:49:42] at org.tribot.api.DynamicClicking.clickRSNPC(xh:1078) 
  • [15:49:42] at scripts.DTools.DruidCombat.attack(DruidCombat.java:31) 
  • [15:49:42] at scripts.DDruids.loop(DDruids.java:671) 
  • [15:49:42] at scripts.DDruids.run(DDruids.java:464) 
  • [15:49:42] at java.lang.Thread.run(Unknown Source) 
  • [15:49:42] Script Ended: DDruids. 

 

 

I'm now getting that with D's druid script after a while, sometimes 30 minutes sometimes an hour or more, point is the script just stops and comes up with that error, can you look into it trilez? The script ran fine before this update, thank you.

Edited by Ratz241

Share this post


Link to post
Share on other sites

@Trilez please reduce CPU usage cause it grow up twice it was. My bots was using rougly 12% now it's 25%-30%. Please fix it ;)

yes i used to be able to run 8 at about 50% cpu now i can barely run 4 without it hitting 100%

 

Edit: This has been happening since a few versions ago not this one

Edited by Mikkolol

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Our picks

    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
      • 55 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
      • 27 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
        • Like
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Sad
      • 22 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×