Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

aHunter v2 [Birds, Lizards/Salamanders, Chinchompas, Falconry]

Recommended Posts

Array
2 hours ago, Aropupu said:

It should already pick them up. Will check it out but need to know what you were hunting exactly?

Edit; just saw through team viewer that it did in fact pick up the traps , I was losing traps because it accidentally placed a trap outside of the designated area 

Edited by theholyone

Share this post


Link to post
Share on other sites
13 hours ago, theholyone said:

Edit; just saw through team viewer that it did in fact pick up the traps , I was losing traps because it accidentally placed a trap outside of the designated area 

Still need to know what you were hunting and possibly a video or even just a screenshot of it happening to be able to do anything about it.

Share this post


Link to post
Share on other sites

@Aropupu hi. Looks like it does not work for chinchompas. Does not loot traps that have chins inside, or traps that failed to catch chin. Only loot the ones that have right click option - Lay trap (when it collaps or smth like that)

EDIT - tbh it does not loot any kind of traps. Well, it does for first few times and then stops. i deleted .tribot folder but that does not help.

Edited by guywithlsd

Share this post


Link to post
Share on other sites
On 8/15/2017 at 11:09 PM, guywithlsd said:

@Aropupu hi. Looks like it does not work for chinchompas. Does not loot traps that have chins inside, or traps that failed to catch chin. Only loot the ones that have right click option - Lay trap (when it collaps or smth like that)

EDIT - tbh it does not loot any kind of traps. Well, it does for first few times and then stops. i deleted .tribot folder but that does not help.

Works just fine. Without more information from you, I cannot know what's wrong. Make a proper bug report.

Share this post


Link to post
Share on other sites
3 hours ago, Aropupu said:

Works just fine. Without more information from you, I cannot know what's wrong. Make a proper bug report.

account already banned. i have tested your script many times, and it's almost impossible to go pass 53 hunt lvl 

As for more info, there was nothing more i could tell you, no logger info or anything. 

Share this post


Link to post
Share on other sites
40 minutes ago, guywithlsd said:

account already banned. i have tested your script many times, and it's almost impossible to go pass 53 hunt lvl 

As for more info, there was nothing more i could tell you, no logger info or anything. 

There's plenty of information you can give me. Where you are hunting (screenshot), which chinchompas, settings, LG or not, which client etc. etc. You just choose not to. And that is completely fine. Completely up to you if you are willing or have the time to give me all the information. You just need to understand that I cannot really do anything about your issue if everything works just fine on my end. Tested the script for several hours.

Edited by Aropupu

Share this post


Link to post
Share on other sites

This script is quite temperamental. Sometimes it works fine, other times it doesn't, even with the exact same settings. It loses box traps all the time and for that reason I have to take 20ish traps. Same with net traps. I think it loses traps because it tries to place a trap, and then sees no trap on the ground, so immediately tries again to place a trap. What then happens is you have 1 trap which is on the ground (lay or take position) and another trap which is setup. The bot doesn't pick up the trap which is underneath.

I think the main problems come from the setup and the fact that you have to select your trap areas. This applies to both salamanders and chinchompas.

Share this post


Link to post
Share on other sites
20 hours ago, Condor said:

@Aropupu I'm doing swamp lizards and the click for the next action is happening too quickly. It clicks on the next action, but hasn't completed the one it's currently working on, which doesn't register the click. 

Looks non-human like.

Can take a look when I can but please tell what your settings are, especially if you changed anything

Edited by Aropupu

Share this post


Link to post
Share on other sites
On October 23, 2017 at 8:33 AM, Aropupu said:

Can take a look when I can but please tell what your settings are, especially if you changed anything

@Aropupu Let me take a look tonight. Going to try it at orange salamanders now. I will note my settings.

 

UPDATE:

AFK setting enabled. Clicking next priority action item too quickly. (i.e. trap failed [rope and net on ground] and the script was checking a trap then clicked to pickup the rope on the ground to quickly, as in it was still completing previous animation)

 

Does that make sense?

Edited by Condor

Share this post


Link to post
Share on other sites
17 hours ago, Condor said:

@Aropupu Let me take a look tonight. Going to try it at orange salamanders now. I will note my settings.

 

UPDATE:

AFK setting enabled. Clicking next priority action item too quickly. (i.e. trap failed [rope and net on ground] and the script was checking a trap then clicked to pickup the rope on the ground to quickly, as in it was still completing previous animation)

 

Does that make sense?

Unable to recreate the issue you are having. Nothing like you describe is happening on my end.

EDIT: I made an update based on a guess of what could be causing the issue for you. Hopefully it fixes the issue.

Share this post


Link to post
Share on other sites
8 hours ago, Aropupu said:

Unable to recreate the issue you are having. Nothing like you describe is happening on my end.

EDIT: I made an update based on a guess of what could be causing the issue for you. Hopefully it fixes the issue.

I can try to recreate it and screen cap it in some way. If not, I can and am happy to share my screen via Skype or some format if you care to see. (of course pending my ability to recreate the issue)

Share this post


Link to post
Share on other sites

@Aropupu There is something weird that happens.  For instance, when a trap fails (net trap = net + rope) and the items are on the ground.  It clicks the first item, and as it's running it tries to click or move the mouse to the next item to pick up. 

 

The mouse moves in a very odd/slow way compared to all other movements.  Have you seen this? Happy to share a recording with you if needed.

Share this post


Link to post
Share on other sites
19 hours ago, Condor said:

@Aropupu Whatever you did, it fixed the issue I was having :)

 

Does the script not move the camera at all? (i.e. via arrow keys or other)

ABC2 handles antiban camera movement.

19 hours ago, Condor said:

@Aropupu There is something weird that happens.  For instance, when a trap fails (net trap = net + rope) and the items are on the ground.  It clicks the first item, and as it's running it tries to click or move the mouse to the next item to pick up. 

 

The mouse moves in a very odd/slow way compared to all other movements.  Have you seen this? Happy to share a recording with you if needed.

Mouse movement is done by Tribot.

Share this post


Link to post
Share on other sites

This is one of the best-made scripts I've ever used. But I've been testing it extensively over the past couple days and there has been one bug that sometimes occurs. Would it be possible for you to add an option to not move the camera angle? I've noticed that when I'm running the script it would sometimes lower the camera angle, it's rare but sometimes it would misclick the tile and set up a trap on a tile that isn't one of the preset one's used for hunting. This would waste a trap (bot doesn't pick it back up) then and the tile where the trap was supposed to go will no longer be in use (the white box disappear from that tile).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
      • 49 replies
    • Come give us feedback on the next version of TRiBot!
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...