Jump to content
TRiLeZ

TRiBot Beta 7.12_0

Recommended Posts

Great thanks, have you addressed the bug where it sometimes tries to click tiles off the minimap? This only happens when you first start webwalking. 

I addressed an issue where minimap tiles where in-accurately calculated depending on the camera angle. So I think that should fix the off-minimap tile clicking.

 

 

great update. :)

 

@Trilez Is it possible if you could make Grounditems detect amounts?

I don't believe it's possible to detect Ground Item stack.

Share this post


Link to post
Share on other sites

I addressed an issue where minimap tiles where in-accurately calculated depending on the camera angle. So I think that should fix the off-minimap tile clicking.

 

 

I don't believe it's possible to detect Ground Item stack.

 

Does WebWalking support the wild yet? Everytime I tried to use it for a tile in the wild, it walked west (even if I was only a few squares on the south side of the ditch). It seemed to work when I was actually in the while, though.

Share this post


Link to post
Share on other sites

Does WebWalking support the wild yet? Everytime I tried to use it for a tile in the wild, it walked west (even if I was only a few squares on the south side of the ditch). It seemed to work when I was actually in the while, though.

No, not yet. It will soon though.

Share this post


Link to post
Share on other sites

Hey Trilez, did any1 reported tribot breaks with the latest update on linux yet? I was running some scripts and the script ended abruptly http://imgur.com/mqgi0pz, so I restarted the client and it prompted me to redownload the jar file as its outdated, to the newest 1.61. The login interface pops out and after entering credentials and clicking on login, it takes forever to load and the interface where you select "new client" doesn't pop out but this instead http://imgur.com/rT75gFM. I tried changing forum password as suggested by druid but does no difference. If this is because of the latest update, a fix/update would be greatly appreciated :D Thanks!

Share this post


Link to post
Share on other sites

On ubuntu, when running multiple bots either a client goes all white when switching screens,can kill the process with task manager only, or all the clients freeze and cant even close them, only solution is restarting the vnc

can't provide any errors logs because theres none, and no, cpu isn't even over 60% and got enough ram for it, never goes over 40%, even changed the max heap size to 1gb

started happening since TRiBot Beta 7.03_0 i think

Share this post


Link to post
Share on other sites

To be honest, client version 7.0_25 was the best I still got some clients opened.

Facts about version 7.0_25:

1. They take a lot less cpu then the current version of client (running on centos 5.9,7.0_25v takes around 2 times less cpu then the current tribot client version)

2. They don't crash, non of my 7.0_25 clients crashed and with current version of the client you get white-out every ~5 hours and you can't even kill the process (kill (pid) or killall java, won't even kill the client that froze, you have to reboot computer..).

 

Could it be possible to backup 7.0_25 version of client? Because it was the best one for linux users =)

Maybe I am missing something and we can boot older version of the client, but I just don't how?

 

EDIT: I just realized that 1.7.0_25 is my java version and that's not a tribot client's version. I can't check the version of the client, since message from client's log is gone :/. However I know that client used Tribot loader 1.58

Edited by yutpod
  • Like 1

Share this post


Link to post
Share on other sites

To be honest, client version 7.0_25 was the best I still got some clients opened.

Facts about version 7.0_25:

1. They take a lot less cpu then the current version of client (running on centos 5.9,7.0_25v takes around 2 times less cpu then the current tribot client version)

2. They don't crash, non of my 7.0_25 clients crashed and with current version of the client you get white-out every ~5 hours and you can't even kill the process (kill (pid) or killall java, won't even kill the client that froze, you have to reboot computer..).

 

Could it be possible to backup 7.0_25 version of client? Because it was the best one for linux users =)

Maybe I am missing something and we can boot older version of the client, but I just don't how?

Ahh not only me noticed that bot uses a lot more cpu. I'm using win8

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
      • 23 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
      • 22 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      [NEW] Bug fix for intelligent banking


      [NEW] Improvement to the stability of LG over time


      [NEW] Vastly improved the reliability and speed of Screen#getColorAt on both LG and the regular client


      [NEW] Fix LG login problems


      [NEW] Fixed re-sizable mode container bug


      [NEW] Fixed re-sizable mode mouse bug


      [NEW] Use of public constants in the Banking API


      [NEW] Use of other various constants such as Projection#NULL_PT and Screen#EMPTY_COLOR



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
      • 12 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×