Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Encoded

[Lite] Encoded Fisher

Recommended Posts

script doesn't work, update it please

 

i get this error;   

 

  • [09:10:32] Exception in thread "P[1346812167]"
  • [09:10:32] java.lang.NoSuchMethodError: org.tribot.api2007.Walking.invertPath([Lorg/tribot/api2007/types/RSTile;)[Lorg/tribot/api2007/types/RSTile;
  • [09:10:32] at scripts.Fisher.(Fisher.java:202)
  • [09:10:32] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
  • [09:10:32] at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
  • [09:10:32] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
  • [09:10:32] at java.lang.reflect.Constructor.newInstance(Unknown Source)
  • [09:10:32] at java.lang.Class.newInstance(Unknown Source)
  • [09:10:32] at org.tribot.script.ScriptHandler.start(pk:20)
  • [09:10:32] at obf.sf.run(qo:1046)
  • [09:10:32] at java.lang.Thread.run(Unknown Source) 

Share this post


Link to post
Share on other sites

 

script doesn't work, update it please

 

i get this error;   

 

  • [09:10:32] Exception in thread "P[1346812167]"
  • [09:10:32] java.lang.NoSuchMethodError: org.tribot.api2007.Walking.invertPath([Lorg/tribot/api2007/types/RSTile;)[Lorg/tribot/api2007/types/RSTile;
  • [09:10:32] at scripts.Fisher.(Fisher.java:202)
  • [09:10:32] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
  • [09:10:32] at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
  • [09:10:32] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
  • [09:10:32] at java.lang.reflect.Constructor.newInstance(Unknown Source)
  • [09:10:32] at java.lang.Class.newInstance(Unknown Source)
  • [09:10:32] at org.tribot.script.ScriptHandler.start(pk:20)
  • [09:10:32] at obf.sf.run(qo:1046)
  • [09:10:32] at java.lang.Thread.run(Unknown Source) 

 

Did you already update to 1.00_7?

I'm assuming you haven't as you're the only one posting problems still after I updated all my scripts yesterday.

Edited by Encoded

Share this post


Link to post
Share on other sites

I am not, It's crazy fast though; I drop the entire inventory within 6 seconds is that normal?  I'll restart tribot and see if maybe it just bugged on me.

Yeah that's normal, I'm about to release shilo village so I'll see if slowing down the mouse fixes your problem.


I'm starting to not see a point in shilo fishing unless you want to bank the fish. Barb village spots are much closer together.

 

Alright I am going to make shilo fish at the south shore only as that will be most effective for banking. In my opinion if you are going for xp you should fish at barb village.

 

Shilo is done, just testing for a few hours to make sure it's stable. I will be working on requirements for swan song.

Edited by Encoded

Share this post


Link to post
Share on other sites

Hey man script is acting kind of funny, just caught it stuck in the bank moving the mouse around in 3 random spots. I was doing fishing guild barehand swords/tuna

 

nyfe3k.png

 

This ^ while the status says walking to bank. It seems to be trying to click the empty bank booth on the north wall instead of the normal bank booths.

Edited by K ReeGZ

Share this post


Link to post
Share on other sites

Hey man script is acting kind of funny, just caught it stuck in the bank moving the mouse around in 3 random spots. I was doing fishing guild barehand swords/tuna

 

nyfe3k.png

 

This ^ while the status says walking to bank. It seems to be trying to click the empty bank booth on the north wall instead of the normal bank booths.

That's tribot's banking api for you, I guess I better switch back to my custom banking methods.

 

Actually I'll just make it use the bankers to bank.

 


 

Download the script again, it will now use the banker rather than the booth to bank.

Edited by Encoded

Share this post


Link to post
Share on other sites

Could you test it out? It is now having trouble clicking on the fishing spots lol

 

it seems its not clicking the correct spots anymore? when i do shark fishing @ fishing guild doesnt matter what platform it keep click on cage/net fishing spot and its not cliking on it so its keep stand and spamm click the location

 

Sorry about that guys, download from the original post and replace your old fisher.tribot.

I made the transition to not using ids.

You'll thank me later when ids change and this script still works while others don't.

Share this post


Link to post
Share on other sites

Hello. This is a very good script! Thanks a lot for it! But I have noticed a big issue, I'm not sure if I'm the only one who has this but after about 2 hours, at the barbarian fishing spot, the bot just clicked back and forth between the spots, not letting itself catch any fish. I corrected it myself and it worked fine for another 10 minutes and then It started clicking back and forth again. Can I have a little help please? :P

Share this post


Link to post
Share on other sites

Hello. This is a very good script! Thanks a lot for it! But I have noticed a big issue, I'm not sure if I'm the only one who has this but after about 2 hours, at the barbarian fishing spot, the bot just clicked back and forth between the spots, not letting itself catch any fish. I corrected it myself and it worked fine for another 10 minutes and then It started clicking back and forth again. Can I have a little help please? :P

Did this only happen once and not every time you run the script? And by barbarian fishing spot you mean the leaping fish correct?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This release will:

      Add new internal framework for capturing exceptions


      Fix issue with not selecting the last column in world hopper (Thanks @Todd)


      Add a message about pin usage in Banking#openBank (Thanks @Todd)


      Disable the firewall by default (Thanks @Todd)


      Fix handling of the welcome screen after login (Thanks @Encoded)


      Fix wrong amount bank withdrawal (Thanks @Encoded)


      Fix Screen#isInViewport


      Fix Game#isInViewport (Thanks @Encoded)


      Call onBreakEnd for ListenerManager Breaking Listeners (Thanks @Encoded)


      Fix Prayer#getPrayerPoints NumberFormatException (Thanks @JoeDezzy1)



      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Thanks
        • Like
      • 19 replies
    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 64 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 34 replies
    • This release will:

      Fix an issue where breaks would stop firing


      Fix Combat#getWildernessLevel, use dynamic search for text and cache ID for later calls


      Fix an NPE in the Combat API


      Fix Mouse#leaveGame bug where the mouse wouldn't actually leave the game screen
        • Like
      • 21 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×