Jump to content
Encoded

[Lite] Encoded Fisher

Recommended Posts

Often at leap fishing drop it uses a fish and then uses that on other fishes, also it won't even drop whole inv 3 fishes keeps in or even more

That's what would happen if you were doing real mouse key dropping as well, sometimes it cant get all of them. And mouse key dropping is actually allowed by jagex/ If it uses the fish on the other fish this could be from your lag or you moving the mouse.

Share this post


Link to post
Share on other sites

That's what would happen if you were doing real mouse key dropping as well, sometimes it cant get all of them. And mouse key dropping is actually allowed by jagex/ If it uses the fish on the other fish this could be from your lag or you moving the mouse.

 

not lagging not moving the mouse

Share this post


Link to post
Share on other sites

Often at leap fishing drop it uses a fish and then uses that on other fishes, also it won't even drop whole inv 3 fishes keeps in or even more

You aren't the first to tell me this, however I personally have never had it happen so it is hard to fix a problem you don't have. Do you know why it may have clicked use rather than drop, did you see it happen?

 

http://i40.tinypic.com/2qa2zk2.png

 

continuously clicks the wrong option in this case here when two spots are on top of eachother. In this case I was doing sword/tuna so it picks the first option

That is in my known bugs section, the client isn't able to detect the difference between the two options.


On another note, I will be posting a guide in the original post on how to always have the most recent script without having to download anything after an update.

 

I accidentally put my tanner in the same file as my fisher so if you are wondering why you have it, that may be why.

Edited by Encoded

Share this post


Link to post
Share on other sites

You aren't the first to tell me this, however I personally have never had it happen so it is hard to fix a problem you don't have. Do you know why it may have clicked use rather than drop, did you see it happen?

 

That is in my known bugs section, the client isn't able to detect the difference between the two options.


On another note, I will be posting a guide in the original post on how to always have the most recent script without having to download anything after an update.

 

I accidentally put my tanner in the same file as my fisher so if you are wondering why you have it, that may be why.

 

Nope I haven't.. sorry

Share this post


Link to post
Share on other sites

great ! :)

Alright updated it, let me know if that works or not for you.

 

You should be using version 1.00_5


Once I get all these kinks worked out, I am going to be working on making this script not use any ids.

Edited by Encoded

Share this post


Link to post
Share on other sites

http://i40.tinypic.com/2qa2zk2.png

 

continuously clicks the wrong option in this case here when two spots are on top of eachother. In this case I was doing sword/tuna so it picks the first option

I've come up with a fix but it's going to take me a bit to implement it. I'll get back to you when it's working.

 

Got it working a lot faster than I thought, testing it for a bit then I'll post it.

 

Alright posting it and then getting some sleep, let me know if I broke anything with this fix as I had to change my fishing method quite a bit.

Edited by Encoded

Share this post


Link to post
Share on other sites

after about 4 hours of running flawlessly at otto's grotto i get this error.

 

[11:55:01] java.lang.NullPointerException
[11:55:01] at scripts.Fisher.state(Fisher.java:393)
[11:55:01] at scripts.Fisher.run(Fisher.java:245)
[11:55:01] at java.lang.Thread.run(Unknown Source)
[11:55:01] Script Ended: Encoded Fisher.

Share this post


Link to post
Share on other sites

 

after about 4 hours of running flawlessly at otto's grotto i get this error.

 

[11:55:01] java.lang.NullPointerException
[11:55:01] at scripts.Fisher.state(Fisher.java:393)
[11:55:01] at scripts.Fisher.run(Fisher.java:245)
[11:55:01] at java.lang.Thread.run(Unknown Source)
[11:55:01] Script Ended: Encoded Fisher.

 

What version are you running? Line 393 can't throw that error in the current version so I'll have to go back and look at the older one to find out where that is. (It tells you the version when you start the script in the client debug tab at the bottom of the client)

Share this post


Link to post
Share on other sites

What version are you running? Line 393 can't throw that error in the current version so I'll have to go back and look at the older one to find out where that is. (It tells you the version when you start the script in the client debug tab at the bottom of the client)

 

I had the same problem, I'm running 1.00_5

Share this post


Link to post
Share on other sites

I had the same problem, I'm running 1.00_5

Weird I thought I updated to 1.00_6 last night but apparently not. Anyhow, I think I fixed this.

Download and replace your old fisher.tribot file in the scripts folder. Should print version 1.00_6 when you start the script.

Edited by Encoded

Share this post


Link to post
Share on other sites

Was running perfectly, untill;
 

 

  • [20:28:16] java.lang.NullPointerException 
  • [20:28:16] at scripts.Fisher.run(Fisher.java:351) 
  • [20:28:16] at java.lang.Thread.run(Unknown Source) 
  • [20:28:16] Encoded Fisher: Thank you for using Encoded Fisher. 
  • [20:28:16] Script Ended: Encoded Fisher. 

I am running 1.00_6, not trying to complain, just thought I'd let you know.

Share this post


Link to post
Share on other sites

Was running perfectly, untill;

 

 

  • [20:28:16] java.lang.NullPointerException 
  • [20:28:16] at scripts.Fisher.run(Fisher.java:351) 
  • [20:28:16] at java.lang.Thread.run(Unknown Source) 
  • [20:28:16] Encoded Fisher: Thank you for using Encoded Fisher. 
  • [20:28:16] Script Ended: Encoded Fisher. 

I am running 1.00_6, not trying to complain, just thought I'd let you know.

Let me run the script for a few hours and make sure I actually fix it this time because I know this error doesn't occur right away. Out of curiosity, where were you using the script at?

Share this post


Link to post
Share on other sites

Let me run the script for a few hours and make sure I actually fix it this time because I know this error doesn't occur right away. Out of curiosity, where were you using the script at?

Leaping fish, and you're right about not doing it at the start, it was running for a while. 

Share this post


Link to post
Share on other sites

Great bot, but for some reason hogs alot of cpu, around 2-3x as much as other fishing bots. Could you please look into this?

Thanks

That's strange, mine only uses roughly 200k memory and I'm not even in lite mode. I'll try and reduce the paint's file size and see if that helps.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
      • 24 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
      • 22 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      [NEW] Bug fix for intelligent banking


      [NEW] Improvement to the stability of LG over time


      [NEW] Vastly improved the reliability and speed of Screen#getColorAt on both LG and the regular client


      [NEW] Fix LG login problems


      [NEW] Fixed re-sizable mode container bug


      [NEW] Fixed re-sizable mode mouse bug


      [NEW] Use of public constants in the Banking API


      [NEW] Use of other various constants such as Projection#NULL_PT and Screen#EMPTY_COLOR



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
      • 12 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×