Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Leespiker

[SEPT 28 UPDATE] Spiker Warriors' Guild Defender-er

112 posts in this topic

Updated to v1.31.  Let me know if you have anymore lagging problems, and please be as detailed as possible with your GUI settings, and what was currently happening as well as the debug output at the bottom.

Share this post


Link to post
Share on other sites

It leaves once it gets a new defender right?

I minimized it for a second, it found a black defender, and I had it minimized for maybe 90 seconds, and i came back it was fighting a cyclopse. 
Maybe it did leave.



Edit:
Found a problem, 
If you try to pause it and do something by hand, bot goes all laggy, if you try to go to another tab, bot goes all laggy, 
Only way to fix this is to go back to inventory tab . . then it should continue working fine. 


Edit: It does not go outside to get a new defender. No worries though. Just noticed it because I came back . . and had two mithril defenders in my inventory :P. No worries, went from steel - mith in 30 mins. 

Edit: got steel - rune in an hour or so, thanks buddy!

Edited by 714

Share this post


Link to post
Share on other sites

It leaves once it gets a new defender right?

I minimized it for a second, it found a black defender, and I had it minimized for maybe 90 seconds, and i came back it was fighting a cyclopse. 

Maybe it did leave.

Edit:

Found a problem, 

If you try to pause it and do something by hand, bot goes all laggy, if you try to go to another tab, bot goes all laggy, 

Only way to fix this is to go back to inventory tab . . then it should continue working fine. 

Edit: It does not go outside to get a new defender. No worries though. Just noticed it because I came back . . and had two mithril defenders in my inventory :P. No worries, went from steel - mith in 30 mins. 

Edit: got steel - rune in an hour or so, thanks buddy!

 

Will be updating the script very soon (by tomorrow) to fix the lag and other problems.  New version has many, many fixes.

Share this post


Link to post
Share on other sites

ever since you've updated it, it seems pretty flawless other than the lag when you try to click combat tab or tools tab etc.

Edited by DanielC1989

Share this post


Link to post
Share on other sites

ever since you've updated it, it seems pretty flawless other than the lag when you try to click combat tab or tools tab etc.

Yes it should. I'll look into it.

Share this post


Link to post
Share on other sites

Version 1.5 is out! I have fixed all known problems and more!

 

To name a few:

  • If you are under level 76, it right-clicks all cyclopes to attack.
  • NO MORE LAG!
  • Fixed any and all crashes due to NullPointerException, etc.
  • Loots faster.
  • More antiban.
  • Correctly leaves the room to show Kamfreena your new defender (if not rune).

Enjoy!  :D

Edited by Leespiker

Share this post


Link to post
Share on other sites

Version 1.51 is out!

 

Enjoy the fresh new progress report paint.

 

It now tracks prayer xp and prayer xp per hour.  

 

Post some progress reports to brag about!

 

Enjoy!  :D 

 

EDIT: I also added an open source link.  Hope everyone can learn something from it!

Edited by Leespiker

Share this post


Link to post
Share on other sites

when I ran out of food it just randomly ran into the corner of the room and stopped there and didn't do anything? then I tried to pause the script get food out but then it just ran to the other corner and stood there? only fixed it by stopping and starting the script again

Share this post


Link to post
Share on other sites

when I ran out of food it just randomly ran into the corner of the room and stopped there and didn't do anything? then I tried to pause the script get food out but then it just ran to the other corner and stood there? only fixed it by stopping and starting the script again

Hmm, I'll take a look at it, thanks.

Share this post


Link to post
Share on other sites

when I ran out of food it just randomly ran into the corner of the room and stopped there and didn't do anything? then I tried to pause the script get food out but then it just ran to the other corner and stood there? only fixed it by stopping and starting the script again

 

Did this only happen once? It was when you ran out of food in your inventory in the cyclops room? Did it say anything in the debug output?

 

Which corners did it run to?  Was it trying to click outside the perimeter of the cyclops room?

Edited by Leespiker

Share this post


Link to post
Share on other sites

will try and get some reports for you so far

 

if your inventory is full and you plan on looting your guy will be stuck and stand still because their is no inventory space

Share this post


Link to post
Share on other sites

will try and get some reports for you so far

 

if your inventory is full and you plan on looting your guy will be stuck and stand still because their is no inventory space

 

Thanks for pointing this out.  I have fixed it and will push the update first thing in the morning.

Share this post


Link to post
Share on other sites

doesnt work to well for me, withdraws food eats one then goes back to the room fights till the hp gets to the dedicated number to eat food at and then instead of eating goes back to the bank deposits all food withdraws eats one and repeats :/ reaaly hoping to try this once fixed as i used your other bot for token and works flawlessly

Share this post


Link to post
Share on other sites

doesnt work to well for me, withdraws food eats one then goes back to the room fights till the hp gets to the dedicated number to eat food at and then instead of eating goes back to the bank deposits all food withdraws eats one and repeats :/ reaaly hoping to try this once fixed as i used your other bot for token and works flawlessly

 

Updating it today.

Share this post


Link to post
Share on other sites

GUI doesn't show xp for combat. The run time is working and the state. 

 

Edit: I'm using version 1.53 and it still runs to the bank when it gets to the set point to eat and deposits all the food then withdraws and eats one and repeats.

Edited by goldnight500

Share this post


Link to post
Share on other sites

GUI doesn't show xp for combat. The run time is working and the state. 

 

Edit: I'm using version 1.53 and it still runs to the bank when it gets to the set point to eat and deposits all the food then withdraws and eats one and repeats.

combat xp is working

Share this post


Link to post
Share on other sites

  • [22:28:58] Warriors' Guild Defender-er: Spiker's Warriors' Guild Defender-er v1.53 has started.

[22:29:46] java.lang.NoClassDefFoundError: org/tribot/api2007/WebWalking

[22:29:46] at scripts.WarriorsGuildDefenderer.attack(WarriorsGuildDefenderer.java:765)

[22:29:46] at scripts.WarriorsGuildDefenderer.run(WarriorsGuildDefenderer.java:113)

[22:29:46] at java.lang.Thread.run(Thread.java:724)

[22:29:46] Script Ended: Warriors' Guild Defender-er. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.