Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

I was running this flawlessly throughout today, then I received a message to update tribot.  After the update I am now receiving a mass of (Unknown source) errors upon starting up this script(with default settings, attempting to motherlode mine.)

 

I've pmed the OP a screenshot of the errors.

 

This is not a script issue.

 

You are using looking glass? It's a looking glass issue. It's in beta, expect it to be buggy.

 

If you are not using looking glass it still seems to be a connection issue.

 

Regardless, only Trilez can fix it if there anything to fix. There could also be a problem on your end. Try restarting tribot etc. and if you are using looking glass try restarting runescape too.

Share this post


Link to post
Share on other sites

 

This is not a script issue.

 

You are using looking glass? It's a looking glass issue. It's in beta, expect it to be buggy.

 

If you are not using looking glass it still seems to be a connection issue.

 

Regardless, only Trilez can fix it if there anything to fix. There could also be a problem on your end. Try restarting tribot etc. and if you are using looking glass try restarting runescape too.

 

 

My apologies, looks like I needed to restart my LG browser window and tribot.  it's now running great!

 

Thanks!

Share this post


Link to post
Share on other sites

Update:

- Added support for World Switcher. THIS FEATURE IS IN BETA, which means it can have bugs. I have tested it quite a lot and it seems to be working fine though. If you encounter a problem with it, please provide a picture of the situation and describe the problem as much as possible.

- Added a failsafe for Neitiznot.

Edited by Aropupu

Share this post


Link to post
Share on other sites

I recorded a runite run with debug on in the wildy if you would be interested in looking at it. I haven't uploaded it yet.

 

Unfortunately there's no benefit in something like this for me, because I can only work on it when I have time. When I have time I will test it myself etc.

Edited by Aropupu

Share this post


Link to post
Share on other sites

@Aropupu hey i payed for the premium version so i can use the crafting guild bot but it just trys to bank in the bank chest there for a couple minutes each trip then runs the long way to falador to bank can u change it so it can climb under the wall each time its 1000 time faster , 

Share this post


Link to post
Share on other sites

@Aropupu hey i payed for the premium version so i can use the crafting guild bot but it just trys to bank in the bank chest there for a couple minutes each trip then runs the long way to falador to bank can u change it so it can climb under the wall each time its 1000 time faster , 

 

@cjk

This is a bug, which was probably introduced when the bank chest was added to the crafting guild. It was never intended and because very few people use crafting guild, no one has reported it to me. I'll change it so that it will use the normal bank always. I'll let you know once it's done. I'll be able to do it later today when I get home.

 

EDIT: Should be fixed now.

Edited by Aropupu

Share this post


Link to post
Share on other sites

What the hell, the script ain't working yo. He ain't mining the runites, he isn't even moving
 

  • [15:29:37] TRiBot Release 9.223_6 loaded. (1.8.0_45:C:\Program Files (x86)\Java\jre1.8.0_45)
  • [15:29:38] Loading human mouse movement data.
  • [15:29:38] Could not load human mouse data. Reason: Human mouse data encryption key not found.
  • [15:29:57] java.net.ConnectException: Connection timed out: connect
  • [15:29:57] at java.net.DualStackPlainSocketImpl.connect0(Native Method)
  • [15:29:57] at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
  • [15:29:57] at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
  • [15:29:57] at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
  • [15:29:57] at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
  • [15:29:57] at java.net.PlainSocketImpl.connect(Unknown Source)
  • [15:29:57] at java.net.SocksSocketImpl.connect(Unknown Source)
  • [15:29:57] at java.net.Socket.connect(Unknown Source)
  • [15:29:57] at java.net.Socket.connect(Unknown Source)
  • [15:29:57] at java.net.Socket.(Unknown Source)
  • [15:29:57] at java.net.Socket.(Unknown Source)
  • [15:29:57] at obf.MB.H(nc:169)
  • [15:29:57] at obf.Nl.run(aab:126)
  • [15:29:57] at java.lang.Thread.run(Unknown Source)
  • [15:31:40] java.lang.InterruptedException: sleep interrupted
  • [15:31:40] at java.lang.Thread.sleep(Native Method)
  • [15:31:40] at scripts.b.run(loginCheck.java:53)
  • [15:31:40] at java.lang.Thread.run(Unknown Source)
  • [15:33:03] java.lang.InterruptedException: sleep interrupted
  • [15:33:03] at java.lang.Thread.sleep(Native Method)
  • [15:33:03] at scripts.b.run(loginCheck.java:53)
  • [15:33:03] at java.lang.Thread.run(Unknown Source)
Edited by bogdas123

Share this post


Link to post
Share on other sites

 

What the hell, the script ain't working yo. He ain't mining the runites, he isn't even moving

 

  • [15:29:37] TRiBot Release 9.223_6 loaded. (1.8.0_45:C:\Program Files (x86)\Java\jre1.8.0_45)
  • [15:29:38] Loading human mouse movement data.
  • [15:29:38] Could not load human mouse data. Reason: Human mouse data encryption key not found.
  • [15:29:57] java.net.ConnectException: Connection timed out: connect
  • [15:29:57] at java.net.DualStackPlainSocketImpl.connect0(Native Method)

 

 

@bogdas123

Please wait until Trilez fixes the client. It's not a script issue.

 

EDIT: Some problems should be fixed now. Banking is still broken as far as I know.

Edited by Aropupu

Share this post


Link to post
Share on other sites

is there a reason when using the world hop beta mining rune ore every time it logs into a new world it'll run to the start of the heroes guild and then back?

@Duke4eva

Probably caused by Tribot not detecting the correct information whenever runescape is changing the world. I didn't have this problem when I was using it so it could have something to do with how fast you change the world. I'll try to recreate it to find out how tribot fails.

 

Motherlode Mine works good or it bugs?

@tomelis3211

Use the free trial to test it if you don't already own this script.

Share this post


Link to post
Share on other sites

@Aropupu

 

This is what happens when it runs to the front of the guild after hopping using new world switch.

 

  • [00:12:19] java.lang.InterruptedException: sleep interrupted
  • [00:12:19] at java.lang.Thread.sleep(Native Method)
  • [00:12:19] at scripts.p.run(loginCheck.java:53)
  • [00:12:19] at java.lang.Thread.run(Thread.java:745) 
Edited by Duke4eva

Share this post


Link to post
Share on other sites

 

@Aropupu

 

This is what happens when it runs to the front of the guild after hopping using new world switch.

 

  • [00:12:19] java.lang.InterruptedException: sleep interrupted
  • [00:12:19] at java.lang.Thread.sleep(Native Method)
  • [00:12:19] at scripts.p.run(loginCheck.java:53)
  • [00:12:19] at java.lang.Thread.run(Thread.java:745) 

 

 

@Duke4eva

This is from the bot debug and doesn't tell me anything. I need the information from the client debug to know what's causing it. If you could PM that to me, it would be great.

Share this post


Link to post
Share on other sites

@Aropupu It is fixed, thank you so much!

 

EDIT: Now it's getting stuck at this

 

  • [09:28:01] Runite should be respawned in world 321. Hopping there.
  • [09:28:03] Runite should be respawned in world 321. Hopping there. 

and will stay doing that forever, without hopping. Only when using quickhop method

Edited by Duke4eva

Share this post


Link to post
Share on other sites

@Aropupu It is fixed, thank you so much!

 

EDIT: Now it's getting stuck at this

 

  • [09:28:01] Runite should be respawned in world 321. Hopping there.
  • [09:28:03] Runite should be respawned in world 321. Hopping there. 

and will stay doing that forever, without hopping. Only when using quickhop method

 

@Duke4eva

Thank you for the bug report. Will have to check this out to know what's causing it.

Share this post


Link to post
Share on other sites

Mining in Lumbridge swamp doesn't seem to work. The bot just walks to draynor instead.

 

Also, Mining in Varrock East is fairly bugged. The script often just sits not clicking any rocks when it first arrives after a bank run.

Edited by jantzaw

Share this post


Link to post
Share on other sites

Mining in Lumbridge swamp doesn't seem to work. The bot just walks to draynor instead.

 

Also, Mining in Varrock East is fairly bugged. The script often just sits not clicking any rocks when it first arrives after a bank run.

 

@jantzaw

Both locations are working just fine. You could be having client issues. Please try restarting or even reinstalling your client. If you are using Looking Glass, try using it without it and see if that helps. Looking glass is still in beta and can be buggy. Also, make sure you are not in resizable mode.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • This update features:

      Fixed broken hooks from today's update


      Fix wilderness level with RuneLite (Thanks @Todd)


      Add support for Kotlin .class files in scripts (Thanks @wastedbro)


      Overhaul Inventory API (Thanks @wastedbro)


      Add List support for common methods


      Change method grouping to make more sense (by functionality)


      Refactor methods to utilize Java 8 streams instead of cumbersome loops




      Recognize chatbox minimization (Thanks @JoeDezzy1)


      Fix Screen#isInViewport when NPC chat is open (Thanks @JoeDezzy1)


      Fix login bot bugs (Thanks @erickho123)


      Fix hint arrow return values (Thanks @Encoded)


      Fix depositAllExcept functionality (Thanks @wastedbro)


      Change containing box interface bound and adjust for Y values (Thanks @erickho123)
        • Like
      • 151 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
    • This release will:

      Add new internal framework for capturing exceptions


      Fix issue with not selecting the last column in world hopper (Thanks @Todd)


      Add a message about pin usage in Banking#openBank (Thanks @Todd)


      Disable the firewall by default (Thanks @Todd)


      Fix handling of the welcome screen after login (Thanks @Encoded)


      Fix wrong amount bank withdrawal (Thanks @Encoded)


      Fix Screen#isInViewport


      Fix Game#isInViewport (Thanks @Encoded)


      Call onBreakEnd for ListenerManager Breaking Listeners (Thanks @Encoded)


      Fix Prayer#getPrayerPoints NumberFormatException (Thanks @JoeDezzy1)



      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Thanks
        • Like
      • 28 replies
    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 64 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...