Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

Array
Posted (edited)
14 hours ago, nrwriter said:

Seems to be a large delay between mining the rocks. It waits a long time before selecting next one (iron rocks at al kharid). Any suggestions?

 

If it's caused by ABC2, you can disable ABC2 delays in script settings under Antiban --> ABC2 settings. If not, you should check the "Are you having problems with the script?" part of the first post. If those steps don't solve your issue, you should make a proper bug report containing your setup information, settings, full client debug and bot debug

11 hours ago, yagayaganiga said:

what happened to the cool paint with the miner dude. did i mess up settings or something because i cant see it anymore.

There seems to have been an issue getting the paint image for the paint. When it fails to get paint image it will default to text only paint. That should be fixed in the latest version. If you didn't see any paint information, even text, then you have most likely disabled the paint (check paint settings) or something else is wrong. You should provide a proper bug report in this case.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites

This script worked amazing. Currently nearing my one month auth. I used this script in upper lvl MLM on a very well progressed account. 200+ qps, 1800+ total, got me from 95-99 in a month. Obviously if youre questioning using this script be smart in the way you bot. If youre using it for end goals, dont run it for more than 3 hours a day. I did other things in game in between the times i was mining, as I was also doing MLM manually sometimes.
I also played with the clients AB-Delay settings switching them between -2, -3, and -4, causing the xp rates to vary as i let the script run for a couple hours every day. 
Also I had 

- deposit box enabled.

- the script to use the esc and minimap to close deposit box

- 6 trips to hopper before emptying sack

- drop gems

Thank you again for a great script Aropupu

Share this post


Link to post
Share on other sites

Damn, had 10 accounts running (all had 40 attack strength defence). Tryed to level them up before i mined so i wouldnt have 10 level 3 accounts running around looking suspicious as hell. Started up the bot last night for them to mine copper and tin to 15, then iron to 30 and of course start motherlode. The way my breaks are setup is 6 hours of gameplay over a 10 hour period. Woke up this morning and all my accounts were banned. Could be for a different reason (ie flagged before i ever started mining or something) but one thing I did notice was everytime my bots would bank, they would put their pickaxe back in the bank, start running back to the ore, realize they dont have a pick and go back to the bank to grab it. settings were bone stock other than equip pickaxes. Is motherlode as quick of a ban as spinning flax or something? And no I'm not blaming the script owner I just thought you guys who use the script should know to watch out for this.

Share this post


Link to post
Share on other sites

I just want to say I've been running this script for the last 2 weeks, with a good 18 hours or so a day of running it with no ban yet. I'm currently at 81 mining and I have to say great job. I'm relatively new to botting, but from the way everyone makes it sound, getting banned is an extremely common thing. I usually try to edit my settings even a little bit every time I run it, and I also ALWAYS use LG. I figure better safe than sorry, also for me it's simply for my main as I played a long time ago, got to a high level, forgot the account info/stopped playing for 10 years, and wanted to basically start where I left off. I also have used your agility client with much success as well!

Share this post


Link to post
Share on other sites
1 hour ago, cyberh0und said:

Any plans on sandstorm?

The sandstone grinder is already added. You can find a setting to enable using it by selecting quarry as location and going to quarry settings. You will need to select custom sandstone rocks though under custom settings.

Share this post


Link to post
Share on other sites
18 hours ago, Aropupu said:

The sandstone grinder is already added. You can find a setting to enable using it by selecting quarry as location and going to quarry settings. You will need to select custom sandstone rocks though under custom settings.

Ohh, okay. Will check it out.

Share this post


Link to post
Share on other sites
Posted (edited)

I used to use this bot a lot 1 year ago, im having serious banking issues now especially at motherloade. is this fixable ? ive tried playing with all the options nothings working

my banking issues are,

1) they either dump their pickaxe in the bank or,

2) just sit at the bank dumb founded not doing anything

I come back to them all logged off at the chest, ive tried deposit box , they still deposit the pickaxe

this never used to happen and I never had to play with the settings except for upper lvl ect

if anyone has any experience in this would be greatly appreciated thank you:)

Edited by Ondog

Share this post


Link to post
Share on other sites
Posted (edited)

[14:37:43] java.lang.NullPointerException

  • [14:37:43] at scripts.miner2.jc.I(BankHandler.java:1299)
  • [14:37:43] at scripts.miner2.jc.k(BankHandler.java:443)
  • [14:37:43] at scripts.miner2.jc.A(BankHandler.java:110)
  • [14:37:43] at scripts.miner2.z.L(Motherlode.java:137)
  • [14:37:43] at scripts.miner2.Main.B(Main.java:334)
  • [14:37:43] at scripts.miner2.Main.run(Main.java:187)
  • [14:37:43] at java.lang.Thread.run(Unknown Source)

    I had this error today. I just xed the client and opened again and it worked....  But now i am sitting here wondering what it was Aropupu`?

    Btw. for thoese who says thay have been banned.
    ---

    **i ONLY USE V2 NOT V3 YET**
     I have been running this script for 1-2 months with only two bans. (I am pretty sure i got flagged. by choosing for example 6 deposit with only 3 desposit enabled on the account or upper lvl without the requirements.  - so thats somehow my own fault.) .  i have botttet over 500mil in mlm with this script.  still have 8-9 accounts 85+ mining. 
    I doesnt change in my ABC2 deays -1-2-3-4-5 i just keep it on one of them. 
    The only thing that never got me banned was.... when i forgot putting the script stop function on.. so my oppunion. 

    - Be carefull when you setup ur script... (IMPORTANT if you run multi clients.) When you hover to the next client, the script your start will be the same as the last one, exept if you load or change it yourself. and THEN that client now has the last saved Aminer profile.
     
Edited by Mansemon
:-)

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Ondog said:

I used to use this bot a lot 1 year ago, im having serious banking issues now especially at motherloade. is this fixable ? ive tried playing with all the options nothings working

my banking issues are,

1) they either dump their pickaxe in the bank or,

2) just sit at the bank dumb founded not doing anything

I come back to them all logged off at the chest, ive tried deposit box , they still deposit the pickaxe

this never used to happen and I never had to play with the settings except for upper lvl ect

if anyone has any experience in this would be greatly appreciated thank you:)

Motherlode is working without any issues. I cannot know what's wrong on your end without any information. Please check the "Are you having problems with the script?" in the first post to fix most common Tribot issues. If those don't solve the issue, please make a proper bug report that includes full client debug and bot debug after encountering the issue and your settings. Information about if you are using looking glass and what client you are using could be useful too. Are you are using v2 or v3

1 hour ago, Mansemon said:

I had this error today. I just xed the client and opened again and it worked....  But now i am sitting here wondering what it was Aropupu`?

Your Tribot hooks were broken. Varbits returned null. Usually restarting tribot or deleting hooks fixes it.

Edited by Aropupu

Share this post


Link to post
Share on other sites
21 hours ago, Hoespitalized said:

what is wrong with the script version 2 doesn't even start version 3 runs

Seems to be working fine. Most likely something wrong with your settings. You should make a proper bug report. Check instructions under "Are you having problems with the script?" part of the first post. Check client debug and bot debug for any errors or messages.

Share this post


Link to post
Share on other sites
Posted (edited)

 I could use some assistance with the Motherload Mine, I have the script set to surrender veins even while mining but it still detects a player on my vein and changes mining spots? Any way to make it not check for other players and just mine wherever is available closest? Upper Level by the way. 

@Aropupu

Edited by oilup

Share this post


Link to post
Share on other sites

Hi everything works pretty well right now I just came across a small problem, in motherload mining

iv set to use gembag, and to empty then a gem is is full, but the bot script ends after it ends the gem sack

I came back and I could tell every bot stopped when they emptied their gem bag

any suggestions to fix this ? am I the only one having this issue? ty

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, oilup said:

 I could use some assistance with the Motherload Mine, I have the script set to surrender veins even while mining but it still detects a player on my vein and changes mining spots? Any way to make it not check for other players and just mine wherever is available closest? Upper Level by the way. 

@Aropupu

If you have the surrender option enabled, the script will surrender (stop mining) veins when someone comes to mine them with you. You need to disable that option. You should also disable options to "Prevent stealing veins from other players" and any upper level avoid player options if you don't want it to avoid players.

4 hours ago, Ondog said:

Hi everything works pretty well right now I just came across a small problem, in motherload mining

iv set to use gembag, and to empty then a gem is is full, but the bot script ends after it ends the gem sack

I came back and I could tell every bot stopped when they emptied their gem bag

any suggestions to fix this ? am I the only one having this issue? ty

The script will print a message or an error when the script stops. This will tell the reason it stops. Please include full client debug (and also bot debug) information after the script stops in your issue report.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, Aropupu said:

If you have the surrender option enabled, the script will surrender (stop mining) veins when someone comes to mine them with you. You need to disable that option. You should also disable options to "Prevent stealing veins from other players" and any upper level avoid player options if you don't want it to avoid players.

 


I completely misunderstood what that meant, thanks for the help! 

Share this post


Link to post
Share on other sites

Hey Aropupu,

Im at a total loss here. I purchased this script twice now and ive never gotten custom rocks to work. I followed everything in the having problems with this script thread and they still do not work. No matter what i do I cannot get any rocks in the quarry to select, or any rocks at all. Even the select nearest button returns the same error in the debug. 

[01:05:27] Starting client.
[01:06:06] Downloading script 'aMiner v2'.
[01:06:09] Script Started: aMiner v2.
[01:06:27] Rock not detected! Try again! If this continues, please try restarting your tribot client.
[01:06:38] Rock not detected! Try again! If this continues, please try restarting your tribot client.
[01:06:48] Rock not detected! Try again! If this continues, please try restarting your tribot client.
[01:06:49] If you want to select rocks with your mouse (click, right-click, middle mouse), use the 'Start selecting rocks' -button
[01:07:02] Rock not detected! Try again! If this continues, please try restarting your tribot client.

My settings file is blank from deleting everything and trying fresh so uploading that will do no good. Tried in resizable and also fixed with the same problem. I am selecting the quarry as the location and then trying to select the custom rocks since the quarry settings do not seem to work either, bot just stands there like it also isnt detecting rocks.

Hope you can help, thanks.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 49 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...