Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

Posted (edited)
9 hours ago, iK0u4ever said:
  • [01:46:15] Disabling Tribot's random dismisser for Motherlode. If you have dismissing enabled in motherlode settings, it will dismiss them
  • [01:46:15] Disabled all randoms.

Why does it say disabled all randoms when I unchecked it?

Motherlode will always "Disable all randoms" because Tribot's random dismisser doesn't work well in there. If you want it to dismiss randoms, enable it in the settings of the script.

Edited by Aropupu

Share this post


Link to post
Share on other sites

[10:36:29] Starting client.
[10:37:40] Downloading script 'aMiner v2'.
[10:37:44] Script Started: aMiner v2.
[10:37:47] Next AFK in 42.524532 minutes.
[10:37:47] Disabling Tribot's random dismisser for Motherlode. If you have dismissing enabled in motherlode settings, it will dismiss them
[10:37:47] Disabled all randoms.
[10:37:54] java.lang.NullPointerException
[10:37:54]     at org.tribot.api2007.Camera.setCameraAngle(gk:244)
[10:37:54]     at scripts.aMinerNEW.mc.e(Failsafes.java:94)
[10:37:54]     at scripts.aMinerNEW.Main.m(Main.java:212)
[10:37:54]     at scripts.aMinerNEW.Main.run(Main.java:175)
[10:37:54]     at java.lang.Thread.run(Thread.java:748)
[10:37:55] Script Ended: aMiner v2.
[10:38:14] Downloading script 'aMiner v2'.
[10:38:17] Script Started: aMiner v2.
[10:38:24] Next AFK in 34.768467 minutes.
[10:38:25] Disabling Tribot's random dismisser for Motherlode. If you have dismissing enabled in motherlode settings, it will dismiss them
[10:38:25] Disabled all randoms.
[10:38:30] java.lang.NullPointerException
[10:38:30]     at org.tribot.api2007.Camera.setCameraAngle(gk:244)
[10:38:30]     at scripts.aMinerNEW.mc.e(Failsafes.java:94)
[10:38:30]     at scripts.aMinerNEW.Main.m(Main.java:212)
[10:38:30]     at scripts.aMinerNEW.Main.run(Main.java:175)
[10:38:30]     at java.lang.Thread.run(Thread.java:748)
[10:38:30] Script Ended: aMiner v2.
[10:39:07] Downloading script 'aMiner v2'.
[10:39:11] Script Started: aMiner v2.
[10:39:13] Next AFK in 26.737534 minutes.
[10:39:13] Disabling Tribot's random dismisser for Motherlode. If you have dismissing enabled in motherlode settings, it will dismiss them
[10:39:13] Disabled all randoms.
[10:39:20] java.lang.NullPointerException
[10:39:20]     at org.tribot.api2007.Camera.setCameraAngle(gk:244)
[10:39:20]     at scripts.aMinerNEW.mc.e(Failsafes.java:94)
[10:39:20]     at scripts.aMinerNEW.Main.m(Main.java:212)
[10:39:20]     at scripts.aMinerNEW.Main.run(Main.java:175)
[10:39:20]     at java.lang.Thread.run(Thread.java:748)
[10:39:20] Script Ended: aMiner v2.
[10:39:30] Downloading script 'aMiner v2'.
[10:39:33] Script Started: aMiner v2.
[10:39:34] Next AFK in 36.5766 minutes.
[10:39:35] Disabling Tribot's random dismisser for Motherlode. If you have dismissing enabled in motherlode settings, it will dismiss them
[10:39:35] Disabled all randoms.
[10:39:40] Script Ended: aMiner v2.
[10:41:47] Downloading script 'aMiner v2'.
[10:41:50] Script Started: aMiner v2.
[10:42:09] Next AFK in 34.77775 minutes.
[10:42:09] Disabling Tribot's random dismisser for Motherlode. If you have dismissing enabled in motherlode settings, it will dismiss them
[10:42:09] Disabled all randoms.
[10:42:15] java.lang.NullPointerException
[10:42:15]     at org.tribot.api2007.Camera.setCameraAngle(gk:244)
[10:42:15]     at scripts.aMinerNEW.mc.e(Failsafes.java:94)
[10:42:15]     at scripts.aMinerNEW.Main.m(Main.java:212)
[10:42:15]     at scripts.aMinerNEW.Main.run(Main.java:175)
[10:42:15]     at java.lang.Thread.run(Thread.java:748)
[10:42:15] Script Ended: aMiner v2.

 

 

 

I tried starting it 3 time's to no avail. It hits the middle mouse button and toggles it on and off for the camera view, than stops script.

Share this post


Link to post
Share on other sites
Posted (edited)
32 minutes ago, supfreshs said:

 

I tried starting it 3 time's to no avail. It hits the middle mouse button and toggles it on and off for the camera view, than stops script.

Your tribot client is not working correctly. Most likely a hook issue. Please check the "Are you having problems with the script?" part of the first post of this thread for the most common fixes to Tribot issues. Most important steps are deleting hooks.dat, deleting jagex cache and restarting Tribot (instructions for everything in the first post).

Edited by Aropupu

Share this post


Link to post
Share on other sites
On 4/8/2019 at 11:19 PM, contemporary said:

Bot doesn't drop gems in MLM with either "drop gems" option enabled (in main tab, or MLM tab).

Seems to be dropping gems without any issues. Please do share all of your settings so I can take a better look at what might be causing your issue.

Share this post


Link to post
Share on other sites
Posted (edited)

ore mining order selection? Im mining a few ores using custom rock selections but the bot selects the rocks seemingly on random, It will ignore an ore 2 tiles away but will go and mine an ore 3 or 4 tiles away. Inefficient and not like a real player

Ive set the rock order and even had the bot mine in an order that i selected but it seems to ignore all of my settings and continues on ore random selection

EDIT:

NVM i have fixed it, just hadn't enabled the custom rock selection. perhaps greying out the options of the custom rock selection if it is not enabled would stop silly user errorfrom occurring?

Edited by remedy160

Share this post


Link to post
Share on other sites
On 4/14/2019 at 7:31 PM, johnleaf said:

Share settings with me pretty please. PM if you find it easier.

Location tab default

worldhopping normal mode with random hopping

motherlode use upper level  3 deposits drop hammer fix nearest wheel 

anti ban abc2-4 

 

pretty standard stuff lol just luck maybe

Share this post


Link to post
Share on other sites
18 hours ago, goon39148236 said:

literally jsut got banned at 97. RIP

Lets also establish exactly what other custom settings you were using as well.

Did you use any of the following custom settings? "mouse always goes off screen" "use max deposits" "move camera before clicking on vein" "fix only 1 wheel"

Also what were your break handler settings?

Personally I think always taking a hammer is less bot like because legit people grinding there are lazy in terms of getting a hammer every time they go to empty sack, it's easier to keep in inv as people will always follow the path of least resistance; same goes for fixing 1 wheel only.

 

Share this post


Link to post
Share on other sites

Amazing script! Got 80 mining on my F2P only ironman. I botted max 2 hours and trained other skills/quests too. Did ALOT of silver ore mining/banking with the world hop feature. Bots don't do that, so that might explain why i didn't get caught. Most bots just stand with 10 others at 2 iron ores LOL. 

New worlds got added so it gets stuck now, should be a simple fix for u tho :) 

Share this post


Link to post
Share on other sites
Posted (edited)
22 hours ago, kees421 said:

Amazing script! Got 80 mining on my F2P only ironman. I botted max 2 hours and trained other skills/quests too. Did ALOT of silver ore mining/banking with the world hop feature. Bots don't do that, so that might explain why i didn't get caught. Most bots just stand with 10 others at 2 iron ores LOL. 

New worlds got added so it gets stuck now, should be a simple fix for u tho :) 

Are you using in-game worldhopper or out of game worldhopper? What do you mean by getting stuck? Please describe exactly what happens for you. How often does it happen? Anything in client debug?

Also, have you tried the steps in "Are you having problems with the script?" part of the first post of this thread?

Edited by Aropupu

Share this post


Link to post
Share on other sites
20 hours ago, Aropupu said:

Are you using in-game worldhopper or out of game worldhopper? What do you mean by getting stuck? Please describe exactly what happens for you. How often does it happen? Anything in client debug?

Also, have you tried the steps in "Are you having problems with the script?" part of the first post of this thread?

These worlds got added last update:

  • W526 - 2200 skill total
  • W527 - 2000 skill total
  • W528 - 1500 skill total
  • W529 - 1250 skill total
  • W530 - 750 skill total (F2P)

Share this post


Link to post
Share on other sites

I use the ingame world hopper. I use f2p worlds only. The script starts at world 301, and i have it set so it goes down in order. (not random hopping). It all goes well, untill the bot reached the new worlds and it tried to click on it. But that doesn't work cuz im not a member. I don't remember exactly what world the bot clicked on, but most likely 526. I have not checked client debug. 

I have never experienced this again, because i use the option ''only use these worlds'' now. I select that to 301 to 504. So it never reaches the new worlds :) It is really amazing how many options the script has. Best script i have ever used. 

Share this post


Link to post
Share on other sites

I must say, the script is wokring very well at mlm.

i'm 5 days into my purchase, and have been half babysitting and botting 4/5 hours a day.  There have been no problems!

I currently have my antigen settings on ABC2-4 and have put afking on every 10-30 minuets. 

Are there any more ways I can increase my account not getting banned!? 

Thankyou very much for the script!! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • This update features:

      Fixed broken hooks from today's update


      Fix wilderness level with RuneLite (Thanks @Todd)


      Add support for Kotlin .class files in scripts (Thanks @wastedbro)


      Overhaul Inventory API (Thanks @wastedbro)


      Add List support for common methods


      Change method grouping to make more sense (by functionality)


      Refactor methods to utilize Java 8 streams instead of cumbersome loops




      Recognize chatbox minimization (Thanks @JoeDezzy1)


      Fix Screen#isInViewport when NPC chat is open (Thanks @JoeDezzy1)


      Fix login bot bugs (Thanks @erickho123)


      Fix hint arrow return values (Thanks @Encoded)


      Fix depositAllExcept functionality (Thanks @wastedbro)


      Change containing box interface bound and adjust for Y values (Thanks @erickho123)
        • Like
      • 148 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
    • This release will:

      Add new internal framework for capturing exceptions


      Fix issue with not selecting the last column in world hopper (Thanks @Todd)


      Add a message about pin usage in Banking#openBank (Thanks @Todd)


      Disable the firewall by default (Thanks @Todd)


      Fix handling of the welcome screen after login (Thanks @Encoded)


      Fix wrong amount bank withdrawal (Thanks @Encoded)


      Fix Screen#isInViewport


      Fix Game#isInViewport (Thanks @Encoded)


      Call onBreakEnd for ListenerManager Breaking Listeners (Thanks @Encoded)


      Fix Prayer#getPrayerPoints NumberFormatException (Thanks @JoeDezzy1)



      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Thanks
        • Like
      • 28 replies
    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 64 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
  • Recently Browsing   1 member

×
×
  • Create New...