Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

13 hours ago, IDontActuallyLift said:

@Aropupu

Im using the runite version of your mining script.  It functions correctly but when it hops to a world with ore in it it doesnt click on the ore.  It will hover over it but doesn't actaully click it.  I can give more information, im currently at work sorry. 

 

EDIT:

Worldhopping is broken too unfortunately. 

Seems to be clicking rocks just fine. Worldhopping also seems to be working just fine. Can't really do anything without more information. Settings, location, what actually happens etc.

Please do try the steps in "Are you having problems with the script?" part of the first post if you haven't already. Those usually solve all Tribot-related issues. Most important steps are deleting hooks.dat, reinstalling tribot and deleting your cache.

Edited by Aropupu

Share this post


Link to post
Share on other sites
Array
  • [11:58:24] Script Started: aMiner v2 [RUNITE].
  • [11:58:29] profile: TzhaarRunite
  • [11:58:32] When using shift-click dropping, always make sure it's enabled in Runescape settings!
  • [11:58:32] Next AFK in 32.032482 minutes.
  • [11:58:35] Current pickaxe is Dragon pickaxe
  • [11:58:36] Updating world list...
  • [11:58:36] Loading worlds
  • [11:58:36] Valid worlds, 302, 303, 304, 305, 306, 307, 309, 310, 311, 312, 313, 314, 315, 318, 319, 320, 321, 322, 323, 324, 327, 328, 330, 331, 332, 333, 334, 336, 338, 339, 340, 341, 342, 343, 344, 346, 347, 348, 350, 351, 352, 354, 355, 356, 357, 358, 359, 360, 362, 367, 368, 369, 370, 374, 375, 376, 377, 378, 386, 387, 388, 389, 390, 395, 421, 422, 494, 495, 496, 516, 517, 518, 519, 520, 521, 522, 523, 524, 525
  • [11:59:08] Debug: Failed to worldhop! Destination world: 359
  • [11:59:08] Debug information: 1 - 3 - false

 

When I start the bot in a world with no runite, it will attempt to hop and this occurs.  Not sure if the debug info is helpful.

When the script is started in a with with runite available, it will move the mouse over the rock but will not click.  The script stops after a while of nothing happening. 

The issue started to occur after tribots recent outage, I have reinstalled osbuddy and deteled my hooks.dat file.  I am using looking glass.  I will attempt to reinstall tribot to see if that helps the problem.

 

EDIT:

I switched over to runelite and everything seems to be working correctly now.

Edited by IDontActuallyLift

Share this post


Link to post
Share on other sites
1 hour ago, IDontActuallyLift said:

When I start the bot in a world with no runite, it will attempt to hop and this occurs.  Not sure if the debug info is helpful.

When the script is started in a with with runite available, it will move the mouse over the rock but will not click.  The script stops after a while of nothing happening. 

The issue started to occur after tribots recent outage, I have reinstalled osbuddy and deteled my hooks.dat file.  I am using looking glass.  I will attempt to reinstall tribot to see if that helps the problem.

EDIT:

I switched over to runelite and everything seems to be working correctly now.

Weird, could have been some weird LG issue then. I tested it with OSBuddy and it seemed to still work. The debug points to interfaces not being detected correctly or Tribot failing to click on an interface. That depends on exactly where it got stuck when trying to worldhop. Not sure about the being unable to click though. Those kind of issues are usually hook issues but LG could have its own issues.

I'm glad that you got it sorted out though! Lmk if anything else comes up or it reoccurs.

Edited by Aropupu

Share this post


Link to post
Share on other sites

Just a couple things i'd like to point out @Aropupu

1) Do you think you could add an auto checker / solver for when the account has not toggled the " Do not warn me about world hopping unless PVP world " for fresh accounts? or maybe if some users are afraid, to select the yes option when prompted. 

Occurs on fresh accounts that have not enable that option for using in game world hopper.

affects: aAgility + aMiner

2) May we please get an additional paint display for total nuggets in bank next to the amount mined on current session? maybe in parenthesis. not too much of a problem here, just would be nice.

 

Thanks!

Edited by theholyone

Share this post


Link to post
Share on other sites
14 hours ago, theholyone said:

Just a couple things i'd like to point out @Aropupu

1) Do you think you could add an auto checker / solver for when the account has not toggled the " Do not warn me about world hopping unless PVP world " for fresh accounts? or maybe if some users are afraid, to select the yes option when prompted. 

Occurs on fresh accounts that have not enable that option for using in game world hopper.

affects: aAgility + aMiner

2) May we please get an additional paint display for total nuggets in bank next to the amount mined on current session? maybe in parenthesis. not too much of a problem here, just would be nice.

 

Thanks!

1) There already should be a failsafe for that but could have got outdated with a Runescape update, will take a look. EDIT: This should be fixed now in the latest version of the script.

2) Can consider it

Edited by Aropupu

Share this post


Link to post
Share on other sites
13 hours ago, Core743 said:

How do you reduce ABC2 delay? I just want to mine for a bit some iron ores and the delay is quite long....as in....a normal human would be mining much faster.

You can find ABC2 settings in Antiban --> ABC2 settings. You can disable ABC2 delays completely (will use lower delays more suitable for powermining) or use the modifier (-5 = least amount of delays).

 

Share this post


Link to post
Share on other sites
5 hours ago, namstar said:

Whats too far? Can you share some data for learning experience

i think i botted for too long without taking a break (about 10 hours straight) but i was doing different skills. I did about 4 hours of agility, 3 hours of wintertodt, then 2.5 hours of motherload mine. I was not using Looking glass which could be a reason i got banned. i am currently getting another account up to the stats to try again with looking glass to see how long it lasts. i got banned 2.5 hrs in without looking glass at MLM.

Edited by Theycallmetubz
typo

Share this post


Link to post
Share on other sites

Getting a error with the script - Will not mine only just hops worlds. Same settings as I have used for my previous 50 accounts so not really sure what the error is? Says that it failed to worldhop but I'm literally watching it hop to the world stated.

I have it set so it only hops when someone talks in range - Which they're not yet it is still deciding to hop over and over and over and over and over and over and over and not mine anything



[17:48:47] Will start mining at Varrock West. Dropping: Tin Copper Worldhop

  • [17:48:49] Updating world list...
  • [17:48:50] Loading worlds
  • [17:48:50] Valid worlds, 302, 303, 304, 305, 306, 307, 309, 310, 311, 312, 313, 314, 315, 318, 319, 320, 321, 322, 323, 324, 327, 328, 330, 331, 332, 333, 334, 336, 338, 339, 340, 341, 342, 343, 344, 346, 347, 348, 350, 351, 352, 354, 355, 356, 357, 358, 359, 360, 362, 367, 368, 369, 370, 374, 375, 376, 377, 378, 386, 387, 388, 389, 390, 395, 421, 422, 424, 446, 466, 492, 493, 494, 495, 496, 514, 515, 516, 517, 518, 519, 520, 521, 522, 523, 524, 525
  • [17:49:57] Debug: Failed to worldhop! Destination world: 339
  • [17:49:57] Debug information: 2 - 6 - true
  • [17:49:57] Valid worlds, 302, 303, 304, 305, 306, 307, 309, 310, 311, 312, 313, 314, 315, 318, 319, 320, 321, 322, 323, 324, 327, 328, 330, 331, 332, 333, 334, 336, 338, 339, 340, 341, 342, 343, 344, 346, 347, 348, 350, 351, 352, 354, 355, 356, 357, 358, 359, 360, 362, 367, 368, 369, 370, 374, 375, 376, 377, 378, 386, 387, 388, 389, 390, 395, 421, 422, 424, 446, 466, 492, 493, 494, 495, 496, 514, 515, 516, 517, 518, 519, 520, 521, 522, 523, 524, 525
  • [17:49:57] Trying another world...
  • [17:50:07] Debug: Failed to worldhop! Destination world: 315

Share this post


Link to post
Share on other sites
35 minutes ago, ConnorM said:

Getting a error with the script - Will not mine only just hops worlds. Same settings as I have used for my previous 50 accounts so not really sure what the error is? Says that it failed to worldhop but I'm literally watching it hop to the world stated.

I have it set so it only hops when someone talks in range - Which they're not yet it is still deciding to hop over and over and over and over and over and over and over and not mine anything

[17:48:47] Will start mining at Varrock West. Dropping: Tin Copper Worldhop

It seems like you have "WORLDHOP when no rocks are available" enabled (Will start mining at Varrock West. Dropping: Tin Copper Worldhop). That could be causing the issue, but that would mean it isn't detecting the rocks itself. Please do check the "Are you having problems with the script?" part of the first post for the most common fixes to issues. Will send you a PM asking for your exact settings and more information. Seems to be working with settings I can see from your debug, doesn't worldhop.

When debug doesn't say that it's worldhopping because of player then it's not hopping because of a player near or talking. This means it's worldhopping because it's not detecting the rocks and that would only happen if they are all depleted or your TRibot client isn't working correctly and not detecting rocks.

Edited by Aropupu

Share this post


Link to post
Share on other sites
10 minutes ago, ConnorM said:

Can you make an option if the script gets in combat to run away?

I've had so many accounts die at varrock west - I'm guessing the script is miss clicking onto the mugger as nothing else would cause them to die.

Disable attack options in runescape settings:

ZtmdMFR.png

Share this post


Link to post
Share on other sites
18 minutes ago, ipk0wnu said:

not letting me click Runite on the box?

Are you using the runite version of the script? You also need to select a runite location. Some locations like the mining guild have the runite location as a separate option. All runite locations are separate in the location list. Please do share more about where you are trying to mine.

Edited by Aropupu

Share this post


Link to post
Share on other sites
3 minutes ago, Aropupu said:

Are you using the runite version of the script? You also need to select a runite location. Some locations like the mining guild have the runite location as a separate option. All runite locations are separate in the location list. Please do share more about where you are trying to mine.

messaged

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...