Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

6 hours ago, phickster said:

having a problem with the script it stops mining and says max amount of ores mined which lasts me about two inventories.  not sure if its a setting I can change or what some help would be appreciated

Sounds like you might have "Stop after ores mined" setting enabled. Please go to Antiban ---> Stop After in the script settings and make sure those are disabled.

If they are disabled, please include the full message or even better full client debug info. You can easily copypaste your entire client debug by right-clicking on the client debug tab and clicking on copy to clipboard.

DzdslQF.png

Share this post


Link to post
Share on other sites

thank you

On 8/27/2017 at 4:57 PM, Aropupu said:

Sounds like you might have "Stop after ores mined" setting enabled. Please go to Antiban ---> Stop After in the script settings and make sure those are disabled.

If they are disabled, please include the full message or even better full client debug info. You can easily copypaste your entire client debug by right-clicking on the client debug tab and clicking on copy to clipboard.

DzdslQF.png

fixed it thanks

Share this post


Link to post
Share on other sites

hey guys,

im just getting used to the script and btw, i love the way the anti-ban is set up .

im running into a problem when the bot always seems to try and switch worlds. The logger might be broken because it keeps on trying to switch to worlds it cant. 

It happened a few mins ago logging in from a break, i feel stupid but i cant find the option to turn this feature off. 

Thank You :)

Share this post


Link to post
Share on other sites
21 hours ago, runite sol said:

hey ive used this script before and last time it was very good, now i go to click start at mother lode mine after setting up some custom settings (just anti ban) and when i click start it wont start.

Mottherlode is currently working without any issues. Something is wrong on your end, most likely your Tribot client isn't working correctly. Please check the "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

If those don't solve the issue, please check both the bot debug and the client debug for any errors. You can easily copypaste both by right-clicking on them and selecting "Copy to clipboard":

DzdslQF.png

19 hours ago, sgt p0wned said:

hey guys,

im just getting used to the script and btw, i love the way the anti-ban is set up .

im running into a problem when the bot always seems to try and switch worlds. The logger might be broken because it keeps on trying to switch to worlds it cant. 

It happened a few mins ago logging in from a break, i feel stupid but i cant find the option to turn this feature off. 

Thank You :)

The script itself doesn't change worlds without a debug message unless you have "Worldhop when no rocks available" enabled. Please check your client debug and bot debug for any messages. You can easily copypaste both by right-clicking on them and selecting "Copy to clipboard":

DzdslQF.png

If the world changing happens when the login bot is trying to login, that's a tribot issue. Tribot's login bot can try to change worlds and tribot's worldhopper is currently broken most likely.

Share this post


Link to post
Share on other sites
  • [15:51:23] java.lang.NullPointerException
  • [15:51:23] at org.tribot.api2007.types.RSObject.getModel(bg:637)
  • [15:51:23] at org.tribot.api2007.types.RSObject.isClickable(bg:323)
  • [15:51:23] at scripts.aMinerNEW.oc.i(ClickingMethods.java:97)
  • [15:51:23] at scripts.aMinerNEW.v.g(Motherlode.java:696)
  • [15:51:23] at scripts.aMinerNEW.v.C(Motherlode.java:138)
  • [15:51:23] at scripts.aMinerNEW.Main.c(Main.java:243)
  • [15:51:23] at scripts.aMinerNEW.Main.run(Main.java:136)
  • [15:51:23] at java.lang.Thread.run(Thread.java:748)

i get a lot of errors every time im running the script in Motherlore

Share this post


Link to post
Share on other sites
48 minutes ago, Zaross said:
  • [15:51:23] java.lang.NullPointerException
  • [15:51:23] at org.tribot.api2007.types.RSObject.getModel(bg:637)
  • [15:51:23] at org.tribot.api2007.types.RSObject.isClickable(bg:323)
  • [15:51:23] at scripts.aMinerNEW.oc.i(ClickingMethods.java:97)
  • [15:51:23] at scripts.aMinerNEW.v.g(Motherlode.java:696)
  • [15:51:23] at scripts.aMinerNEW.v.C(Motherlode.java:138)
  • [15:51:23] at scripts.aMinerNEW.Main.c(Main.java:243)
  • [15:51:23] at scripts.aMinerNEW.Main.run(Main.java:136)
  • [15:51:23] at java.lang.Thread.run(Thread.java:748)

i get a lot of errors every time im running the script in Motherlore

Not a script issue. If you are using Looking Glass and the official Runescape client, please use some other client with LG. The official OSRS client doesn't work well with LG. OSBuddy is confirmed to work.

If you are not using the official OSRS client, please check the "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

Share this post


Link to post
Share on other sites
1 hour ago, shadowisle said:

it keeps on taking off my dpick? why is this?

Hard to say when you don't tell where you are mining and any settings you have changed. One possible cause is that you have enabled 4 or 7 deposits in motherlode mine which require placeholders and one of those is your pickaxe. If your issue even is that it unequips your pickaxe. Change your placeholders if it bothers you or disable 4 or 7 deposits.

Edited by Aropupu

Share this post


Link to post
Share on other sites
  • [21:09:50] Exception in thread "AWT-EventQueue-1"
  • [21:09:50] java.lang.NullPointerException
  • [21:09:50] at org.tribot.api.General.println(st:260)

 

Getting these errors when running the script for Varrock East

 

I have yet to test any other location. Going to try other now. As a developer, tried to debug but was unsuccessful. Not a huge java developer :P

 

Will edit post with more information to see if other spots produce same results.

Share this post


Link to post
Share on other sites
7 hours ago, GoldMineProductions said:

Unable to edit above post for whatever reason. Getting errors no matter what I do.

 

Using aMinerV1 without problems.

 

Would like to buy/use the premium version. However can't see myself just yet with the trial not working.

You should provide the full error instead of cutting it like that. So far it seems like something could be wrong on your end. Please check the "Are you having problems with the script?" part of the first post for the most common fixes to Tribot issues.

That's what the trial is for. Don't buy it if you don't like it or if it just doesn't work on your end.

Will send you a PM, please reply to that with full client debug info. But please try the troubleshooting steps on the first post.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
On 9/6/2017 at 4:33 AM, polak4_lyfe said:

This script worked wonders for me. Had no problems. On my way to 85 mining and 85 smithing (dax blast furnace)

Remember to bot smart, take breaks every 30 mins or so and you should be fine, also dont bot more then 8 hours daily i recommend.

That seems like overkill. 85 mining would take years if you only grinded for 30 minutes at a time

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 24 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 70 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 23 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...