Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

7 hours ago, TooGud said:

Alright, I'll post a screenshot next time it happens. It's always happened with no runes, but it doesn't happen often. Would you prefer the screenshot in a message or on here? I also think that the script got stuck in the room because the door just happened to shut before it could click in the shop.

If you send a PM it will be better. If it was caused by that it should be quite rare. Tribot sometimes missclicks quite badly while walking which can cause it to walk inside a building right when the door is going to close. I have added some failsafes for these circumstances in my aAgility script, but I need to know the exact place it happens in.

Share this post


Link to post
Share on other sites
Array
16 hours ago, Aropupu said:

If you send a PM it will be better. If it was caused by that it should be quite rare. Tribot sometimes missclicks quite badly while walking which can cause it to walk inside a building right when the door is going to close. I have added some failsafes for these circumstances in my aAgility script, but I need to know the exact place it happens in.

currently when the account receives a clue geode, it keeps it in the inventory instead of banking it. please fix thanks

Share this post


Link to post
Share on other sites
9 hours ago, ericcc1029 said:

currently when the account receives a clue geode, it keeps it in the inventory instead of banking it. please fix thanks

Thank you for letting me know, these should be added in the latest version. Restart script without using the rerun button to update it.

8 hours ago, godspower33 said:

@Aropupu It also doesn't drop these when power mining.

Why would you want to drop them?

Share this post


Link to post
Share on other sites

Seems to have problems in dwarven mines.

 

1) If I start the script in Fally East bank the script just stops, doesn't attempt to leave the bank

2) If I start it in the mine the script mines 1 inventory and then stops; doesn't attempt to leave the mine

 

Sorry for the crappy bug report, I don't have the debug/error and just started it up at a different location. Thought it was the client initially.

Share this post


Link to post
Share on other sites
2 hours ago, Bot2stake said:

Seems to have problems in dwarven mines.

 

1) If I start the script in Fally East bank the script just stops, doesn't attempt to leave the bank

2) If I start it in the mine the script mines 1 inventory and then stops; doesn't attempt to leave the mine

 

Sorry for the crappy bug report, I don't have the debug/error and just started it up at a different location. Thought it was the client initially.

Thank you for the bug report! Fortunately I didn't need any more information than this in this case.

Should be fixed in the latest version. Restart without using the rerun button to update it.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, WYD said:

Any update you working somehow to get this to work with LG?

The script works without any issues on LG. Tested it on an extremely laggy laptop too since I don't have access to my own computer currently. Most likely something is wrong on your end or your Tribot client isn't working correctly. Please check the "Are you having problems with the script?" part of the main post for most common fixes to Tribot issues. I cannot fix looking glass bugs or issues and LG is also in BETA testing.

If you are using the official runescape client, it doesn't currently work properly with Tribot's Looking Glass and only Trilez can fix it. Please try a normal browser or OSBuddy if you are using the official client.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
15 minutes ago, Aropupu said:

The script works without any issues on LG. Tested it on an extremely laggy laptop too since I don't have access to my own computer currently. Most likely something is wrong on your end or your Tribot client isn't working correctly. Please check the "Are you having problems with the script?" part of the main post for most common fixes to Tribot issues. I cannot fix looking glass bugs or issues and LG is also in BETA testing.

If you are using the official runescape client, it doesn't currently work properly with Tribot's Looking Glass and only Trilez can fix it. Please try a normal browser or OSBuddy if you are using the official client.

I was using the official Client do you think that why?

Share this post


Link to post
Share on other sites

This might be pretty obvious but for the abc2 modifier https://gyazo.com/b2973e3981ecd223a0d8a2cab7d592b6, i dont get if the higher the number u chose, the more frequent abc2 delays happen?

For example if i were to chose "-4 faster", would that have less frequent abc2 delays than "-2 faster"?  Can someone explain this to me

Share this post


Link to post
Share on other sites
5 hours ago, ericcc1029 said:

This might be pretty obvious but for the abc2 modifier https://gyazo.com/b2973e3981ecd223a0d8a2cab7d592b6, i dont get if the higher the number u chose, the more frequent abc2 delays happen?

For example if i were to chose "-4 faster", would that have less frequent abc2 delays than "-2 faster"?  Can someone explain this to me

Default = always use ABC2 delays

-1 = less frequent

-2 even less frequent etc.

If you run the script with the default settings you will notice that the ABC2 delay happens after every rock mined. The only way to go from there is less frequent.

I was using the official Client do you think that why?

Most likely yes

Edited by Aropupu

Share this post


Link to post
Share on other sites

bot debug

[13:02:01] TRiBot Release 9.303_6 loaded. (1.8.0_101:C:\Archivos de programa\Java\jre1.8.0_101)
[13:02:05] Loading human mouse movement data.
[13:02:05] Could not load human mouse data. Reason: Human mouse data encryption key not found.
[13:06:53] java.lang.NullPointerException
[13:06:53]     at scripts.aMinerNEW.Main.d(Main.java:284)
[13:06:53]     at scripts.aMinerNEW.Main.passArguments(Main.java:277)
[13:06:53]     at obf.Rf.run(do:242)
[13:06:53]     at java.lang.Thread.run(Unknown Source)
[16:49:56] Re-calc true
[19:03:05] java.lang.NullPointerException
[19:03:05]     at scripts.aMinerNEW.Main.d(Main.java:284)
[19:03:05]     at scripts.aMinerNEW.Main.passArguments(Main.java:277)
[19:03:05]     at obf.Rf.run(do:242)
[19:03:05]     at java.lang.Thread.run(Unknown Source)

client debug

[13:02:41] Starting client.
[13:06:50] Downloading script 'aMiner v2 [PREMIUM]'.
[13:06:53] Script Started: aMiner v2 [PREMIUM].
[13:06:57] Login bot started.
[13:06:57] Login Bot: Login...
[13:07:12] Login bot succeeded.
[13:15:31] Generating script antiban profile...
[13:15:33] Antiban profile successfully generated!
[13:15:33] Current pickaxe is Rune pickaxe
[13:52:36] We are attempting to solve the Dismissible Random random.
[13:52:38] We successfully solved the Dismissible Random random.
[15:48:25] We are attempting to solve the Dismissible Random random.
[15:48:28] We successfully solved the Dismissible Random random.
[16:01:55] XP failsafe is now disabled before breaking.
[16:01:55] Break Handler: Taking a break for: 00:47:39
[16:49:56] Break Handler: Break ended.
[16:49:56] XP failsafe is now enabled after breaking.
[17:10:08] We are attempting to solve the Dismissible Random random.
[17:10:10] We successfully solved the Dismissible Random random.
[17:32:42] The script didn't gain any xp/ores in 5 minutes. Logging out!
[17:32:42] If you think this was an error, you can disable this in the settings! (General -> Misc settings)
[17:32:42] Position: (2936, 3294, 0) - false
[17:32:42] 29380 - 29380
[17:33:01] Script Ended: aMiner v2 [PREMIUM].
[19:03:02] Downloading script 'aMiner v2 [PREMIUM]'.
[19:03:06] Script Started: aMiner v2 [PREMIUM].
[19:03:10] Login bot started.
[19:03:10] Login Bot: Login...
[19:03:24] Login bot succeeded.
[19:04:40] Generating script antiban profile...
[19:04:42] Antiban profile successfully generated!
[19:04:42] Current pickaxe is Rune pickaxe
[19:13:30] We are attempting to solve the Dismissible Random random.
[19:13:33] We successfully solved the Dismissible Random random.

My error is after using the crafting guild preset for gold, after a few hours (random) it would sit in the same spot outside the guild and after 5 min the xp failsafe would kick in logging out and ending the script. I've restarted tribot, pc, and other things still the same problem.

Share this post


Link to post
Share on other sites
5 hours ago, roklobster315 said:

My error is after using the crafting guild preset for gold, after a few hours (random) it would sit in the same spot outside the guild and after 5 min the xp failsafe would kick in logging out and ending the script. I've restarted tribot, pc, and other things still the same problem.

Are you using the f2p path option for Crafting Guild?

When I was testing it, the only situation when it could get stuck (rarely) in that tile was using the f2p path and that was caused by Tribot's WebWalking. I have now added a failsafe for it so it should be fixed if this was the case.

If you were not using the f2p path, do you have roofs disabled in Runescape? Can you tell me any other script settings you have changed, if you have? 

Edited by Aropupu

Share this post


Link to post
Share on other sites
19 hours ago, Aropupu said:

Are you using the f2p path option for Crafting Guild?

When I was testing it, the only situation when it could get stuck (rarely) in that tile was using the f2p path and that was caused by Tribot's WebWalking. I have now added a failsafe for it so it should be fixed if this was the case.

If you were not using the f2p path, do you have roofs disabled in Runescape? Can you tell me any other script settings you have changed, if you have? 

Yes I indeed was using the f2p path, I have roofs disabled. Maybe it was that bug what was causing it i'll get back to you if it happens again.

Share this post


Link to post
Share on other sites
On 9/28/2016 at 10:15 AM, Bot2stake said:

For some reason at Neitz it withdraws prayer pot, drinks, but won't bank it

Should be fixed in the latest version. Restart the script without using the rerun button to update it.

On 9/28/2016 at 0:14 AM, caesar846 said:

Hey is there any way to have the script mouseover the next rock? i can't find any way to do this and it really drives down my xp per hour. Any help is appreciated.

ABC2 decides when to hover over next rock. It's completely controlled by Tribot. Every account gets an unique profile and some accounts will hover more than others.

Hovering shouldn't affect xp that much while mining. Your xp/hr is most likely affected by something else and I cannot know what without more information. The script itself is working without any issues. If you have ABC2 delays enabled, those will bring your xp/hr down.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Bot2stake said:

Is worldhopping in the script or Tribot? Deadman worlds have it all screwed up. Tried to select a custom range of worlds not including any deadman worlds to work around this but it just gets stuck on log-in screen for some reason on the first hop-attempt

Jagex changed a lot of worlds to deadman worlds. They should be updated in the latest version. Filtering should also be fixed. Restart without using the rerun button to update.

  • Like 1

Share this post


Link to post
Share on other sites
5 minutes ago, Aropupu said:

Jagex changed a lot of worlds to deadman worlds. They should be updated in the latest version. Filtering should also be fixed. Restart without using the rerun button to update.

there notthing you can do about LG logging bug?

Share this post


Link to post
Share on other sites
18 minutes ago, WYD said:

there notthing you can do about LG logging bug?

If you mean the bug where sometimes even after breaks the login bot won't log back in to Runescape on LG, then no. I cannot fix Looking Glass bugs especially when they happen in a Tribot feature (in this case the login bot).

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • [CONTEST ANNOUNCEMENT] 2019 Botter's Choice Awards
      2019 Botter’s Choice Awards

      To celebrate the launch of our TRiBot Official RuneScape Bot Blog,

      we’re doing a giveaway! 

      The TRiBot Official RuneScape Bot Blog: 

      Teaching you how to do more advanced botting, faster.
      Contest Details

      Prize: 3 winners will be selected to win 25 TRiBot credits.

      How to enter:

      Respond to this forum post by November 12th tagging the thread for: 

      Your favorite script

      Provide a brief explanation (1-2 sentences) why you think that script should be put in the top 5. 

      Who can enter?

      Botter’s who are not currently scripters. Sorry scripters, the people are going to vote. Your contest is here.

      The top 5 in each category will be showcased on our TRiBot Official RuneScape Bot Blog in a “People’s Choice” section and promoted across the TRiBot website. 

      -- Credits will be awarded based on thoughtfulness and humor -- 

      Bonus points

      Use a meme in your explanation. Because we all love memes.

      *no purchase necessary. Winners will be announced on Friday, November 15, 2019 at 4:00 p.m. on our News and Announcements forum. 

      -- Vote Below -- 
        • Like
      • 28 replies
    • [READ TO THE END FOR A TEASER]

      I've noticed some new TRiBotters have had some troubles finding out sources of how to do certain things, such as using advanced scripts and often get lost in the forums.

      We are still getting posts asking where to start, what to do, recommended scripts, etc. 

      As many of you know, I am new to the team, and had troubles myself learning how to bot, let alone script. 

      So, what our team decided to do was make it easier to learn how to bot, how to script, and just become an overall better botter and scripter faster. 

      As some of you might have seen, I've posted 3 new blogs, you can check it out by clicking on the following picture or here.


      These first 3 blogs are the first of many blogs that will be TRiBot official. They are encouraged to be challenged, improved upon and act as A Best Practices Guide for Botters.

      What information would you like to see in the blogs?

      👇 [TEASER] 👇

      .

      .

      .

      We are going to be hosting a  CONTEST  this  OCTOBER.

      Its scary to think how soon you'll find out.👻

      Stay tuned.


      - RileyZ
      • 8 replies
    • Today marks a big day for TRiBot! To make it easier for users to use TRiBot, we've created installers available for every platform! These installers are all bundled with the latest version of OpenJDK 1.8 (Java 😎, which is LG compatible.

      Using TRiBot is now easy. Simply download the installer for your platform, install TRiBot, and run it. The TRiBot Loader will correctly identify the bundled JDK so there's no need to change the Java selection.

      Windows

      EXE installer: TRiBot-windows-x64-4.0.3.exe


      MSI installer: TRiBot-windows-x64-4.0.3.msi


      Portable version: TRiBot-windows-x64-4.0.3.zip


      Mac OS

      Installer: TRiBot-macos-4.0.3.dmg


      Portable version: TRiBot-macos-4.0.3.tgz


      Unix/Linux

      Installer: TRiBot-unix-4.0.3.sh


      RPM installer (CentOS/Fedora): TRiBot-linux-4.0.3.rpm


      DEB installer (Debian): TRiBot-linux-4.0.3.deb


      Portable version: TRiBot-unix-4.0.3.tar.gz


      Platform Independent

      JAR file: tribot-loader-4.0.3.jar


      Note that this jar file does not include the bundled JDK.



      Windows and Mac OS users may notice a warning message stating that the installer/application is un-recognized or un-trusted. Please ignore this message and proceed with running the installer/application. We need to acquire a code signing certificate so that we can sign the installers letting the operating system know that these files can be trusted. It will take a week or more to acquire one, so please hold tight.

      Other notable changes to the TRiBot Loader:

      Support getting the version from OpenJDK distributions


      Add check for bundled JDK


      Copy OpenJDK tools.jar to the bundled JDK if not present


      Set the current java as the first available list entry


      Ignore Java versions which are symbolic links


      Make the bundled JDK the preferred Java version


      Update icon images


      Reduce the number of HTTP calls
        • Thanks
        • Like
      • 32 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 18 replies
    • Hello TRiBot,

      Today we have a significant release that has been in the works for the last month addressing several key issues, features and bugs in the backlog.

      With these changes, we are also including a new TRiBot Loader which will allow you to select any version that is released. This adds the flexibility of allowing you to revert to a previous version should an issue arise, run development only builds, view an accurate change log between versions etc. we are very proud to offer this feature and think it will add a lot more functionality down the road as we continue to release new versions.

      These changes include 80+ commits by our development team, a list of them is summarized below and also available for your viewing pleasure in the new TRiBot Loader.

      In addition, we have taken additional steps to improve as a development team by adding continuous integration and deployment into our workflow to assist in delivering timely releases such as bug fixes as well as new features on a weekly basis depending on our development cycle.
        • Thanks
        • Like
      • 39 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...