Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Aropupu

[ABCL 10] [ABC2] aMiner v2 [ MOTHERLODE / BANKING / POWERMINING / WORLDHOPPING ]

Recommended Posts

Not sure whats going on, I can't get it to mine iron rocks at varrock east.

 

  • [11:15:14] Downloading script 'aMiner v2 [PREMIUM]'.
  • [11:15:16] Script Started: aMiner v2 [PREMIUM].
  • [11:15:16] NEW UPDATES: Added requested Zeah saltpetre digging
  • [11:15:16] CURRENTLY WORKING ON: Some requested new locations and Autoleveling
  • [11:16:08] Generating script antiban profile...
  • [11:16:09] Antiban profile successfully generated!
  • [11:16:09] Current pickaxe is Steel pickaxe

 

Just sits there until it hits the 5 minute mark of no xp gain and logs itself out. I tried the regular varrock east/iron rocks/mouse key drop and I also tried custom rocks in the same spot, with the same result. 

Share this post


Link to post
Share on other sites
Array
1 hour ago, gavin101 said:

Not sure whats going on, I can't get it to mine iron rocks at varrock east.

 

  • [11:15:14] Downloading script 'aMiner v2 [PREMIUM]'.
  • [11:15:16] Script Started: aMiner v2 [PREMIUM].
  • [11:15:16] NEW UPDATES: Added requested Zeah saltpetre digging
  • [11:15:16] CURRENTLY WORKING ON: Some requested new locations and Autoleveling
  • [11:16:08] Generating script antiban profile...
  • [11:16:09] Antiban profile successfully generated!
  • [11:16:09] Current pickaxe is Steel pickaxe

 

Just sits there until it hits the 5 minute mark of no xp gain and logs itself out. I tried the regular varrock east/iron rocks/mouse key drop and I also tried custom rocks in the same spot, with the same result. 

If the script is not mining at all, it's usually a Tribot hook issue. Have you tried the steps in  Are you having problems with the script? in the main post of this thread?

Share this post


Link to post
Share on other sites

[15:18:11] Starting client.
[15:19:27] Downloading script 'aMiner v2 [PREMIUM]'.
[15:19:31] Script Started: aMiner v2 [PREMIUM].
[15:19:31] NEW UPDATES: Added requested Zeah saltpetre digging
[15:19:31] CURRENTLY WORKING ON: Some requested new locations and Autoleveling
[15:19:43] Generating script antiban profile...
[15:19:45] Antiban profile successfully generated!
[15:19:46] Current pickaxe is Dragon pickaxe
[15:20:13] Script Ended: aMiner v2 [PREMIUM].
[15:20:54] Downloading script 'aMiner v2 [PREMIUM]'.
[15:20:57] Script Started: aMiner v2 [PREMIUM].
[15:20:57] NEW UPDATES: Added requested Zeah saltpetre digging
[15:20:57] CURRENTLY WORKING ON: Some requested new locations and Autoleveling
[15:20:58] Generating script antiban profile...
[15:21:00] Antiban profile successfully generated!
[15:21:00] Current pickaxe is Dragon pickaxe
[15:21:38] Script Stack Trace:
[15:21:38]  java.lang.Thread.sleep(Native Method)
[15:21:38]  obf.iC.Od(cd:31)
[15:21:38]  org.tribot.api.General.sleep(at:89)
[15:21:38]  scripts.aMinerNEW.qc.F(Antiban.java:48)
[15:21:38]  scripts.aMinerNEW.a.F(WalkingMethods.java:104)
[15:21:38]  scripts.aMinerNEW.j.d(Motherlode.java:341)
[15:21:38]  scripts.aMinerNEW.j.a(Motherlode.java:119)
[15:21:38]  scripts.aMinerNEW.Main.E(Main.java:219)
[15:21:38]  scripts.aMinerNEW.Main.run(Main.java:134)
[15:21:38]  java.lang.Thread.run(Unknown Source)

 

Bot was working great yesterday but after update this morning it seems to get stuck at the collect ore sack. Well its actually never gets started it just goes to fix the mils then collect ore even though it hasn't started mining yet. I tried multiple times starting it in different areas and changing the settings.. 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, ghosty1919 said:

[15:18:11] Starting client.
[15:19:27] Downloading script 'aMiner v2 [PREMIUM]'.
[15:19:31] Script Started: aMiner v2 [PREMIUM].
[15:19:31] NEW UPDATES: Added requested Zeah saltpetre digging
[15:19:31] CURRENTLY WORKING ON: Some requested new locations and Autoleveling
[15:19:43] Generating script antiban profile...
[15:19:45] Antiban profile successfully generated!
[15:19:46] Current pickaxe is Dragon pickaxe
[15:20:13] Script Ended: aMiner v2 [PREMIUM].
[15:20:54] Downloading script 'aMiner v2 [PREMIUM]'.
[15:20:57] Script Started: aMiner v2 [PREMIUM].
[15:20:57] NEW UPDATES: Added requested Zeah saltpetre digging
[15:20:57] CURRENTLY WORKING ON: Some requested new locations and Autoleveling
[15:20:58] Generating script antiban profile...
[15:21:00] Antiban profile successfully generated!
[15:21:00] Current pickaxe is Dragon pickaxe
[15:21:38] Script Stack Trace:
[15:21:38]  java.lang.Thread.sleep(Native Method)
[15:21:38]  obf.iC.Od(cd:31)
[15:21:38]  org.tribot.api.General.sleep(at:89)
[15:21:38]  scripts.aMinerNEW.qc.F(Antiban.java:48)
[15:21:38]  scripts.aMinerNEW.a.F(WalkingMethods.java:104)
[15:21:38]  scripts.aMinerNEW.j.d(Motherlode.java:341)
[15:21:38]  scripts.aMinerNEW.j.a(Motherlode.java:119)
[15:21:38]  scripts.aMinerNEW.Main.E(Main.java:219)
[15:21:38]  scripts.aMinerNEW.Main.run(Main.java:134)
[15:21:38]  java.lang.Thread.run(Unknown Source)

 

Bot was working great yesterday but after update this morning it seems to get stuck at the collect ore sack. Well its actually never gets started it just goes to fix the mils then collect ore even though it hasn't started mining yet. I tried multiple times starting it in different areas and changing the settings.. 

Yes I'm getting this as well

Share this post


Link to post
Share on other sites
Just now, ghosty1919 said:

Bot was working great yesterday but after update this morning it seems to get stuck at the collect ore sack. Well its actually never gets started it just goes to fix the mils then collect ore even though it hasn't started mining yet. I tried multiple times starting it in different areas and changing the settings.. 

Problems like these are usually caused by broken hooks. 

You should try the following to fix any hook issues:
- Simply restarting your Tribot client can sometimes help too. Close all windows of Tribot and then restart it.
- If you are using LG with OSBuddy, try it with a normal browser instead.
- Make sure you have "Restart client on update" DISABLED in Tribot's settings. If it's enabled, it will cause problems after Runescape updates.
 
You can do the following all in one before restarting your client:
- Try clicking on File ---> Delete Cached Clients and restart your Tribot client.
- (You can skip this step if you decide to do the next one) Please try deleting hooks.dat and/or general.ini files from your .tribot folder. After this restart your Tribot. (close all windows)
- If removing hooks.dat/general.ini didn't work. Try reinstalling Tribot by deleting your .tribot folder and then restarting Tribot. Will reset your Tribot settings, consider doing a backup.

Share this post


Link to post
Share on other sites
On 2016-07-22 at 9:30 PM, Aropupu said:

Problems like these are usually caused by broken hooks. 

You should try the following to fix any hook issues:
- Simply restarting your Tribot client can sometimes help too. Close all windows of Tribot and then restart it.
- If you are using LG with OSBuddy, try it with a normal browser instead.
- Make sure you have "Restart client on update" DISABLED in Tribot's settings. If it's enabled, it will cause problems after Runescape updates.
 
You can do the following all in one before restarting your client:
- Try clicking on File ---> Delete Cached Clients and restart your Tribot client.
- (You can skip this step if you decide to do the next one) Please try deleting hooks.dat and/or general.ini files from your .tribot folder. After this restart your Tribot. (close all windows)
- If removing hooks.dat/general.ini didn't work. Try reinstalling Tribot by deleting your .tribot folder and then restarting Tribot. Will reset your Tribot settings, consider doing a backup.

i just purchased this script, must i run it with clint update on disabled? or is it updated? 

Share this post


Link to post
Share on other sites
19 hours ago, SnaDouble C said:

i just purchased this script, must i run it with clint update on disabled? or is it updated? 

It doesn't matter what you have as the setting. It will only cause problems if you have it enabled when a Runescape update happens because your client hooks will get outdated and it will mess everything up.

Share this post


Link to post
Share on other sites
6 hours ago, smurfs14 said:

hey @Aropupu, i've noticed when you have a " set a certain lvl " enabled with the d axe special, it will log out when it activates the special because the bot thinks it has got the mining level when infact it was just boosted because of the special attack.

Will fix this tomorrow.

2 hours ago, Phat Shock said:

Where do we get the script arguments?

Quote

- the ability to start the script without a GUI (using "last" argument)
 > You can also write your setting profile name in the script arguments to start it without a GUI and with that profile.

 

Share this post


Link to post
Share on other sites

Currently running the script and it seems to be working fine, although the log is going crazy.
 

[01:10:50] 	at org.tribot.api2007.types.RSCharacter.isInCombat(so:528)
[01:10:50] 	at obf.qe.DE(dj:132)
[01:10:50] 	at obf.ug.ce(pi:216)
[01:10:50] 	at obf.ug.Df(pi:318)
[01:10:50] 	at obf.ug.run(pi:314)
[01:10:50] 	at java.lang.Thread.run(Thread.java:745)
[01:10:51] java.lang.ClassCastException: obf.on cannot be cast to java.lang.Iterable
[01:10:51] 	at org.tribot.api2007.types.RSCharacter.uo(so:429)
[01:10:51] 	at org.tribot.api2007.types.RSCharacter.isInCombat(so:528)
[01:10:51] 	at obf.qe.DE(dj:132)
[01:10:51] 	at obf.ug.ce(pi:216)
[01:10:51] 	at obf.ug.Df(pi:318)
[01:10:51] 	at obf.ug.run(pi:314)
[01:10:51] 	at java.lang.Thread.run(Thread.java:745)
[01:10:52] java.lang.ClassCastException: obf.on cannot be cast to java.lang.Iterable
[01:10:52] 	at org.tribot.api2007.types.RSCharacter.uo(so:429)
[01:10:52] 	at org.tribot.api2007.types.RSCharacter.isInCombat(so:528)
[01:10:52] 	at obf.qe.DE(dj:132)
[01:10:52] 	at obf.ug.ce(pi:216)
[01:10:52] 	at obf.ug.Df(pi:318)
[01:10:52] 	at obf.ug.run(pi:314)
[01:10:52] 	at java.lang.Thread.run(Thread.java:745)
[01:10:53] java.lang.ClassCastException: obf.on cannot be cast to java.lang.Iterable
[01:10:53] 	at org.tribot.api2007.types.RSCharacter.uo(so:429)
[01:10:53] 	at org.tribot.api2007.types.RSCharacter.isInCombat(so:528)
[01:10:53] 	at obf.qe.DE(dj:132)
[01:10:53] 	at obf.ug.ce(pi:216)
Edited by KyyL

Share this post


Link to post
Share on other sites
13 hours ago, KyyL said:

Currently running the script and it seems to be working fine, although the log is going crazy.
 

[01:10:51] java.lang.ClassCastException: obf.on cannot be cast to java.lang.Iterable
[01:10:51] 	at org.tribot.api2007.types.RSCharacter.uo(so:429)
[01:10:51] 	at org.tribot.api2007.types.RSCharacter.isInCombat(so:528)
[01:10:51] 	at obf.qe.DE(dj:132)
[01:10:51] 	at obf.ug.ce(pi:216)
[01:10:51] 	at obf.ug.Df(pi:318)
[01:10:51] 	at obf.ug.run(pi:314)
[01:10:51] 	at java.lang.Thread.run(Thread.java:745)

 

This is a Looking Glass error. Hopefully will be fixed soon by Trilez.

If the script works fine even though it prints out errors, there most likely is no need to worry about it.
If it doesn't, you should wait until it's fixed or use the normal client instead.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, daoudwis said:

@Aropupu I am interested in buying premium. just one question, I see that you have afk antiban as a setting available. does this mean that you do not use ABC2 reaction times? 

No, AFK mode is an extension which you can use to get longer afk times for example. ABC2 delays are still there and you can customize them a bit or leave them as they are.

Share this post


Link to post
Share on other sites

Update:

I have now released a test version of progressive mode (= autoleveling mode). This feature is in BETA and should only be used if you want to test it. There can be some issues with some parts of the feature. I will also be testing the feature a lot in the next few days.

- You can add locations to queue and choose when you want it to stop mining at those locations. Available stop conditions are: level, time and ore amount.
  > You can also add a location to the end of the queue that the script will mine at infinitely.
  > The queue will skip locations if stop condition is already reached. So you can make a queue and it will skip locations for levels that you have already reached.
- Currently only supports one custom location but there are plans to add profile support which will allow you to use unlimited custom locations.
- All locations should support their own custom settings that you can save in the custom tab of the script.

If you have any suggestions to make the feature better, please let me know. Bug reports are also welcome.

Edited by Aropupu
  • Like 1

Share this post


Link to post
Share on other sites
42 minutes ago, badkarma said:

Could you check the MLM portion please? It runs to the edge of the map and tries to click outside of the MLM. Been like this for abut a week with me. Thanks!

I had this problem. Make sure you change the location tab to motherload mine. If it is set to another location, it will constantly click trying to webwalk to that area 

  • Like 1

Share this post


Link to post
Share on other sites
On 8/9/2016 at 6:36 PM, jazlinmtf said:

how do you bot mining without getting banned?? epecially running for more than 77h non stop i keep getting banned after like 24 hours.

my signature can help you attain your goldfarm goals!

 

On 8/9/2016 at 9:17 PM, WYD said:

Use LG mate

ew no way not for goldfarming!

Edited by Yuhan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...