Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Deluxes

Registered
  • Content Count

    1,059
  • Joined

  • Last visited

  • Days Won

    19
  • Feedback

    100%

Everything posted by Deluxes

  1. Main feature doesn't work 4 stars btw.
  2. Wow you actually finally decided to do something useful.
  3. Sorry but that makes too much sense.
  4. If you actually followed tutorials you would already know you don't export the shit to a jar lol..
  5. why would you need a second thread for a fucking timer lmao
  6. If statement for dev can be changed to ternary within the x/y declaration.
  7. retard scripters shouldn't have offered lifetime in the first place i agree.
  8. Pretty sure your stuff must be packaged in scripts. So your antiban stuff should be in scripts.api.Antiban for example.
  9. Methods that return booleans and do nothing else follow is/has/can/should prefixes. Example ArrayList#isEmpty vs ArrayList#remove. isEmpty just returns if its empty or not, while remove does an action inside of the method. https://wiki.eclipse.org/Recommenders/CodingConventions
  10. Naming conventions and brace placements/lack of in some places are cancer. More so just a walk through of how you when about doing your script than an actual scripting tutorial.
  11. Yea its my private api, maybe ill release it some time as I don't really do any tribot shit anymore.
  12. I made that because they don't have a useful cmd support. May or may not work anymore tho.
  13. Not sure why your "aHelper" class is included if it's not used at all. Code is pretty low quality as well. Just looking through aHelper, canAlch() will recursively call itself forever if you are able to alch so thats not even going to work. Shit like food should be put into an array or something so it doesn't take 500 lines just to determine what food to eat, let alone calling getDefinition() 500 times instead of caching the data into a variable.
  14. TreeInfo.java whats the point of setting a levelRequired variable if you aren't going to use it. Something like this is would make more sense. At least add some useful shit like upgrading axes from the bank, etc if your going to go for scripter u retard public static TreeInfo getCurrentTreeInfo() { int level = Skills.SKILLS.WOODCUTTING.getActualLevel(); TreeInfo current = null; for (TreeInfo info : TreeInfo.values()) { if (level >= info.levelRequired) { current = info; } } return current; } public static String getTreeName() { TreeInfo info = getCurrentTreeInfo(); return info.treeName; }
  15. ur right the cmd argument starter is impeccable and the insane amounts of innovation in the past 2 years is crazy
  16. A real update not hook fixes, that an actual fucking surprise.
×
×
  • Create New...